Dreambox 800 SE HD + OpenVPN

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Dreambox 800 SE HD + OpenVPN

      Hi,

      ich habe seit Tagen versucht das hin zu bekommen, aber leider ohne Erfolg...... Habe im Netz diverse Anleitungen bzw. Infos und Tipps dazu gelesen aber es will nicht funktionieren. Jetzt hoffe ich auf eurer Hilfe.

      Ich habe folgendes: Dreambox 800 SE HD (hängt direkt an meinem Router) + newnigma2_stable_lean_dm800se_v4.0.9 + OpenVPN (zusätzleich installiert und unter Werkzeuge zu finden) und ein VPN-Dienst Premium Plus ( bis 5 Geräte ) bei CyberGhost.
      Ziel: Ich möchte mit meiner Dreambox den Dienst von CyberGhost (z.B. über ein Server im Ausland) nutzen da ich ja bis zu 5 Geräte nutzen kann und bereits zwei Geräte (PC und Notebook) installiert habe. Die Dreambox soll das dritte Gerät sein, ich nehme an sie wäre dann ein "Client".

      Das habe ich bis jetzt gemacht:
      - Die Datei "cyberghostvpn.ovpn" von CyberGhost heruntergeladen und so (unverändert) ins Ordner /etc/openvpn der Dreambox geschoben. Dem File die Rechte 755 erteilt.
      - Nach einer Anleitung die Dateien: ca.crt, cert.crt und key.key erstellt und ebenfalls in den Ordner /etc/openvpn der Dreambox geschoben. Auch diese drei Dateien die Rechte 755 vergeben.
      - Die Datei "password.txt" mit den Zugangsdaten von CyberGhost erstellt, erste Zeile den Benutzername, zweite Zeile das Passwort. Ebenfalls in den Ordner /etc/openvpn geschoben. Auch hier die Rechte auf 755 gesetzt.
      - Eine Datei zwecks die Abfrage über Telnet mit welcher IP die Dreambox "unterwegs" ist. Die Datei nennt sich "ip.py" und wird ebenfalls mit Telnet gestartet.

      Jetzt habe ich das OpenVPN-Plugin gestartet (habe auch auf Ja mit der Fernbedienung durch Taste OK bestätigt).

      Ich starte die Dreambox komplett NEU und frage die IP durch diese Datei "ip.py" gestartet durch Telnet ab. Leider wird mit die "echte" IP meines Provider und nicht irgend eine andere aus der vielfalt von Server bei CyberGhost angezeigt.

      Frage: Was mache ich falsch? Muß ich in den Einstellung beim Plugin OpenVPN weitere Einstellungen vornehmen? Wenn ja, wo und was ?!!??

      Ich hoffe das verständlich genug dargestellt zu haben. Vielen Dank für jede Hilfe die mich weiter bringt.
    • lackschuh schrieb:

      Verbind dich mal per Telnet mit der Box und dann:

      Quellcode

      1. openvpn --config /etc/openvpn/cyberghostvpn.ovpn &


      Wenn dies fehlerfrei funktioniert, dann können wir über den Autostart reden ;D


      Hallo lackschuh, ich habe die o.g. Befehl eingegeben und ausgeführt. Das ist das Ergebnis (mußte ich abschneiden da das zu lang ist um es hier posten zu können):

      ------------------------------------------------------
      [1] 32685
      root@dm800se:~# Wed Apr 23 21:26:29 2014 us=457429 Current Parameter Settings:
      Wed Apr 23 21:26:29 2014 us=458386 config = '/etc/openvpn/cyberghostvpn.ovpn'

      Wed Apr 23 21:26:29 2014 us=468162 persist_local_ip = DISABLED
      .
      .
      .
      .
      .

      Wed Apr 23 21:26:29 2014 us=497228 port_share_host = '[UNDEF]'
      Wed Apr 23 21:26:29 2014 us=497370 port_share_port = 0
      Wed Apr 23 21:26:29 2014 us=497512 client = ENABLED
      Wed Apr 23 21:26:29 2014 us=497697 pull = ENABLED
      Wed Apr 23 21:26:29 2014 us=497843 auth_user_pass_file = 'stdin'
      Wed Apr 23 21:26:29 2014 us=498182 OpenVPN 2.3.2 mipsel-oe-linux-gnu [SSL (OpenS
      SL)] [LZO] [EPOLL] [eurephia] [MH] [IPv6] built on Jan 7 2014
      Enter Auth Username:
      ----------------------------------------------------

      Vielen Dank für deine Hilfe.
    • Öffne mal mit einem Editor die cyberghostvpn.ovpn Datei und dann ändere folgendes (also den Pfad anpassen):

      ca /etc/openvpn/ca.crt
      cert /etc/openvpn/dein_cert
      key /etc/openvpn/key.key

      auth-user-pass /etc/openvpn/password.txt

      In der password.txt muss der Username und das PW untereinander stehen also so:

      Quellcode

      1. username
      2. password
    • Servus!

      Die Zertifikate brauchst Du nicht raus kopieren
      Die ovpn anpassen

      Quellcode

      1. auth-user-pass /etc/openvpn/password.txt

      Wie schon geschrieben die password.txt anlegen.
      Die ovpn in CyberGhost.conf umbennen und Dateirechte 755
      Dann Telnet

      Quellcode

      1. cd /var/etc
      2. mkdir rcS.d
      3. ln -s /var/etc/init.d/openvpn /var/etc/rcS.d/S80openvpn.sh

      Danach reboot
      Manchmal muß man auch zweimal reboot machen.

      Überprüfen kannst Du das mit dem Script oder im Webbrowser

      Gruß regenwaldzwerg
      Realität ist eine Illusion die durch Biermangel hervorgerufen wird!
    • VIELEN DANK!

      An euch beiden regenwaldzwerg und lackschuh! Die "geänderte" Version von regenwaldzwerg hat am ende funktioniert. Super den Hinweis mit der TXT.-Datei wo die Zugangsdaten eingetragen werden und wo die Datei (in cyberghostvpn.ovpn) dann verlinkt wird durch die Eingabe des Pfades.

      Die Dreambox verbindet sich jetzt mit irgend einen Server von CyberGhost und ist dann mit der entsprechende IP unterwegs.
    • CyberGhost hat Ihren Sitz in Rumänien

      Quellcode

      1. Impressum
      2. CyberGhost S.R.L.
      3. Strada Baratiei Nr. 35, Et 4, Sector 3
      4. 030197 Bucharest
      5. Romania
      6. E-Mail: office@cyberghost.ro (kein Support)
      7. Handelsregister-Nr.: J40/1278/2011
      8. UDI/VAT ID: RO28003392
      9. Registriertes Kapitel: 1.000 RON
      10. Supportkontakt:
      11. E-Mail: support@cyberghost.ro
      Alles anzeigen
      Realität ist eine Illusion die durch Biermangel hervorgerufen wird!
    • hallo

      bin nach der anleitung vorgegangen und bei mir läufts nicht

      oozoon, dreambox 8000, anbieter CyberGhost, könnte hier jemand eine openvpn ipk anhängen und ein start scrip


      rest müsste ich ja noch hinbekommen man o man ich dreh echt am rad

      danke
    • hallo an alle
      da ich neü in diesen gebiet bin mit vpn wollte gern meine vusolo se mitnehmen nach china habe con hide vpn gekauft
      kann kemand mir helfen mit der config bitte sei echt frph wenn es klappt da in china bekannt ist das die vieles blockiert ist
      danke an eüch alle

      das habe ich in den

      openvpnvti.config

      ####### Sample config OpenVPN Client (Linux)########
      #port 1194 #LISTEN PORT default 1194
      #remote XXX.XXX.XXX.XXX #SERVER IP OR URL
      #proto udp #OPENVPN PROTOCOL
      #dev tap
      #tls-client
      #ns-cert-type server
      #tun-mtu 1500
      #tun-mtu-extra 32
      #ca /etc/openvpn/ca.crt
      #cert /etc/openvpn/client.crt
      #key /etc/openvpn/client.key
      auth-user-pass /etc/openvpn/password.txt
      #comp-lzo
      #float
      #pull



      ####### Sample config OpenVPN Server (Linux)########
      #port 1194 #LISTEN PORT default 1194
      #mode server
      #proto udp #OPENVPN PROTOCOL
      #dev tap0
      #server-bridge XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX #StartIP Subnetmask EndIP
      #client-to-client
      #tls-server
      #ca /etc/openvpn/ca.crt
      #dh /etc/openvpn/dh1024.pem
      #cert /etc/openvpn/server.crt
      #key /etc/openvpn/server.key
      #comp-lzo
      #push "route-gateway XXX.XXX.XXX.XXX" #IP OpenVPN Server
      #push "route XXX.XXX.XXX.0 XXX.XXX.XXX.0" IP Network Subnetmask
      #tun-mtu 1500
      #tun-mtu-extra 32
      #float
      #keepalive 15 60
      #ping-timer-rem
      #persist-key
      #persist-tun
      #push "ping 10"
      #push "ping-restart 60"
      #push "ping-timer-rem"
    • Stefan1166 schrieb:

      Hab seit gestern auch OpenVpn drauf funkioniert auch 1A nur beim Booten bekomm ich einen schwarzen Bildschirm mit den drehenden Zahnrädern dauert dan ca 2-5 Minuten dann läuft alles normal.
      Speichert Openvpn irgendwo logs?
      Hab jetzt mal Putty Seriel mitloggen lassen

      Quellcode

      1. [ 19.594081] set current avs auto aspect to 16:9
      2. [ 19.594640] set sb to 3(1)
      3. [ 21.079727] 2854 ms: 56
      4. [ 21.087812] 8 ms: 69
      5. [ 146.352045] change audioenc bitrate to 96000 bits/s
      6. [ 146.355967] vice0: change videoenc bitrate to 1500000 bits/s
      7. [ 146.373733] vice0: change h264 level to 3.1


      Irgendetwas lässt die Box 125sekunden Warten
      Openvpn startet nach log in 1ner sekunde ?(