Yamp Music Player - "gepimpte" Version auch für FHD - neue Version 3.2.2 vom 26.10.2017 - Korrektur FHD-SKins OE2.5 18.12.2017

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Das ist allerdings ein seltsamer Crash, weil versucht wird etwas zu übergeben was noch gar nicht definiert ist, kann aber auch sein das es weil nicht static einfach gelöscht wurde.

      Und ich finde die Einstellung die manch andere haben ... 'ich Teste gerne aber es sollte dafür schon fehlerlos sein' ... echt toll ....
      Bad mood, bad manners, bad Plugins, you have been warned :whistling:
    • gutemine schrieb:

      Das ist allerdings ein seltsamer Crash, weil versucht wird etwas zu übergeben was noch gar nicht definiert ist, kann aber auch sein das es weil nicht static einfach gelöscht wurde.

      Und ich finde die Einstellung die manch andere haben ... 'ich Teste gerne aber es sollte dafür schon fehlerlos sein' ... echt toll ....


      Und wem genau unterstellst Du das nochmal?
      "Alle sagen: Es geht nicht!
      Bis einer kommt, der es nicht wusste
      und es einfach gemacht hat!"
    • Falls es dir schon aufgefallen ist sind wir hier im Thread ziemlich einsam ... und glaub mir ich habe mir schon praktisch ALLE Entschuldigungen anhören müssen ...

      Vielleicht bin ich einfach schon ein bisschen zu dessillusioniert um noch weiterhin einfach nur lieb und nett für andere zu arbeiten ...

      Nehmt das nicht alles persönlich, manchmal ist das auch nur dazu da um überhaupt eine Reaktion zu kriegen ... schliesslich hast du ja auch eher wegen der Provokation als wegen dem schönen Plugin begonnen zu antworten ... nachdem du erfahren hast das es kein fertiges deb gibt ...
      Bad mood, bad manners, bad Plugins, you have been warned :whistling:
    • gutemine schrieb:

      weil versucht wird etwas zu übergeben was noch gar nicht definiert ist, kann aber auch sein das es weil nicht static einfach gelöscht wurde.

      Hi, habe mal als Schuss ins Blaue einen self.currDblist = [ ] in den init gesetzt; im OE2.0 störts zumindest nicht. Kann es sein, dass OE2.2 da rigoroser ist als OE2.0?
      Hab das an DerManuel mal zum Testen als PM geschickt, weils ja wirklich nur ein Schuss ins Blaue ist...
      Yamp - gepimte Version auch für FHD - aktuelle Version V3.2.2 hier
    • @DerManuel: Hast Post. Sieht aus, als ob der Schuss ins Blaue geholfen hat.
      @funsoft: Nein; hab auch keine Ahnung, wie das gehen könnte. Und obs sinnvoll ist, ist die andere Frage. Das Konzept (schon in der alten Version) war ja grade, die Bedienung vom Sessel aus möglichst einfach und intuitiv zu gestalten.
      Yamp - gepimte Version auch für FHD - aktuelle Version V3.2.2 hier
    • Anbei der nächste Crashlog.
      Beim Aufrufen des Datenbankmodus über die rote Taste.
      Habe den Crashlog gekürzt.
      Reicht Euch das?
      Dateien
      • crashlog3.txt

        (722 Byte, 110 mal heruntergeladen, zuletzt: )
      "Alle sagen: Es geht nicht!
      Bis einer kommt, der es nicht wusste
      und es einfach gemacht hat!"
    • Guten morgen, Ihr Fleißigen!

      wir sind mindestens einen Schritt weiter. Wechsle ich über rot in die Datenbank, ist diese zwar leer, aber der Player stürzt nicht mehr ab. Das macht er dann, wenn ich versehentlich grün drücke, wenn ich mich in der Datenbank befinde.
      Anbei das nächste Crashlog.



      Leider ist die Beschriftung der vier bunten Tasten für meinen Skin zu groß, deshalb kann ich nicht alle Beschriftungen lesen und muß per Trial herausfinden, welche Funktionen dort hinterlegt sind.

      LG

      Manuel
      Dateien
      • crashlog4.txt

        (1,48 kB, 121 mal heruntergeladen, zuletzt: )
      "Alle sagen: Es geht nicht!
      Bis einer kommt, der es nicht wusste
      und es einfach gemacht hat!"
    • Nächste Hürde:

      Lege ich mein Playlist Speicherverzeichnis ins Netz, schlägt das Speichern der Listen fehl. Lokal Speichern kein Problem. Wiedergeben der Musik vom NAS funzt. Ansonsten kann ich problemlos FIlme zum Beispiel auf der Freigabe speichern.

      Berechtigungen auf Musik 755, auf Filme und Bilder 555.
      "Alle sagen: Es geht nicht!
      Bis einer kommt, der es nicht wusste
      und es einfach gemacht hat!"
    • Moin,
      zu dem neuen Crash hab ich im Moment keine Erklärung; wie sich mit den letzten Crashs ja schon rausgestellt hat, ist OE2.2 offensichtlich viel rigoroser, was die Initialisierung von irgendwelchen Objekten angeht. Aber das "self.dblist.getSelection().nav", was angemeckert wird, wird vorher initialisiert. Muss mir was überlegen, vielleicht ein Workaround.... Komme aber die nächsten paar Stunden erstmal nicht dazu.

      Hast du überhaupt schon was in die Datenbank übertragen? Wäre mal einen Versuch wert..

      Zum Speichern auf NAS: Funktioniert bei mir problemlos, hab ich grade getestet. Meine aber, das ist erstmal sekundär..... Wichtiger ist, dass es überhaupt mal ohne GS läuft.

      Zur Schriftgrösse: Wird Yamp (die alte Version) vielleicht in deinem alten Skin schon "bearbeitet"? Falls ja, schau mal im VU-Board nach, da gibts von den Skin-Spezialisten ein paar Anmerkungen dazu (so um Beitrag 911). Falls nein, ist bei deinem Skin vielleicht eine Skalierung > 100 eingestellt, dann hilft nur, die Fontgrösse in der Yamp.xml anzupassen (ganz unten key_red bis key_blue).

      Ansonsten werden zumindest die Grundfunktionen der Farbtasten auch in der Original-Anleitung von JohnHenry beschrieben - was zugegebenermassen etwas mühsamer ist.

      Und danke fürs Testen! Ist schon mühsam auf die Art, aber die OE2.0 und OE2.2 verhalten sich halt offensichtlich doch recht unterschiedlich.
      Grüsse Alfred
      Yamp - gepimte Version auch für FHD - aktuelle Version V3.2.2 hier

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von AlfredENeumann ()

    • Ist nicht wirklich ein großes Problem, weder das mit dem NAS Speichern noch mit dem Greenscreen beim Drücken einer nicht belegten Taste. Dennoch wollte ich es für weitere Entwicklungen nicht vorenthalten.

      Nach der Font Size schaue ich dann mal!

      Jedenfalls lief es den ganzen Morgen problemlos! Schon mal super!

      Und es soll sich auch niemand gehetzt fühlen. Komme manchmal selbst tagelang zu nichts. :D :D
      "Alle sagen: Es geht nicht!
      Bis einer kommt, der es nicht wusste
      und es einfach gemacht hat!"
    • Über die rote Taste kann ich wohl die Datenbankenübersicht aufrufen, beim Anlegen einer Datenbank durch Drücken der gelben Taste (wie ich nur vermuten kann), kommt dann doch der ungeliebte Greenscreen! Ich hatte aber noch nicht die Zeit, miene Schriftgröße für den YAMP zu editieren.
      "Alle sagen: Es geht nicht!
      Bis einer kommt, der es nicht wusste
      und es einfach gemacht hat!"
    • Dank der Tests von DerManuel sind nun mittlerweile einige Gründe für die GS bei der OE2.2-Version behoben - vor allem noch nicht ausgeführte Portierungen. Im Eingangspost gibt es jetzt eine aktualisierte deb, die auf der von gutemine aufbaut.
      Allerdings: Die deb habe ich nach Anleitung von gutemine erstellt, so gut ich konnte. Ich kanns aber wie immer nicht testen. Deshalb - falls es sich gar nicht installieren lässt - noch die geänderten Dateien als Yamp-deb-Änderungen-2016-02-23.zip. Die müssten dann eben - falls die deb nicht funzt - manuell nachinstalliert werden.
      Und immer noch: Erwartet nicht, dass es auf OE2.2 fehlerfrei läuft, wir kommen einfach langsam Schritt für Schritt weiter. Ist halt mühsam, wenn man selbst keine Box hat, auf der man testen kann.
      Auch hier: Bitte um Rückmeldungen, ob 1. die deb funktioniert (=sich installieren lässt) und 2. wo noch Fehler / GS auftreten - gern als PM, damit der Thread hier nicht so voll wird...
      Edit 20:25: Nach der Rückmeldung von gutemine deb nochmal entfernt. Bitte die deb von gutemine benutzen und dann mit den Dateien in der Änderungsdatei überschreiben.
      Neue deb im Eingangspost angehängt - bitte testen, ob die funktioniert....
      Yamp - gepimte Version auch für FHD - aktuelle Version V3.2.2 hier

      Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von AlfredENeumann ()

    • Nein das *.deb lässt sich nicht installieren, scheinbar verwendest du ein altes ipkg-build.

      Ich habe dir ein dpkg-build shellscript um auch auf einer OE 2.0 Box deb kits zu bauen angehangen.

      Einfach dpkg-build.txt auf dpkg-build umbenennen und mit chmod 755 dpkg-build auf der box ausführbar machen.

      Sonst verwendet man es genauso wie das ipkg-build script nur müssen control file und evt. die p* scripte in einem DEBIAN subdirectory sein statt in CONTROL.

      Und wenn du als architecture all verwendest und ein aktuelles ipkg-build script hast, dann kannst du aus dem selben kit build directory ein ipk und ein deb kit bauen.

      LG
      gutemine
      Dateien
      • dpkg-build.txt

        (3,61 kB, 193 mal heruntergeladen, zuletzt: )
      Bad mood, bad manners, bad Plugins, you have been warned :whistling:

      Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von gutemine ()