Dream8000 - Probleme mit interner HDD

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Fred Bogus Trumper wrote:

      wenn der SWAP aktiv ist, ist das ok, obwohl ich glaube, dass 130MB zu wenig sind

      mach mal folgendens: Deaktiviere den Medias/DNLA Server, Samba Server und NFS Server

      Source Code

      1. /etc/init.d/nfsserver stop
      2. /etc/network/if-down.d/01samba-kill


      dann die Platte aushängen, das muss ohne Fehlermeldung erfolgen - ausser sie war bereits ausgehängt!

      Source Code

      1. umount -fl /dev/sde1

      Wenn das geklappt hat, aktiviere zu Sicherheit ein 2. Swapfile auf CF (dauert eine Weile)j - es muss aber 512MB auf der CF frei sein

      Source Code

      1. dd if=/dev/zero of=/media/cf/temporary_swap bs=1M count=512
      2. mkswap /media/cf/temporary_swap
      3. swapon /media/cf/temporary_swap
      dann den Check anstossen, das wird ne Weile dauern ....


      Source Code

      1. fsck.ext3 -f -v -p /dev/sde1
      Umounten schlägt schon mal fehlt:

      Dreambox 7080 HD PVR mit WD40EURX AV-PG 4TB
      Dreambox 8000 HD PVR mit WD20EVDS Caviar AV-GP 2TB
      Dreambox 800 HD SE mit WD10TPVT Scorpio Blue 1TB
    • Fred Bogus Trumper wrote:

      umount -fl (klein F, klein L) eingegeben?

      sonst poste mal die Ausgabe von df -h

      Source Code

      1. df -h|tee /tmp/df-h.log
      2. mount|grep /dev/sde >> /tmp/df-h.log


      df-h.log hier hochladen, die screenshots sind furchtbar
      -fl war in Kleinbuchstaben eingegeben

      df-h.log



      Mal ne andere Frage: kann es sein, dass es an dem SATA-Kabel liegt? Die Festplatten-Kabel waren zwar alle richtig und fest angeschlossen, aber das SATA-Kabel ist so komisch verdreht angeschlossen. Vor ca. 2 Wochen hatte ich die Box auf, um Staub zu entfernen. Es kann sein, dass ich an dieses SATA-Kabel gestoßen bin, das jetzt gefühlte 6 Jahre so drinsteckt. Könnte es sein, dass ich dadurch einen teilweisen Kabelbruch verursacht habe??
      Dreambox 7080 HD PVR mit WD40EURX AV-PG 4TB
      Dreambox 8000 HD PVR mit WD20EVDS Caviar AV-GP 2TB
      Dreambox 800 HD SE mit WD10TPVT Scorpio Blue 1TB

      The post was edited 1 time, last by Philomathia ().

    • ja, daran könnte es auch liegen. Mit Verkabelung überprüfen meinte ich auch das SATA Kabel.

      Hast du auch wie beschrieben den DNLA Server deaktiviert (MENU - Einstellungen - System - Mediaserver) und den samba- und nfs-server gestoppt, falls die aktiv sind

      versuchs mal so:

      Source Code

      1. umount -fl /dev/disk/by-uuid/10eb31df-68b6-416d-bbbd-6acf1ac2c17a
      wenn das nicht klappt, greift noch etwas auf die Platte zu
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox
    • Fred Bogus Trumper wrote:

      ja, daran könnte es auch liegen. Mit Verkabelung überprüfen meinte ich auch das SATA Kabel.

      Hast du auch wie beschrieben den DNLA Server deaktiviert (MENU - Einstellungen - System - Mediaserver) und den samba- und nfs-server gestoppt, falls die aktiv sind

      versuchs mal so:

      Source Code

      1. umount -fl /dev/disk/by-uuid/10eb31df-68b6-416d-bbbd-6acf1ac2c17a
      wenn das nicht klappt, greift noch etwas auf die Platte zu
      Ich habe die obigen Befehle zum Abschalten der Server alle eingegeben. Allerdings ist es dann komisch, dass unter df-h dann auch die im Netzwerk freigegebenen Festplatten der anderen beiden Dreamboxen auftauchen, oder??

      Wie kriege ich die Server eigentlich hinterher wieder aktiviert ?(

      Die Kabel kann ich ja nur überprüfen, indem ich schaue, ob sie richtig sitzen. Ob es im Kabel gebrochene Drähte gibt, kann ich ja von außen nicht sehen.
      Aber da ich ohnehin umrüsten wollte und ein DVD-Laufwerk einbauen wollte, brauche ich ohnehin neue Kabel.

      Vielleicht kannst Du mich noch bzgl. SATA-Strom-Kabel beraten, um dann HDD und DVD-Laufwerk zusammen betreiben zu können. Da stehe ich gerade echt auf dem Schlauch, was ich da genau brauche, denn es ist ja nur 1 SATA-Anschluss auf dem Mainboard und 1 Stromanschluss am Netzteil vorhanden. Also brauche ich so ne Art Y-Kabel, oder?
      Und an den zwei anderen Enden brauche ich SATA/Strom in Kombination - wie heißt das denn genau?? Muss ich da bzgl. Dream 8000 noch irgendwas beachten??
      Für heute muss ich Schluss machen und danke Dir erst einmal bis hierhin herzlich für Dein Bemühen :blumen: :blumen:
      Dreambox 7080 HD PVR mit WD40EURX AV-PG 4TB
      Dreambox 8000 HD PVR mit WD20EVDS Caviar AV-GP 2TB
      Dreambox 800 HD SE mit WD10TPVT Scorpio Blue 1TB
    • Philomathia wrote:

      Allerdings ist es dann komisch, dass unter df-h dann auch die im Netzwerk freigegebenen Festplatten der anderen beiden Dreamboxen auftauchen, oder??
      Wie kriege ich die Server eigentlich hinterher wieder aktiviert ?(

      Das ist der Zugriff auf andere Platten im Netzwerk, wir müssen den Zugriff auf die Platte der Box stoppen. Das erreicht man durch das stoppen der Server aiuf der Box.
      Am einfachsten rebooten und den DNLA Server unter MENU - Einstellungen - System - Mediaserver wieder aktivieren.

      Zum Rest sage ich jetzt nicht allzuviel, weil das überhaupt nicht in diesen Threat passt.

      - ein Molex Y-Kabel für den 2. Strom Anschluss wird notwendig sein
      - wenn die Box einen SATA Anschluss hat, kannst du auch kein 2. SATA Device verbauen. (hat die 8k nicht auch zwei SATA Ports oder hängt das von der Revision ab? Dachte bei den älteren Boxen hängt der 2. SATA Anschluss am USB Controller)

      Tausch mal Strom und SATA Kabel zu der Platte die Macken macht. Dann mal nach dem Filesystem sehen was die Platte macht.
      Wenn das Netzteil schwächelt (könnte auch Ursache der Probleme sein) macht es nicht viel Sinn ein DVD-Laufwerk einzubauen - eins nach dem anderen
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox
    • Fred Bogus Trumper wrote:

      Philomathia wrote:

      Allerdings ist es dann komisch, dass unter df-h dann auch die im Netzwerk freigegebenen Festplatten der anderen beiden Dreamboxen auftauchen, oder??
      Wie kriege ich die Server eigentlich hinterher wieder aktiviert ?(
      Das ist der Zugriff auf andere Platten im Netzwerk, wir müssen den Zugriff auf die Platte der Box stoppen. Das erreicht man durch das stoppen der Server aiuf der Box.
      Am einfachsten rebooten und den DNLA Server unter MENU - Einstellungen - System - Mediaserver wieder aktivieren.

      Zum Rest sage ich jetzt nicht allzuviel, weil das überhaupt nicht in diesen Threat passt.

      - ein Molex Y-Kabel für den 2. Strom Anschluss wird notwendig sein
      - wenn die Box einen SATA Anschluss hat, kannst du auch kein 2. SATA Device verbauen. (hat die 8k nicht auch zwei SATA Ports oder hängt das von der Revision ab? Dachte bei den älteren Boxen hängt der 2. SATA Anschluss am USB Controller)

      Tausch mal Strom und SATA Kabel zu der Platte die Macken macht. Dann mal nach dem Filesystem sehen was die Platte macht.
      Wenn das Netzteil schwächelt (könnte auch Ursache der Probleme sein) macht es nicht viel Sinn ein DVD-Laufwerk einzubauen - eins nach dem anderen
      Moch mal ganz kurz zur Kabel- und DVD-Geschichte. Natürlich könnte ich jetzt die Kabel austauschen, indem ich das originale KIT dafür bestelle, denn ich habe so etwas nicht in der Schublade liegen. Gibt es bei ebay für EUR 30,- - für ein Kabelset, an das ich dann anschließend das bereits vorhandene DVD-Laufwerk nicht anschließen kann.

      Das Originale Kit hat einen kleinen 4-Pin-Stecker oder so etwas Ähnliches, das nach Bedienungsanleitung für den Anschluss des DVD-Laufwerkes gedacht ist. Ich habe aber ein SATA-Laufwerk, in das der Stecker definitiv nicht passt. Oder brauche ich dann dafür einen Adapter??
      Deshalb wäre mir recht, bevor ich Kabel kaufe, zu klären, welche Kabel ich für HDD plus DVD brauche.

      Ich kann keinen 2. SATA-Anschluss erkennen, in der Bedienungsanleitung wird der Einbau eines DVD-Slim-Laufwerkes beschrieben und da sind auch 2 SATA-Anschlüsse zu sehen. Scheint dann wohl eine anderer Rev. zu sein. Ich habe jetzt aber noch Photos vom Inneren gemacht, die ich morgen dann mal hochladen werde. Vielleicht hast Du eine Idee, wo der 2. SATA-Anschluss sitzen könnte.

      So jetzt muss ich aber endlich noch was arbeiten ;)
      Dreambox 7080 HD PVR mit WD40EURX AV-PG 4TB
      Dreambox 8000 HD PVR mit WD20EVDS Caviar AV-GP 2TB
      Dreambox 800 HD SE mit WD10TPVT Scorpio Blue 1TB
    • Rätsel gelöst!!
      Nachdem ich die Original-Verpackung der Dream8000 im Keller ausgegraben habe, konnte ich feststellen, dass ein SATA-Adapter mitgeliefert wurde, der an das DVD-Laufwerk angeschraubt wird. Das originale SATA-Kit der Festplatte kann so den benötigten Strom auch an das DVD-Laufwerk liefern.
      Doch ein Adapter, um den SATA-Anschluss an den USB-Anschluss des Mainboards anzuschließen, war nicht beigelegt.

      Letztlich haben weitere Recherchen ergeben, dass es 2 weitere SATA-Anschlüsse gibt, die allerdings zwischen Festplatte und dem Befestigungsrahmen des DVD-Laufwerkes liegen - so versteckt, dass ich die Anschlüsse nicht gesehen habe.

      Das originale SATA/Strom-Kit habe ich bestellt!

      Selbstverständlich werde ich jetzt nicht das DVD-Laufwerk einbauen, sondern erst das HDD-Problem zu lösen versuchen!!
      Dreambox 7080 HD PVR mit WD40EURX AV-PG 4TB
      Dreambox 8000 HD PVR mit WD20EVDS Caviar AV-GP 2TB
      Dreambox 800 HD SE mit WD10TPVT Scorpio Blue 1TB
    • testsoft wrote:

      Hast du deine Platte denn jetzt schon mal mit dem von mir empfohlenem Programm überprüft ?
      oette.wordpress.com/2015/10/17…laechenfehler-reparieren/
      Nein, dazu kam ich noch nicht.
      Neben den ganzen anderen Versuchen habe ich zwischenzeitlich noch versucht, so weit es überhaupt geht Aufnahmen von der Festplatte zu evakuieren, damit nicht alles verloren ist.

      Aber danke für den Link - der hilft mir sicherlich, das problemlos machen zu können :blumen:
      Dreambox 7080 HD PVR mit WD40EURX AV-PG 4TB
      Dreambox 8000 HD PVR mit WD20EVDS Caviar AV-GP 2TB
      Dreambox 800 HD SE mit WD10TPVT Scorpio Blue 1TB
    • griffel wrote:

      Wenn die Aufnahmen evakuiert sind, kannst du die Platte doch einfach mal neu initialisieren.
      Das Problem ist, dass nicht alle Aufnahmen angezeigt oder korrekt angezeigt werden.
      Statt des Blockes mit 6 Dateien finde ich z.B im DCC ein Torso aus mal cut, eit, ap, meta oder .ts Dateien. Wenn eine ts-Datei da ist, ziehe ich sie auf meinen Rechner. Scheiden kann ich sie schließlich auch da mit dem Ts-Doc.




      Und nach jedem Neustart der Box tauchen wieder andere Aufnahmen auf, dafür fehlen andere.

      Ich möchte halt soviel wie möglich retten und hoffe noch darauf, dass es am SATA-Kabel liegt - der neue Kabelsatz kommt in 2-3 Tagen. Dann wird man sehen.
      Dreambox 7080 HD PVR mit WD40EURX AV-PG 4TB
      Dreambox 8000 HD PVR mit WD20EVDS Caviar AV-GP 2TB
      Dreambox 800 HD SE mit WD10TPVT Scorpio Blue 1TB
    • Fred Bogus Trumper wrote:


      - wenn die Box einen SATA Anschluss hat, kannst du auch kein 2. SATA Device verbauen. (hat die 8k nicht auch zwei SATA Ports oder hängt das von der Revision ab? Dachte bei den älteren Boxen hängt der 2. SATA Anschluss am USB Controller)
      Also offenbar hängt das von der Revision ab - die 8000 gibt es offenbar mit 1 SATA und einem 2. SATA-Anschluss am USB-Controller, da liegt dann offenbar ein SATA-USB-Adapter bei. Dann gibt es sie noch mit 2 SATA-Anschlüssen, die direkt nebeneinander und gut sichtbar liegen, und in meinem Fall gibt es einen vereinzelnten SATA-Anschluss, in dem die HDD angeschlossen ist und 2 weitere zwischen Festplattenrahmen und DVD-Rahmen - nicht so leicht zu sehen.
      Dreambox 7080 HD PVR mit WD40EURX AV-PG 4TB
      Dreambox 8000 HD PVR mit WD20EVDS Caviar AV-GP 2TB
      Dreambox 800 HD SE mit WD10TPVT Scorpio Blue 1TB
    • Ok, neues Kabel-Kit ist heute gekommen - inzwischen eingebaut, aber wenn ich mir das ata.log anschaue, sehe ich da genauso oft ERROR wie vorher. Aber seht selbst


      Noch eine andere Frage, bevor ich Festplatte wechsle oder ein neues Netzteil einbaue - kann es auch an dem SATA-Anschluss am Mainboard liegen?
      Ich versuche es jedenfalls mal an einem anderen Anschluss.
      Dreambox 7080 HD PVR mit WD40EURX AV-PG 4TB
      Dreambox 8000 HD PVR mit WD20EVDS Caviar AV-GP 2TB
      Dreambox 800 HD SE mit WD10TPVT Scorpio Blue 1TB
    • testsoft wrote:

      testsoft wrote:

      Hast du deine Platte denn jetzt schon mal mit dem von mir empfohlenem Programm überprüft ?
      Oder willst du noch tagelang weiter Rätseln woran es denn nun liegt ?
      ?( ?( ?(

      Philomathia wrote:

      testsoft wrote:

      Hast du deine Platte denn jetzt schon mal mit dem von mir empfohlenem Programm überprüft ?
      oette.wordpress.com/2015/10/17…laechenfehler-reparieren/
      Nein, dazu kam ich noch nicht.Neben den ganzen anderen Versuchen habe ich zwischenzeitlich noch versucht, so weit es überhaupt geht Aufnahmen von der Festplatte zu evakuieren, damit nicht alles verloren ist.

      Aber danke für den Link - der hilft mir sicherlich, das problemlos machen zu können :blumen:

      Noch einmal vielen Dank für Deinen Hinweis bzgl. Festplattenprüfung, aber vielleicht erlaubst Du mir
      1. vor einer Prüfung der Festplatte meine Aufnahmen zu evakuieren, soweit das geht und
      2. zeitgleich Schritt für Schritt auch andere Fehlerquellen auszuschließen?
      Dreambox 7080 HD PVR mit WD40EURX AV-PG 4TB
      Dreambox 8000 HD PVR mit WD20EVDS Caviar AV-GP 2TB
      Dreambox 800 HD SE mit WD10TPVT Scorpio Blue 1TB
    • So, nachdem der alternative SATA-Anschluss nicht in Frage kam, das das SATA-Kabel zu kurz ist, habe ich kurzerhand die Festplatte gegen eine neue ausgtauscht. Neue HDD initialisiert, eine Aufnahme gemacht, Movieliste aufgerufen, Aufnahme abgespielt, alles ok. Anschließend ein ata.log erstellt, das keinerlei ERRORs aufweist.


      Dann habe ich die alte hdd per SATA-USB-Adapter an die Dream angeschlossen und versucht, die Movieliste auf die neue hdd zu transferieren. Das klappte zunächst auch, aber der Transfer brach nach 8 Dateien an, denn die alte hdd war mal wieder nicht mehr richtig "ansprechbar".
      Nach einem Neustart klappte es dann - zumindest läuft der Transfer auf die neue hdd bisher ohne weiteren Abbruch.

      @testsoft
      Wenn ich dann meine Aufnahmen auf der neuen hdd habe, werde ich das von Dir empfohlene Programm nutzen, und die alte Festplatte überprüfen.
      Dreambox 7080 HD PVR mit WD40EURX AV-PG 4TB
      Dreambox 8000 HD PVR mit WD20EVDS Caviar AV-GP 2TB
      Dreambox 800 HD SE mit WD10TPVT Scorpio Blue 1TB
    • Tja, das mit dem Kopieren hat dann nicht lange gedauert, ca. 40-50 Aufnahmen, dann brach die Verbindung wieder ab.
      Wenn ich über Telnet mit dem Befehlt cp arbeite, fängt der Kopiergang dann wieder bei der ersten Aufnahme an, deshalb die Frage: gibt es irgendeine Möglichkeit, die Aufnahmen in Blöcken zu kopieren?
      Ich habe versucht, die bisher kopierten Dateien auf der alten HDD zu löschen, damit dann nur die weiteren Aufnahmen kopiert werden, aber das scheitert derzeit auch.
      Über DCC die Aufnahmen auf den PC zu transferieren scheitert auch, vermutlich geht das bei der HDD nur noch über den internen SATA-Anschluss und nicht über den SATA-USB-Adapter, wenn überhaupt noch etwas geht. :(
      Dreambox 7080 HD PVR mit WD40EURX AV-PG 4TB
      Dreambox 8000 HD PVR mit WD20EVDS Caviar AV-GP 2TB
      Dreambox 800 HD SE mit WD10TPVT Scorpio Blue 1TB
    • - alte HDD wieder in die Dream8000 eingebaut
      - Aufnahmen, die bereits auf die neue HDD transferiert wurden, konnten nun via DCC gelöscht werden
      - externe USB-Festplatte angeschlossen
      - copy auf externe HDD läuft (hoffentlich diesmal länger!!)
      Dreambox 7080 HD PVR mit WD40EURX AV-PG 4TB
      Dreambox 8000 HD PVR mit WD20EVDS Caviar AV-GP 2TB
      Dreambox 800 HD SE mit WD10TPVT Scorpio Blue 1TB