Pinned DM900UHD root write protect, Filesystem read only gemountet

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Ich hab selbst keine 900UHD, aber auf meiner 7080 funktionierte das noch mit remount. Wenn das schon nicht geht, ist wohl noch mehr hinüber, und du hast nicht nur das read only Problem. Vielleicht kann dir noch @Fred Bogus Trumper oder @Joey weiter helfen, ohne gleich auf neu flashen zu verweisen ;) .

      PS: 1 large file ???
      vielleicht eine Aufnahme im Flash?
    • Backup wird gemacht, läuft quasi schon. Mache erst noch alle Updates und ziehe dann Backup.
      Vielen Dank nochmal, war ja ne schwere Geburt :)
      » Samsung UE55D6500 • Denon AVRX6200W • Dreambox 7020HD • Dreambox 500HD • Dreambox 900 UHD • MacBook Pro 8,1 • MacMini i7 • iPhone 6 + 7 (64GB) • iPadMini «
    • Ich gebe zu, ich habe nicht den ganzen Thread gelesen aber ich habe offenbar das selbe Problem. :O

      Ich habe eine DM900 (DVB-T2, kein Kabel, kein Sat). Letztens habe ich ein Update auf Dreambox OS Version: 4.3.1r28-115-g20699-2018-10-02 gemacht und seit dem (da bin ich mir ziemlich sicher), werden die Autotimer nicht mehr
      abgearbeitet also keine neuen Timer erstellt. Auch durch Öffnen und Schliessen der Autotimer-Liste kann ich offenbar keine Suche mehr starten. Manuell kann ich weiterhin Timer erstellen. Bei der Fehlersuche habe ich einen Neustart gemacht und es kam der Greenscreen. In /media/hdd/enigma2_crash_1540470337.log fand ich:

      Source Code

      1. saveFile: failed to write to /etc/enigma2/settings: [Errno 30] Read-only file system: '/etc/enigma2/.settings.Fa0w2h'
      2. saveFile: failed to write to /etc/enigma2/timers.xml: [Errno 30] Read-only file system: '/etc/enigma2/.timers.xml.PUTTxH'
      3. saveFile: failed to write to /etc/enigma2/settings: [Errno 30] Read-only file system: '/etc/enigma2/.settings.pyetue'
      4. saveFile: failed to write to /etc/enigma2/autotimer.xml: [Errno 30] Read-only file system: '/etc/enigma2/.autotimer.xml.1cIr1q'
      Die Rechte der Verzeichnisse und Dateien scheinen aber in Ordnung zu sein (drw-r--r-- 1 root root). Und der root-Eintrag in der /etc/fstab scheint mir auf den ersten Blick auch ok (rootfs / rootfs rw,relatime 0 1). Aber:

      Source Code

      1. root@dm900:/etc/enigma2# mount -i
      2. /dev/mmcblk0p2 on / type ext4 (ro,relatime,data=ordered)
      3. devtmpfs on /dev type devtmpfs (rw,relatime,size=503456k,nr_inodes=55121,mode=755)
      4. sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
      5. proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
      6. tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev,relatime)
      7. devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)
      8. tmpfs on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
      9. tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
      10. cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
      11. cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
      12. cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
      13. cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
      14. cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
      15. cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
      16. systemd-1 on /media/video type autofs (rw,relatime,fd=26,pgrp=1,timeout=60,minproto=5,maxproto=5,direct)
      17. systemd-1 on /data type autofs (rw,relatime,fd=27,pgrp=1,timeout=0,minproto=5,maxproto=5,direct)
      18. systemd-1 on /media/music type autofs (rw,relatime,fd=28,pgrp=1,timeout=60,minproto=5,maxproto=5,direct)
      19. systemd-1 on /media/photo type autofs (rw,relatime,fd=29,pgrp=1,timeout=60,minproto=5,maxproto=5,direct)
      20. systemd-1 on /media/videoSpielfilme type autofs (rw,relatime,fd=32,pgrp=1,timeout=60,minproto=5,maxproto=5,direct)
      21. mqueue on /dev/mqueue type mqueue (rw,relatime)
      22. tmpfs on /var/volatile type tmpfs (rw,relatime,mode=755)
      23. tmpfs on /tmp type tmpfs (rw,relatime)
      24. /dev/sda1 on /media/hdd type ext4 (rw,relatime,data=ordered)
      25. /etc/auto.misc on /misc type autofs (rw,relatime,fd=6,pgrp=299,timeout=300,minproto=5,maxproto=5,indirect)
      26. -hosts on /net type autofs (rw,relatime,fd=12,pgrp=299,timeout=300,minproto=5,maxproto=5,indirect)
      27. /etc/auto.hotplug on /autofs type autofs (rw,relatime,fd=18,pgrp=299,timeout=300,minproto=5,maxproto=5,indirect)
      28. /etc/auto.network on /media/net type autofs (rw,relatime,fd=24,pgrp=299,timeout=300,minproto=5,maxproto=5,indirect)
      29. /dev/mmcblk0p3 on /data type ext4 (rw,relatime,data=ordered)
      Display All

      Leider scheitert die im ersten Post skizzierte Lösung bei mir gleich im Ansatz:

      Source Code

      1. root@dm900:/etc/enigma2# remount
      2. -bash: remount: command not found
      3. root@dm900:/etc/enigma2# mount -o remount,rw /
      4. mount: cannot remount rootfs read-write, is write-protected
      5. root@dm900:/etc/enigma2#
      Was muss ich tun? :/
    • Hallo,

      ich muss alle drei Wochen meine dm900 neu flashen, ständig geht die Box in readonly und es geht nix mehr ...
      Ich habe keine Ahnung warum dies passiert, ich kann ganz normal die Updates machen und von jetzt auf gleich geht dann irgendwann nix mehr?

      Ich hab das neuste Image drauf und der Fehler sollte doch eigentlich Geschichte sein?

      remount oder mount -o remount,rw /
      bringt leider garnix, ich bekomme dann lediglich folgende Meldung

      root@dm900:~$ remount
      mount: cannot remount rootfs read-write, is write-protected
      root@dm900:~$ mount -o remount,rw /
      mount: cannot remount rootfs read-write, is write-protected
      root@dm900:~$

      Weiß hier vielleicht jemand etwas näheres zu?
      Es ist extrem nervig ständig ein neues Image aufspielen zu müßen, ich spiele auch kein fehlerhaftes Backup ein, ich flashe immer komplett neu ...
      » Samsung UE55D6500 • Denon AVRX6200W • Dreambox 7020HD • Dreambox 500HD • Dreambox 900 UHD • MacBook Pro 8,1 • MacMini i7 • iPhone 6 + 7 (64GB) • iPadMini «
    • Der Fehler um den es hier im Thread geht ist behoben und tritt mit aktuellem Softwarestand schon lange nicht mehr auf. Für ein defektes Dateisystem kann es viele Ursachen geben. Davon sieht man dann aber nur die Auswirkung, dass man nicht mehr ins System schreiben kann. Vor kurzem meinte auch jemand, der Fehler würde immer noch auftreten, nur schaltet der die Box am Netzschalter aus, wenn sie mal hängt und macht sich auf diese Weise das Filesystem selbst kaputt - schiebt es aber auf eine Ursache, die es seit Monaten nicht mehr gibt.
      Von defektem Flash bis zur versehentlichen Übernahme einer defekten fstab beim Flashen (die beiden Haken beim Flashen) ist vieles möglich, was dieses verursachen kann.