libc6-dev in OE2.5

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • libc6-dev in OE2.5

      Hallo,

      leider ist in newnigma2 keine dev-Version von libc6 enthalten.

      Ich wollte mir nämlich sabnzbd compilieren, scheitere aber schon an den prerequisites wie z.B. par2cmdline:

      Source Code

      1. configure:3053: checking whether the C++ compiler works
      2. configure:3075: g++ conftest.cpp >&5
      3. /usr/lib/gcc/mipsel-oe-linux/5.3.0/../../../../mipsel-oe-linux/bin/ld: cannot find crt1.o: No such file or directory
      4. /usr/lib/gcc/mipsel-oe-linux/5.3.0/../../../../mipsel-oe-linux/bin/ld: cannot find crti.o: No such file or directory
      5. /usr/lib/gcc/mipsel-oe-linux/5.3.0/../../../../mipsel-oe-linux/bin/ld: cannot find crtbegin.o: No such file or directory
      6. /usr/lib/gcc/mipsel-oe-linux/5.3.0/../../../../mipsel-oe-linux/bin/ld: cannot find -lstdc++
      7. /usr/lib/gcc/mipsel-oe-linux/5.3.0/../../../../mipsel-oe-linux/bin/ld: cannot find -lm
      8. /usr/lib/gcc/mipsel-oe-linux/5.3.0/../../../../mipsel-oe-linux/bin/ld: cannot find -lgcc_s
      9. /usr/lib/gcc/mipsel-oe-linux/5.3.0/../../../../mipsel-oe-linux/bin/ld: cannot find -lgcc
      10. /usr/lib/gcc/mipsel-oe-linux/5.3.0/../../../../mipsel-oe-linux/bin/ld: cannot find -lc
      11. /usr/lib/gcc/mipsel-oe-linux/5.3.0/../../../../mipsel-oe-linux/bin/ld: cannot find -lgcc_s
      12. /usr/lib/gcc/mipsel-oe-linux/5.3.0/../../../../mipsel-oe-linux/bin/ld: cannot find -lgcc
      13. /usr/lib/gcc/mipsel-oe-linux/5.3.0/../../../../mipsel-oe-linux/bin/ld: cannot find crtend.o: No such file or directory
      14. /usr/lib/gcc/mipsel-oe-linux/5.3.0/../../../../mipsel-oe-linux/bin/ld: cannot find crtn.o: No such file or directory
      Display All

      Da libc6-dev nicht verfügbar ist, wollte ich kurzerhand glibc selbst compilieren. Leider tritt dabei irgendwann folgender Fehler auf:

      Source Code

      1. gcc -mabi=32 -nostdlib -nostartfiles -r -o /usr/src/glibc-build/elf/librtld.map.o '-Wl,-(' /usr/src/glibc-build/elf/dl-allobjs.os /usr/src/glibc-build/libc_pic.a -lgcc '-Wl,-)' -Wl,-Map,/usr/src/glibc-build/elf/librtld.mapT
      2. /usr/lib/gcc/mipsel-oe-linux/5.3.0/../../../../mipsel-oe-linux/bin/ld: cannot find -lgcc

      Nur ist auch nach Installation von gcc-plugins gcc-symlinks und libgcc1 keine libgcc.so auf dem System zu finden - lediglich libgcc_s.so.

      Das Paket libc6-dev bereitzustellen, würde Abhilfe schaffen. Ist das möglich?

      Gruß
    • Also eigentlich kompiliert man gar nicht direkt auf der Box, sondern macht das am PC mit einem sog. Cross-Compiler. So werden auch die Images für die 900 gemacht. Am saubersten kannst du den Cross-Compiler aufsetzen, wenn du die OE 2.5-Buildumgebung auf deinem Linux-PC (oder in einer VM) aufsetzt: git.opendreambox.org/?p=opendr…0a9262a3804b108b2;hb=HEAD
      Aber ich bin sicher, dass @gutemine gleich auch noch (berechtigterweise) darauf hinweist, dass das mit einem vollwertigen Debian auf der Box doch auch geht und dass man das mit Barry Allen schnell installieren kann :D

      Dieses konkrete Paket findet sich übrigens schon bei DMM auf dem Feed, sodass du das einfach von dort beziehen kannst ;)
      libc6-dev_2.23-r0.2_armhf.deb
    • Danke, hast mir sehr geholfen. Habe die passenden Pakete unter dreamboxupdate.com/opendreambox/2.5/unstable/r0/dm820/deb/ gefunden.

      Nach manueller Installation von

      libc6-dev_2.23-r0.2_mipsel.deb
      libc6-extra-nss_2.23-r0.2_mipsel.deb
      libc6-thread-db_2.23-r0.2_mipsel.deb
      libc6_2.23-r0.2_mipsel.deb
      libgcc-s-dev_5.3.0-r0.2_mipsel.deb
      libgcc1_5.3.0-r0.2_mipsel.deb
      libstdc++-dev_5.3.0-r0.2_mipsel.deb

      Funktioniert gcc endlich richtig :)

      Wo finde ich Infos zu dem Repo? Würde mir das gern direkt in /etc/apt/apt.sources.d eintragen und die Priority in den preferences runter drehen, damit die Pakete von newnigma Vorrang haben. Irgendwo muss ja ein "Packages" und "Release" file dazu liegen - leider nicht im selben Verzeichnis :/

      The post was edited 1 time, last by trinker ().

    • Für die jenigen, die es interessiert: So kann man sowohl den Feed von newnigma2 als auch dreamboxupdate einbinden und sicherstellen, dass apt alle Pakete bei Updates ordnungsgemäß auf dem aktuellen Stand hält:

      1) Image von dreamboxupdate.com runterladen und auf dem PC entpacken
      2) Dateien aus /etc/apt/sources.list.d mit Prefix "du-" versehen und auf die Dreambox kopieren
      3) /etc/apt/trusted.gpg.d/opendreambox-krogoth.gpg auf die Dreambox kopieren
      4) /etc/apt/preferences.d/du auf der Dreambox mit folgendem Inhalt erstellen:

      Source Code

      1. Package: *
      2. Pin: origin dreamboxupdate.com
      3. Pin-Priority: 300
      4. Package: libc6*
      5. Pin: origin dreamboxupdate.com
      6. Pin-Priority: 1000
      7. Package: libgcc*
      8. Pin: origin dreamboxupdate.com
      9. Pin-Priority: 1000
      10. Package: libstdc++*
      11. Pin: origin dreamboxupdate.com
      12. Pin-Priority: 1000
      Display All
      5) apt-get update
      6) apt-get install libc6-dev libstdc++-dev libgcc-s-dev libstdc++-dev:

      Source Code

      1. root@dm820:/etc/apt$ apt-get install libc6-dev libstdc++-dev libgcc-s-dev libstdc++6 libstdc++-dev
      2. Reading package lists... Done
      3. Building dependency tree
      4. Reading state information... Done
      5. The following extra packages will be installed:
      6. libc6 libgcc1 linux-libc-headers-dev
      7. Recommended packages:
      8. glibc-extra-nss-dev glibc-thread-db-dev libsegfault-dev libgcc-initial-dev libcidn-dev
      9. The following NEW packages will be installed:
      10. libc6-dev libgcc-s-dev libstdc++-dev linux-libc-headers-dev
      11. The following packages will be upgraded:
      12. libc6 libgcc1 libstdc++6
      13. 3 upgraded, 4 newly installed, 0 to remove and 3 not upgraded.
      14. Need to get 2.488 kB/3.662 kB of archives.
      15. After this operation, 0 B of additional disk space will be used.
      16. Do you want to continue? [Y/n]
      17. [..]
      Display All
      Jetzt bevorzugt apt die Pakete von newnigma, egal welche Version auf dreamboxupdate existiert. Sind Pakete nur auf dreamboxupdate zu finden, werden diese installiert. Möchte man einzelne Pakete von dreamboxupdate bevorzugen, einfach kurz in der /etc/apt/preferences.d/du eintragen.