Raute im Passwort

    • Raute im Passwort

      Moin,

      will in meiner DM520 eine # im WLAN-Passwort eintragen. Leider hat es dieses Zeichen ja immer noch nicht in die Auswahl geschafft. Warum eigentlich nicht?

      Habe danach gegoogelt und immer den Hinweis auf die wpa-supplicant in etc/network erhalten. Allerdings finde ich dort nichts wo ich es eintragen soll.


      Wer kann mir eben weiterhelfen?

      Danke und Gruß
    • trag im wlan setup einfach mal was ein und speicher es,
      dann enigma2 beenden, (systemctl stop enigma2)

      dann in der datei das passwort manuell ändern.

      /etc/wpa_supplicant.conf

      network={
      ssid="WLAN24G"
      proto=WPA
      key_mgmt=WPA-PSK
      pairwise=CCMP TKIP
      group=CCMP TKIP WEP104 WEP40
      psk="schluessel"
      priority=2
      }

      enigma2 wieder starten: systemctl start enigma2
      Probleme kann man niemals mit derselben Denkweise lösen.

      "Die Deutsche Rechtschreibung ist Freeware, sprich, du kannst sie kostenlos nutzen.
      Allerdings ist sie nicht Open Source, d.h. du darfst sie nicht verändern oder in veränderter Form veröffentlichen."

    • Moin Danke Dir für deine Antwort.

      Leider sagt er mir beim Speichern erst. Zu lange nix eingegeben ?!?! und dann falsches PW

      in etc/network/ habe ich die Datei auch gar nicht. sondern da sind nur 4 Ordner und in if pre-up liegt die dann drinnen. aber auch nicht als conf.
      da steht dann folgendes drinnen

      Shell-Script

      1. #!/bin/sh
      2. WPA_SUP_BIN="/usr/sbin/wpa_supplicant"
      3. WPA_SUP_PNAME="wpa_supplicant"
      4. WPA_SUP_PIDFILE="/var/run/wpa_supplicant.$IFACE.pid"
      5. WPA_SUP_OPTIONS="-B -P $WPA_SUP_PIDFILE -i $IFACE"
      6. VERBOSITY=0
      7. if [ -s "$IF_WPA_CONF" ]; then
      8. WPA_SUP_CONF="-c $IF_WPA_CONF"
      9. else
      10. exit 0
      11. fi
      12. if [ ! -x "$WPA_SUP_BIN" ]; then
      13. if [ "$VERBOSITY" = "1" ]; then
      14. echo "$WPA_SUP_PNAME: binaries not executable or missing from $WPA_SUP_BIN"
      15. fi
      16. exit 1
      17. fi
      18. if [ "$MODE" = "start" ] ; then
      19. # driver type of interface, defaults to wext when undefined
      20. if [ -s "/etc/wpa_supplicant/driver.$IFACE" ]; then
      21. IF_WPA_DRIVER=$(cat "/etc/wpa_supplicant/driver.$IFACE")
      22. elif [ -z "$IF_WPA_DRIVER" ]; then
      23. if [ "$VERBOSITY" = "1" ]; then
      24. echo "$WPA_SUP_PNAME: wpa-driver not provided, using \"wext\""
      25. fi
      26. IF_WPA_DRIVER="wext"
      27. fi
      28. # if we have passed the criteria, start wpa_supplicant
      29. if [ -n "$WPA_SUP_CONF" ]; then
      30. if [ "$VERBOSITY" = "1" ]; then
      31. echo "$WPA_SUP_PNAME: $WPA_SUP_BIN $WPA_SUP_OPTIONS $WPA_SUP_CONF -D $IF_WPA_DRIVER"
      32. fi
      33. start-stop-daemon --start --quiet \
      34. --name $WPA_SUP_PNAME --startas $WPA_SUP_BIN --pidfile $WPA_SUP_PIDFILE \
      35. -- $WPA_SUP_OPTIONS $WPA_SUP_CONF -D $IF_WPA_DRIVER
      36. fi
      37. # if the interface socket exists, then wpa_supplicant was invoked successfully
      38. if [ -S "$WPA_COMMON_CTRL_IFACE/$IFACE" ]; then
      39. if [ "$VERBOSITY" = "1" ]; then
      40. echo "$WPA_SUP_PNAME: ctrl_interface socket located at $WPA_COMMON_CTRL_IFACE/$IFACE"
      41. fi
      42. exit 0
      43. fi
      44. elif [ "$MODE" = "stop" ]; then
      45. if [ -f "$WPA_SUP_PIDFILE" ]; then
      46. if [ "$VERBOSITY" = "1" ]; then
      47. echo "$WPA_SUP_PNAME: terminating $WPA_SUP_PNAME daemon"
      48. fi
      49. start-stop-daemon --stop --quiet \
      50. --name $WPA_SUP_PNAME --pidfile $WPA_SUP_PIDFILE
      51. if [ -S "$WPA_COMMON_CTRL_IFACE/$IFACE" ]; then
      52. rm -f $WPA_COMMON_CTRL_IFACE/$IFACE
      53. fi
      54. if [ -f "$WPA_SUP_PIDFILE" ]; then
      55. rm -f $WPA_SUP_PIDFILE
      56. fi
      57. fi
      58. fi
      59. exit 0
      Alles anzeigen

      Ich habe mich dann mal mit meinem gast WLAN verbunden. und geschaut ob dann ne Datei da ist. nein.
      auch ein manuelles anlegen mit deinen Zeilen und meiner ssid und pw hat nicht funktioniert
    • Wer hat hier was von /etc/network geschrieben?
      Die Datei ist direkt in /etc.

      Quellcode

      1. root@dm7080:~$ cd /etc
      2. root@dm7080:/etc$ ls wpa*
      3. wpa_supplicant.conf
      4. root@dm7080:/etc$ cat wpa_supplicant.conf
      5. ctrl_interface=/var/run/wpa_supplicant
      6. ctrl_interface_group=0
      7. update_config=1
      8. network={
      9. key_mgmt=NONE
      10. }
      11. root@dm7080:/etc$
      Alles anzeigen
    • Also:

      Enigma Gestoppt
      etc/wpa-supplicant.conf

      Quellcode

      1. ctrl_interface=/var/run/wpa_supplicant
      2. ctrl_interface_group=0
      3. update_config=1
      4. network={
      5. ssid="NAME"
      6. proto=WPA
      7. key_mgmt=WPA-PSK
      8. pairwise=CCMP TKIP
      9. group=CCMP TKIP WEP104 WEP40
      10. psk="PASS"
      11. priority=2
      12. }
      Alles anzeigen
      Enigma Gestartet

      Box neugestartet. WLAN Connected nicht. :(