Script run on every startup?

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Script run on every startup?

      Hello

      At the moment i am not connected to a sattelite dish, so the time and date in the receiver is not configured after restart, i have a script that sync the time and date from my private server, i want to auto run that script each time i reboot the dm900.


      i tried adding it in init.d but it does not run.

      Regards.
    • there are two options:

      1. add your script to /etc/rc.local (have to be created) to be executed on bootup
      /etc/rc.local

      Shell-Script

      1. #!/bin/bash
      2. /path/to/script.sh
      3. exit 0



      2. add your timeserver(s) (IP or FQDN) manuall in the connman settings (Timeservers= ) and reboot
      /var/lib/connman/ethernet_000934xxxxxx_cable/settings

      Source Code

      1. [ethernet_000934xxxxxx_cable]
      2. Name=Wired
      3. AutoConnect=true
      4. Modified=1970-01-01T00:00:10.808602Z
      5. IPv4.method=manual
      6. IPv4.DHCP.LastAddress=192.168.100.226
      7. IPv6.method=off
      8. IPv6.privacy=disabled
      9. IPv4.netmask_prefixlen=24
      10. IPv4.local_address=192.168.100.97
      11. IPv4.gateway=192.168.100.1
      12. Nameservers=192.168.100.1;
      13. Timeservers=de.pool.ntp.org;
      Display All
      you have also to disable the TransponderTime in /etc/enigma2/settings in the Newnigma2 Services: System Tools -> User Transponder Time = no

      Source Code

      1. config.misc.useTransponderTime=false

      The post was edited 2 times, last by Fred Bogus Trumper ().

    • Hello

      it does not seem to work, when i created rc.local, even gave permission, i dont know if i am missing something. is there an option to make it at boot? as i know in linux rc.local is auto startup everything in that file... scripts will run.

      Regards.