Problem mit UBIFS

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Problem mit UBIFS

      Hallos!

      Mit einer DM525 (seit 3 Wochen in der Rollwohnung in Betrieb) habe ich das Problem, dass sie manchmal bootet, manchmal nicht. Heute wollte sie gar nicht mehr starten. Das Bootlog meckert wie folgt:

      Spoiler anzeigen

      Dreambox DM520


      M0CZS
      L2=1
      LLMB=1
      BrCfg=E30FB7C6
      #@


      BCM973625A0 CFE v15.3, Endian Mode: Little
      Build Date: Fri Aug 19 11:48:16 2016 (Jann@Cynric)
      Copyright (C) Broadcom Corporation.


      CI box detected
      card if inited
      Enabling NAND flash at CS2: A5U4GA31ATS(DEVICE ID=0xC8DC9095), ECC Level=4, Spare Area Size=16
      MACRONIX SPI flash detected: Size = 16MB, Sector Size 4096, Page Size 256


      CPU speed: 751MHz
      DDR Frequency: 1061 MHz
      DDR Mode: DDR3
      Total memory(MEMC 0): 512MB
      MEMC 0 DDR Width: 16
      Boot Device: SPI
      Total flash: 16MB
      RTS VERSION: rts_hevc10_1067
      ETH0_PHY: INT
      ETH0_MDIO_MODE: 1
      ETH0_SPEED: 100
      ETH0_PHYADDR: 1


      DM init finalization
      yxml: processing file of 131072 bytes... succeeded!
      no file loaded, create xml restoring default xml
      loaded network params of: DHCP, 192.168.0.219, 255.255.255.0, 192.168.0.1
      [1] type 3, dev nandflash0.kernel, loader elf, filesys raw, file , options
      [2] type 3, dev flash0.kernel, loader elf, filesys raw, file , options
      [3] type 1, dev eth0, loader elf, filesys tftp, file , options bmem=192M@64M console=ttyS0,1000000 root=/dev/nfs ip=dhcp
      added 3 sources to autoboot list
      init fp
      Initializing USB.


      CFE initialized.
      found card in unknown state
      ca valid!




      ***** DREAMBOX SSBL *****


      Not interrupted yet, trying autoboot or rescue loader, hit any key in the next 500ms to cancel
      Proceeding with autoboot.. You can try aborting with Ctrl+C


      *** Autoboot: Trying device 'nandflash0.kernel' file (raw,elf)


      Ethernet Cable unplugged
      Loader:elf Filesys:raw Dev:nandflash0.kernel File: Options:
      Loading: 0x80001000/7588032 0x8073d8c0/235952 Entry address is 0x805cd1d0
      Closing network eth0
      Starting program at 0x805cd1d0


      ø[ 0.232000] console [ttyS0] enabled, bootconsole disabled
      [ 0.232000] console [ttyS0] enabled, bootconsole disabled
      [ 0.236000] loop: module loaded
      [ 0.237000] brcmstb_nand: NAND controller driver is loaded
      [ 0.238000] tun: Universal TUN/TAP device driver, 1.6
      [ 0.239000] tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
      [ 0.361000] bcmgenet: configuring instance #0 for internal PHY
      [ 0.381000] bcmgenet bcmgenet.0: (unregistered net_device): link down
      [ 0.382000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
      [ 0.383000] ehci-brcm ehci-brcm.0: Broadcom STB EHCI
      [ 0.383000] ehci-brcm ehci-brcm.0: new USB bus registered, assigned bus number 1
      [ 0.415000] ehci-brcm ehci-brcm.0: irq 66, io mem 0x10480300
      [ 0.421000] ehci-brcm ehci-brcm.0: USB 0.0 started, EHCI 1.00
      [ 0.422000] hub 1-0:1.0: USB hub found
      [ 0.422000] hub 1-0:1.0: 2 ports detected
      [ 0.423000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
      [ 0.424000] ohci-brcm ohci-brcm.0: Broadcom STB OHCI
      [ 0.424000] ohci-brcm ohci-brcm.0: new USB bus registered, assigned bus number 2
      [ 0.425000] ohci-brcm ohci-brcm.0: irq 67, io mem 0x10480400
      [ 0.491000] hub 2-0:1.0: USB hub found
      [ 0.491000] hub 2-0:1.0: 2 ports detected
      [ 0.492000] Initializing USB Mass Storage driver...
      [ 0.493000] usbcore: registered new interface driver usb-storage
      [ 0.494000] USB Mass Storage support registered.
      [ 0.494000] i2c /dev entries driver
      [ 0.495000] lirc_dev: IR Remote Control driver registered, major 253
      [ 0.495000] usbcore: registered new interface driver btusb
      [ 0.497000] TCP: cubic registered
      [ 0.497000] NET: Registered protocol family 10
      [ 0.499000] NET: Registered protocol family 17
      [ 0.499000] Bluetooth: RFCOMM TTY layer initialized
      [ 0.500000] Bluetooth: RFCOMM socket layer initialized
      [ 0.501000] Bluetooth: RFCOMM ver 1.11
      [ 0.501000] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
      [ 0.502000] Bluetooth: BNEP filters: protocol multicast
      [ 0.502000] Bluetooth: HIDP (Human Interface Emulation) ver 1.2
      [ 0.503000] L2TP core driver, V2.0
      [ 0.503000] Registering the dns_resolver key type
      [ 0.504000] PM: CP0 COUNT/COMPARE frequency does not depend on divisor
      [ 0.506000] EBI CS2: setting up NAND flash (primary)
      [ 0.507000] NAND device: Manufacturer ID: 0xc8, Chip ID: 0xdc (Unknown NAND 512MiB 3,3V 8-bit)
      [ 0.508000] brcmnand brcmnand.0: 512MiB total, 128KiB blocks, 2KiB pages, 16B OOB, 8-bit, BCH-4
      [ 0.508000]
      [ 0.510000] Bad block table found at page 262080, version 0x01
      [ 0.511000] Bad block table found at page 262016, version 0x01
      [ 0.512000] nand_read_bbt: bad block at 0x000008c20000
      [ 0.513000] nand_read_bbt: bad block at 0x00000a380000
      [ 0.513000] nand_read_bbt: bad block at 0x00001ec40000
      [ 0.515000] Creating 3 MTD partitions on "brcmnand.0":
      [ 0.515000] 0x000000000000-0x00001f500000 : "rootfs"
      [ 0.517000] 0x000000000000-0x000020000000 : "entire_device"
      [ 0.519000] 0x00001f500000-0x00001fa00000 : "kernel"
      [ 0.521000] EBI CS0: setting up SPI flash
      [ 0.521000] spi_brcmstb spi_brcmstb.0: 1-lane output, 3-byte address
      [ 0.522000] spi_brcmstb spi_brcmstb.0: master is unqueued, this is deprecated
      [ 0.523000] m25p80 spi0.0: found mx25l12805d, expected w25q128bv
      [ 0.524000] m25p80 spi0.0: mx25l12805d (16384 Kbytes)
      [ 0.526000] UBI: attaching mtd0 to ubi0
      [ 0.526000] UBI: physical eraseblock size: 131072 bytes (128 KiB)
      [ 0.527000] UBI: logical eraseblock size: 126976 bytes
      [ 0.528000] UBI: smallest flash I/O unit: 2048
      [ 0.528000] UBI: VID header offset: 2048 (aligned 2048)
      [ 0.529000] UBI: data offset: 4096
      [ 1.631000] UBI error: check_corruption: PEB 1378 contains corrupted VID header, and the data does not contain all 0xFF, this may be a non-UBI PEB or a severe VID header corruption which requires manual inspection
      [ 1.659000] UBI error: check_corruption: PEB 1379 contains corrupted VID header, and the data does not contain all 0xFF, this may be a non-UBI PEB or a severe VID header corruption which requires manual inspection
      [ 3.726000] UBI error: check_what_we_have: 2 PEBs are corrupted and preserved
      [ 3.727000] Corrupted PEBs are: 1379 1378
      [ 3.727000] UBI: max. sequence number: 5450
      [ 3.742000] UBI warning: print_rsvd_warning: cannot reserve enough PEBs for bad PEB handling, reserved 38, need 40
      [ 3.743000] UBI warning: print_rsvd_warning: 2 PEBs are corrupted and not used
      [ 3.746000] UBI: attached mtd0 to ubi0
      [ 3.746000] UBI: MTD device name: "rootfs"
      [ 3.747000] UBI: MTD device size: 501 MiB
      [ 3.747000] UBI: number of good PEBs: 4005
      [ 3.748000] UBI: number of bad PEBs: 3
      [ 3.748000] UBI: number of corrupted PEBs: 2
      [ 3.749000] UBI: max. allowed volumes: 128
      [ 3.749000] UBI: wear-leveling threshold: 4096
      [ 3.750000] UBI: number of internal volumes: 1
      [ 3.751000] UBI: number of user volumes: 1
      [ 3.751000] UBI: available PEBs: 0
      [ 3.752000] UBI: total number of reserved PEBs: 4003
      [ 3.752000] UBI: number of PEBs reserved for bad PEB handling: 38
      [ 3.753000] UBI: max/mean erase counter: 3/0
      [ 3.753000] UBI: image sequence number: 1136564486
      [ 3.754000] UBI: background thread "ubi_bgt0d" started, PID 54
      [ 3.756000] ALSA device list:
      [ 3.756000] No soundcards found.


      [ 3.762000] UBIFS error (pid 1): ubifs_recover_master_node: failed to recover master node
      [ 3.768000] List of all partitions:
      [ 3.768000] 1f00 513024 mtdblock0 (driver?)
      [ 3.769000] 1f01 524288 mtdblock1 (driver?)
      [ 3.769000] 1f02 5120 mtdblock2 (driver?)
      [ 3.770000] 1f03 16384 mtdblock3 (driver?)
      [ 3.770000] 1f04 491164 mtdblock4 (driver?)
      [ 3.771000] No filesystem could mount root, tried: ubifs
      [ 3.772000] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(31,0)
      [ 3.773000] Rebooting in 180 seconds..


      Der Rescue-Mode funktioniert noch, aber auch dort konnte ich die Firmware bzw. das dbackup erst nach mehreren Versuchen uploaden.

      Sieht IMO nach einem Hardwareproblem aus, kennt jemand diese Symptome?

      Danke und Cheers!
    • ... teste doch mal mit einem frisch geflashten DP original Image, ob da der Fehler ebenfalls auftritt. Nicht, dass dein Filesystem defekt ist, und dein Backup den Fehler auch immer wieder mitbringt, wenn du das zurück flashst. Ist dein RL aktuell? Speicherfehler sind ja nie ganz auszuschließen.
      Gruß
      Hilfsbereit

      ... jeder GS, ist ein GS zu viel ...

      mediaportal-weed-skins
      Screenshot richtig erstellen
    • Mit dem aktuellen Daily hängt die Box auch bei zwei von drei Startversuchen. Ich versuche es noch mit einer Originalfirmware.

      Ich frage mich, wie die folgenden Zeilen im Bootlog zu deuten sind.

      > [ 1.631000] UBI error: check_corruption: PEB 1378 contains corrupted VID header, and the data does not contain all 0xFF, this may be a non-UBI PEB or a severe VID header corruption which requires manual inspection
      > [ 1.659000] UBI error: check_corruption: PEB 1379 contains corrupted VID header, and the data does not contain all 0xFF, this may be a non-UBI PEB or a severe VID header corruption which requires manual inspection
      > [ 3.726000] UBI error: check_what_we_have: 2 PEBs are corrupted and preserved
      > [ 3.727000] Corrupted PEBs are: 1379 1378

      Klingt irgendwie so ähnlich wie bei den guten alten Festplatten, bei denen defekte Sektoren in einer Blacklist landen und nicht mehr benutzt werden. Andererseits deutet "severe VID header corruption which requires manual inspection" auf ein Problem hin, um das man sich selber kümmern muss. Nur wie?
    • Wie hast du das aktuelle Daily geflasht? Ganz frisch, ohne irgendwelche alten Einstellungen zu übernehmen? Ist dein Rescue Loader aktuell? Google spuck da auch nicht wirklich was zu Dreamboxen aus. Die zwei corrupten PEB wurden wieder hergestellt. Kommt die Fehlermeldung bei jedem flashen? Sonst bin ich dann raus, und kann auch nicht weiter helfen.
      Gruß
      Hilfsbereit

      ... jeder GS, ist ein GS zu viel ...

      mediaportal-weed-skins
      Screenshot richtig erstellen
    • moin gutemine,

      können die 2 corrupten PEB`s schon zu solchen Startproblemen führen? Ich hab keine DM520 ....

      @svoop
      mehr zu Mr.Big (Flash) findest du hier ...
      Gruß
      Hilfsbereit

      ... jeder GS, ist ein GS zu viel ...

      mediaportal-weed-skins
      Screenshot richtig erstellen

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Hilfsbereit ()

    • gutemine schrieb:

      Mr. Big (Flash) verwenden und das ubifs kann dir egal sein. Und 2GB Flash gibt's dann auch auf USB :D
      Mit Mr Big läuft die Box zwar stabiler, aber es kommt immer noch vor, dass sie nicht Booten will und ich mehrfach den Saft ab- und wieder andrehen muss. Ich schaue bei Gelegenheit noch einmal, was die Console jetzt anzeigt, wenn's klemmt. Sehe ich dort nichts brauchbares, geht die Box zurück.