EnigmaLight

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • board.newnigma2.to/wbb4/index.php/User/16744-Hilfsbereit/

    das ist nich so teuer 39 euro shop.led-studien.de/de/pixel-d…ghts/sedu-lights-board-v2
    und 3 meter davon
    amazon.de/digitaler-Chipsatz-v…keywords=Ws2801+Led+Strip


    und ein pc netzteil 5V oder anderes 5v netzteil das 8 A liefert

    The post was edited 3 times, last by ralf631 ().

  • Moin.

    habe nun mein Ambilight am TV montiert und versucht meine DM920 mit EnigmaLight 0.4RC0 dazu zu bringen das Sedu-Board V2 anzusprechen. Wenn ich in der Config genau die Werte eintrage wie sie auch bei mir sind (gegen Uhrzeigersinn/Anfang der ersten LED in der Mitte unten dann kriege ich eine ordetliche Stange an Fehlern da die Config offenbar falsch erzeugt wird. Stelle ich den Anfang der ersten LED unten links an und im Uhrzeigersinn wird zumindest eine korrekte Config erzeugt aber damit läuft auch nix. Auch Moodlamp geht nicht... Ist das hier überhaupt richtig wenn die das SeduBoard am hinteren USB angeschlossen hab? output /dev/ttyUSB0

    Gruß
    Alex
  • was ich gefunden habe
    manuell entpacken und auf die box kopieren / ersetzen


    anhang enfernt: ohne funktion
    Probleme kann man niemals mit derselben Denkweise lösen.

    ¯\_(ツ)_/¯

    "Die Deutsche Rechtschreibung ist Freeware, sprich, du kannst sie kostenlos nutzen.
    Allerdings ist sie nicht Open Source, d.h. du darfst sie nicht verändern oder in veränderter Form veröffentlichen."
  • dreambox.de/board/index.php?th…419-enigmalight/&pageNo=2

    frag hier mal nach, vielleicht hat ja einer was neues

    für armhf scheint es aber nur v0.3 zu geben



    Aber die Sache würde mich jetzt auch mal interessieren, da sich an der Dreamboxfront ja nichts neues tut,
    brauch ich was zum basteln.

    Was habt ihr denn für Hardware genommen ? Basteln oder doch lieber so ein fertiges Set für 160 Euro ?
    insanelight.de/shop/sedulight-…-bis-33-zoll-bis-50-zoll/
    Probleme kann man niemals mit derselben Denkweise lösen.

    ¯\_(ツ)_/¯

    "Die Deutsche Rechtschreibung ist Freeware, sprich, du kannst sie kostenlos nutzen.
    Allerdings ist sie nicht Open Source, d.h. du darfst sie nicht verändern oder in veränderter Form veröffentlichen."
  • Hi,

    ja alles drin.
    Ich hatte 5 Meter bestellt. Dabei war Netzteil, die kleine Box in der ein Arduino UNO steckt, ein USB Kabel für den Anschluss der Box an die Dream, ein Netzteil, ein Y Kabel um den Strom am Anfang der 5 Meter und am Ende der 5 Meter einzuspießen, am Anfang und am Ende ein Stromanschluss und am Anfang noch ein Anschluss der dann in die Box mit dem UNO muss.

    Uno ist schon geflashed mit einer Software.

    Wenn man im Enigmalight einfach die Standardeinstellungen für "Adalight" nimmt funktioniert es out of the Box.

    Gruß,
    Stefan
  • @stefanru
    also für dreamOS scheint es nichts neueres zu geben als die 0.3 aus dem dreambox.de board.

    die 0.4 rc4 gibts scheinbar nur beim OpenATV, das läuft auf dreamOS nicht, da dreamOS nicht
    die passenden depends hat (Depends: libc6 (>= 2.26), libgcc1 (>= 6.3.0), libstdc++6 (>= 6.3.0))

    VU+ hat noch ein enigmalight plugin für arm, da sind die aber bei version 2.27, wer weiss
    in welcher relation das zu dem dreamOS plugin steht.
    (bekommt man über umwege und files von vu ans laufen, aber das ist ja nicht der sinn der sache)
    Probleme kann man niemals mit derselben Denkweise lösen.

    ¯\_(ツ)_/¯

    "Die Deutsche Rechtschreibung ist Freeware, sprich, du kannst sie kostenlos nutzen.
    Allerdings ist sie nicht Open Source, d.h. du darfst sie nicht verändern oder in veränderter Form veröffentlichen."
  • O,k dank dir vielmals.
    Die 0.3 funktioniert ja gut.
    Ich hatte gehofft, dass der Webserver zur Steuerung in der 0.4er auch geht. In der 0.3er ist er nur Demo.
    Ich wollte das Band über FHEM und Alexa an und ausschalten können.

    Das ist jetzt aber nicht so wichtig :)

    Wenn ich mal viel Zeit hab compiliere ich es einfach selbst.
    Habe aber mittlerweile auch mal im source code geschaut und ich denke der Webserver ist nicht weiter entwickelt worden.

    Vielen Dank für die Hilfe,
    Stefan
  • ich hab das set heute von aliexpress bekommen,
    bekomms aber nicht ans laufen.

    kann das device nicht finden/öffnen

    @stefanru hast du noch was anderes eingestellt ausser die Adalight config ?

    ich bekomm
    [CConfig::CheckDeviceConfig] ERROR: /etc/enigmalight.conf line 11 section [device]: wrong value 0 for key channels

    edit, es wird nicht hell, er grab zwar was... aber leds bleiben aus

    Source Code

    1. GrabInfo -> X-ResOrig: 1920 Y-ResOrig: 1080 FPS:10.0 Adr: 8BA60000 Adr2: 8BC70000 OFS,OFS2: 1120 608 = 1728 C-offset:216
    2. 2688
    3. [CBitmap::SaveImage] Bitmap saved to /tmp/enigmalight_0380.bmp (120x67)
    4. GrabInfo -> X-ResOrig: 1920 Y-ResOrig: 1080 FPS:10.0 Adr: 89DF8000 Adr2: 8A008000 OFS,OFS2: 1120 608 = 1728 C-offset:216

    er
    Probleme kann man niemals mit derselben Denkweise lösen.

    ¯\_(ツ)_/¯

    "Die Deutsche Rechtschreibung ist Freeware, sprich, du kannst sie kostenlos nutzen.
    Allerdings ist sie nicht Open Source, d.h. du darfst sie nicht verändern oder in veränderter Form veröffentlichen."
  • Moment ich schick dir mal meine Config.
    War eigentlich ein Kinderspiel.
    Die Treiber für USB und im Menü die Adalight/Momo.

    Sieht bei dir ja schon ganz gut aus. Wird die Box beim einstecken denn richtig erkannt?
    Also wenn du beim einstecken dmesq beobachtest bekommt es auch ein device? Also bei mir /dev/ttyUSB0
    Das war mein Problem aber nach dem Installieren des CDM treibers gings auf anhieb.
    Auf keinen Fall wie bei den selbstbau Aduino Uno den Prefix in der Config ändern.
    Der Standard geht sollte das sein : prefix 41 64 61 01 15 41

    Hier meine Config:

    Source Code

    1. [global]
    2. interface 127.0.0.1
    3. port 19333
    4. [device]
    5. name ambilight
    6. output /dev/ttyUSB0
    7. type momo
    8. interval 20000
    9. prefix 41 64 61 01 15 41
    10. channels 834
    11. rate 115200
    12. debug off
    13. [color]
    14. name red
    15. rgb FF0000
    16. gamma 1.15
    17. adjust 0.90
    18. blacklevel 0.0
    19. [color]
    20. name green
    21. rgb 00FF00
    22. gamma 0.95
    23. adjust 1.0
    24. blacklevel 0.0
    25. [color]
    26. name blue
    27. rgb 0000FF
    28. gamma 0.95
    29. adjust 1.0
    30. blacklevel 0.0
    31. [light]
    32. position left
    33. name 1XX
    34. color red ambilight 1
    35. color green ambilight 2
    36. color blue ambilight 3
    37. hscan 0 1
    38. vscan 98.11 100.0
    39. ...
    Display All
    Sollte es immer noch nicht klappen sag bescheid danns chau ich genau welchen Treiber ich installiert hatte. Bekommen wir sicher ans laufen.

    Hast du die LED's selbst angelötet oder so wie aus der Packung?
    Ich habe mittlerweile noch mehr Projekte umgesetzt mit den LED's und bin am Anfang beim selbst löten drauf reingefallen dass die eine Richtung haben.
    Also bei "in" muss man die Datenleitung anklemmen. Klemmt man sie bei out an geht nix.

    Gruß,
    Stefan
  • wie aus der packung erstmal alles angeschlossen,
    (noch nichts am tv angebracht)
    es scheint aber ein treiber zu fehlen für enigma2

    dmesg spuckt nur aus:
    [ 1700.020524] usb 4-1.2: USB disconnect, device number 5
    [ 1701.989276] usb 4-1.2: new full-speed USB device number 6 using ehci-brcm
    [ 1702.075405] usb 4-1.2: New USB device found, idVendor=1a86, idProduct=7523
    [ 1702.075414] usb 4-1.2: New USB device strings: Mfr=0, Product=2, SerialNumber=0
    [ 1702.075419] usb 4-1.2: Product: USB2.0-Serial
    root@dm920:~#

    und

    root@dm920:~# lsusb
    Bus 004 Device 006: ID 1a86:7523
    (die produkt ID von oben)
    Probleme kann man niemals mit derselben Denkweise lösen.

    ¯\_(ツ)_/¯

    "Die Deutsche Rechtschreibung ist Freeware, sprich, du kannst sie kostenlos nutzen.
    Allerdings ist sie nicht Open Source, d.h. du darfst sie nicht verändern oder in veränderter Form veröffentlichen."