Fritzbox Werksreset löscht alle Festplattendaten?

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Fritzbox Werksreset löscht alle Festplattendaten?

      Hallo,

      ich habe ein riesiges Problem. Ich musste an meiner Fritzbox einen Werksreset machen.
      Nach dem Neustart sind anscheinend alle Festplatten auf den Dreamboxen Leer.

      Kann es sein das der Werksreset der Fritzbox Festplatten beeinflusst, die in Dreamboxen eingebaut/angeschlossen sind?
      PlugIn's: AMS, Autotimer, Seriesplugin, Cool Guide, Epgrefresh/backup, SerienRecorder, MediaPortal
    • Dies ist eine neue Funktion in der Fritzbox :
      „ Werksreset komplett“ , löscht alle Daten der angeschlossenen Geräte ( PC , Dreambox ... ) =) .

      Ne, war Spass :thumbup: .

      Könnte sein, dass evtl. Netzwerk-Mounts nicht mehr erreichbar sind, wenn nach dem Werksreset ein anderer IP Bereich eingestellt / vergeben wurde.

      Hast du auf der Dreambox, in der die HDD eingebaut ist, geschaut oder übers Netzwerk ?
    • Ne, IP's und Mounts sind alle so wie vorher.
      Die Platten sind ja auch erreichbar, nur halt leer bzw. fast leer - auf einer Platte werden noch Cover angezeigt, aber bei weitem nicht alle.

      Ich verzweifele gerade. Knapp 7 TB an Filmen und Seren weg.

      Gibt es irgendwelche Rettungstools mit denen ich was versuchen könnte?
      Baue auch gerne die Platte aus und hänge Sie direkt an den PC wenn das was bringt.
      PlugIn's: AMS, Autotimer, Seriesplugin, Cool Guide, Epgrefresh/backup, SerienRecorder, MediaPortal
    • Muss die Platte eigentlich bei solchen Rettungstools aus der Dreambox ausgebaut und direkt am PC angeschlossen werden oder reicht es über das Heimnetzwerk auf ein eingebundenes Laufwerk zuzugreifen?
      PlugIn's: AMS, Autotimer, Seriesplugin, Cool Guide, Epgrefresh/backup, SerienRecorder, MediaPortal
    • mounte mal eine HDD manuell noche inmal und sieh sicherheitshalber noch einmal nach - eventuell device namen anpasssen

      z.B.

      Quellcode

      1. mkdir /tmp/hdd
      2. mount /dev/sda1 /tmp/hdd
      3. ls /tmp/hdd
      4. du -sch /tmp/hdd



      oder per FTP nachsehen

      wenn die Daten wirklich weg sind: NICHTS auf der HDD löschen oder neu speichern


      mit extundelete hast du am ehesten Chancen die Daten direkt auf der Box auf eine externe Platte oder einen NFS mount zu recovern, sofern die Partionen mit ext3 oder ext4 formatiert sind

      wäre auch interssant, welche Boxen du hast
      Gruß Fred
    • Sorry, hatte die Frage einfach übersehen.
      Ich habe über beide Möglichkeiten nachgesehen.

      @Fred Bogus Trumper
      Was meinst du mit Device Namen anpassen, der wird doch von der Festplatte vorgegeben.
      Ich habe eine 7020HD mit eingebauter 4TB Platte sowie eine 920uHD mit einer eingebauten 1TB Platte.
      An der 7020HD hängt per eSata noch zusätzlich eine 3TB Platte in einem externen Gehäuse.
      Meines Wissens sind alle Platten mit ext4 formatiert.
      PlugIn's: AMS, Autotimer, Seriesplugin, Cool Guide, Epgrefresh/backup, SerienRecorder, MediaPortal
    • Glaub ich nicht, daß ein FritzReset Festplatten der Dreambox löscht.
      Ich glaub eher an ein Mount- oder Freigabeproblem.
      Hat die Fritzbox ne andere IP erhalten oder die Dreamboxen?

      Haben die Dreamboxen Internet? Hatte mal den Fall, daß nur 1 Gerät erlaubt war. In der Fritzbox kann man das aber einstellen.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von root1980 ()

    • MarkoP schrieb:

      @Fred Bogus Trumper
      Was meinst du mit Device Namen anpassen, der wird doch von der Festplatte vorgegeben.
      die Partionen
      z.B. interne HDD dm7020hd müsste /dev/sda1, die eSATA /dev/sdb1
      bei der dm920 /dev/sda1 oder /dev/sdb1 - je nach dem ob ein USB Stick dran hängt

      am besten mit df -h nachsehen

      ich glaube auch nicht, dass der Inhalt gelöscht wurde
      Gruß Fred
    • @root1980
      Ich kann es ja auch nicht glauben, aber ich habe einfach keine andere Erklärung dafür, dass drei unabhängige Netzwerkgeräte gleichzeitig nicht mehr wie gehabt funktionieren und alle Dateien und Verzeichnisse verlieren
      Und auf deine Fragen, ja beide Boxen haben Internet, die gleiche IP wie vorher und auch die gleichen Portfreigaben. Selbst die Arbeitsgruppe habe ich nachgeprüft. Alles wieder wie vor dem Werksreset der Fritzbox.

      @Fred Bogus Trumper
      Die externe Platte habe ich gerade an den PC angeschlossen und ein Recovery Tool zeigt mir die Dateien (allerdings ohne Namen) an.
      Hier mal die Ausgabe von df -h auf der 7020HD (aber eben nur mit der internen Festpatte.
      Spoiler anzeigen

      Filesystem Size Used Available Use% Mounted on
      /dev/root 960.4M 548.7M 346.1M 61% /
      devtmpfs 491.6M 0 491.6M 0% /dev
      tmpfs 499.6M 0 499.6M 0% /dev/shm
      tmpfs 499.6M 32.7M 466.9M 7% /run
      tmpfs 499.6M 0 499.6M 0% /sys/fs/cgroup
      systemd-1 1.8T 1.3T 581.2G 69% /media/Fritzbox
      systemd-1 369.6M 120.5M 249.1M 33% /media/Filme
      systemd-1 6.1G 20.7M 5.7G 0% /data
      systemd-1 1.8T 1.3T 581.2G 69% /media/net/Fritzbox
      systemd-1 369.6M 120.5M 249.1M 33% /media/Serien
      df: /media/net/Workstation: No such device
      systemd-1 369.6M 120.5M 249.1M 33% /media/DM7020HD
      tmpfs 499.6M 68.0K 499.6M 0% /tmp
      tmpfs 499.6M 36.0K 499.6M 0% /var/volatile
      /dev/sda1 930.1G 8.7G 921.4G 1% /media/hdd
      /dev/mmcblk0p3 6.1G 20.7M 5.7G 0% /data
      //192.168.178.1/fritz.nas 1.8T 1.3T 581.2G 69% /media/Fritzbox
      //192.168.178.101/media/ST3000DM0011CH1HDD2 369.6M 120.5M 249.1M 33% /media/Filme
      //192.168.178.1/fritz.nas 1.8T 1.3T 581.2G 69% /media/net/Fritzbox
      //192.168.178.101/Media/hdd 369.6M 120.5M 249.1M 33% /media/Serien
      //192.168.178.101/Media 369.6M 120.5M 249.1M 33% /media/DM7020HD
      [1;31mroot[m@[0;32mdm920:[34;1m~[m$
      -------------------- < Script > ----------------------------
      df -m > /tmp/meminfo.dcc; echo ">>> DONE <<<";
      df: /media/net/Workstation: No such device
      >>> DONE <<<
      [1;31mroot[m@[0;32mdm920:[34;1m~[m$


      Soweit ich das sehe ist die Festplatte ganz normal auf /dev/sda1 eingehangen. In der Dreambox wird sie auch als ordnungsgemäß angezeigt.
      Obwohl bei "Workstation" "No such Device" steht funktioniert der Mount korrekt.
      Dass das Recovery Tool die Daten auf der externen Platte anzeigt lässt eventuell vermuten, das der Header der Platten durcheinander gekommen ist.

      Vielleicht fällt dir etwas auf. So gut kenne ich mich mit der Materie nicht aus.
      PlugIn's: AMS, Autotimer, Seriesplugin, Cool Guide, Epgrefresh/backup, SerienRecorder, MediaPortal
    • abgesehen davon, dass du einiges an durcheinander hast, kann das nicht die Ausgabe der dm7020hd sein, OE2.0 verwendet kein system-d ...

      jedenfalls sieht das nicht gut aus, betrifft wohl die dm920

      Quellcode

      1. /dev/sda1 930.1G 8.7G 921.4G 1% /media/hdd

      die interne 1TB HDD hat gerade mal 8.7GB used

      die Fritz.nas ist 2x gemountet - einmal nach /media/Fritzbox und einmal nach /media/net/Fritzbox
      //192.168.178.1/fritz.nas 1.8T 1.3T 581.2G 69% /media/Fritzbox
      //192.168.178.1/fritz.nas 1.8T 1.3T 581.2G 69% /media/net/Fritzbox


      die hdd der dm7020hd 3x!
      wobei es /Media und /Media/hdd auf der dm7020hd nicht gibt - ausser du hast die Ordner selbst ertellt:

      //192.168.178.101/media/ST3000DM0011CH1HDD2 369.6M 120.5M 249.1M 33% /media/Filme
      //192.168.178.101/Media/hdd 369.6M 120.5M 249.1M 33% /media/Serien
      //192.168.178.101/Media 369.6M 120.5M 249.1M 33% /media/DM7020HD


      im share sind das immer 369.6M - das sieht mir aus, als auf der dm7020hd nichts gemountet ist, zumindest nichts was freigegeben ist ...

      wäre interessant was df -h bzw. mount auf der dm7020hd sagt
      Gruß Fred
    • ok, kann sein dass ich mich imm DCC bei einloggen vertan habe und aus versehen die 920uHD erwischt habe.
      Hier jedenfalls die Ausgabe der 7020HD:
      Spoiler anzeigen

      Filesystem Size Used Available Use% Mounted on
      ubi0:rootfs 369.6M 120.5M 249.1M 33% /
      devtmpfs 154.8M 0 154.8M 0% /dev
      none 154.9M 584.0K 154.3M 0% /var/volatile
      none 154.9M 0 154.9M 0% /dev/shm
      /dev/mtdblock2 7.0M 4.0M 3.0M 57% /boot
      /dev/ubi0_1 535.8M 24.0K 531.1M 0% /data
      /dev/disk/by-uuid/3bf95f1b-39a4-4b05-8a67-0d0e7b1bd5ac 2.7T 201.4M 2.7T 0% /media/net/Filme
      /dev/disk/by-uuid/bed0535d-3f25-47be-b949-0bb6e7697cfd 3.6T 642.1M 3.6T 0% /media/hdd
      //192.168.178.10/Workstation 638.5G 515.2G 123.3G 81% /media/net/Workstation
      //192.168.178.100/Harddisk 930.1G 8.7G 921.4G 1% /media/net/DM920uHD
      //192.168.178.1/fritz.nas 1.8T 1.3T 581.2G 69% /media/net/Fritzbox


      Ok, hab jetzt deinen Post komplett durchgelesen und hier ein paar Anmerkungen:
      Das /Media/hdd bezieht sich auf das eigentliche Laufwerk und zwei Symlinks die ich benötige um für die VideoDB die gleichen Ausgangslaufwerke zu schaffen.
      /Media/hdd hatte ich immer schon auf der 7020HD, kenne ich nicht anders. Allerdings scheint es ein abweichende Image zu sein, denn beim Homesharing wird auch ein abweichendes Verzeichnis als üblich benutzt. Das ursprüngliche Image ist schon mehrere Jahre als und nur upgedated worden, nicht neu geflashed.
      Die Fritzbox ist zweimal drin weil es nur auf einer Box das Verzeichnis /media/net gibt. Wenn ich es jetzt gerade richtig im Kopf habe sind bei der 920er alle Mounts direkt unter Media und bei der 7020 unter /Media7net. Warum weiß ich nicht.
      Das die 1TB Platte nur so wenig benutzten Speicher hat kommt hin. Sie dient als reine Aufnahmeplatte und alle Aufzeichnungen die Archiviert werden verschoben, alles andere gelöscht. Viel war da nicht drauf. Es geht hauptsächlich um die anderen Festplatten.

      Ich hoffe die Erläuterungen helfen dir weiter.
      PlugIn's: AMS, Autotimer, Seriesplugin, Cool Guide, Epgrefresh/backup, SerienRecorder, MediaPortal

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von MarkoP ()

    • sieht auch nicht gut aus, beide Platten 0% used

      Warum du die 3TB Platte nach /media/net/Filme gemountet hast bleibt mir ein Rätsel. Jedenfalls ist deine Konfig etwas konfus - sicher mit ein Grund warum alles weg ist.
      Auf der Fritz.nas und der Workstation sind die Daten allerdings noch da. Ich glaube, dass durch dein crossmounten etwas schief ging. Da bleibt dir wohl nur extundelete und die Hoffnung das die Daten recovered werden können.

      Ist auf der DM7020hd bzw. dm920 derzeit Newnigma2 installiert?
      Gruß Fred
    • Ja, auf beiden ist ein aktuelles Image für die jeweilige Box drauf, beide gestern bzw. vorgestern aktualisiert.
      Die 3TB Platte ist so gemounted weil ich sonst nicht von der VideoDB aus darauf zugreifen kann. Wenn ich sie direkt als externe Platte ansprechen würde, wären die Zugriffspfade nicht gleich, da ich ja keinen Mount setzen kann, der direkt eine externe Platte simuliert. Also habe ich auf beiden Boxen einen Mound in ein Verzeichnis "Filme" gesetzt und so die gleichen Zugriffspunkte von beiden Boxen aus. Wenn von beiden Boxen aus auf eine externe Filestation zugegriffen würde, wäre es wesentlich einfacher, leider fehlt mir derzeit das Geld für so eine Lösung.
      PlugIn's: AMS, Autotimer, Seriesplugin, Cool Guide, Epgrefresh/backup, SerienRecorder, MediaPortal
    • Das mit dem Zugriff auf die VideoDB database kann man auch anders lösen, da müssen die Pfade nicht ident sein, soweit ich weiß.

      Jedenfalls benötigst du zumindest eine weitere 4TB Platte für den recovery Versuch - und ich würde das bei der Größenordnung mit einem Linux System versuchen - zur Not funktioniert es auch auf der Box, dauert nur länger

      1. Platte auf eine freie HDD recovern, wenn etwas gefunden wird, Daten zurückkopieren, Daten auf der Recovery HDD löschen, 2. Platte recovern ....

      Das wird wohl ein paar Tage dauern, ohne Gewähr das alle Daten korrekt wieder hergestellt werden können.

      \\Edit
      deinen letzen Post erst jetzt gelesen: Sind die Platten auch auf der Fritz!Box gemoutet?
      Gruß Fred

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Fred Bogus Trumper ()

    • @root1980
      Natürlich wäre das besser, aber wenn du den letzten Satz in meinem Post darüber liest ...
      Den anderen Teil deines Posting kapiere ich ehrlich gesagt nicht.

      @Fred Bogus Trumper
      Es gibt in der VideoDB verschiedene Mountpoints, aber die Pfade müssen gleich sein. Bei mir wurden leider alle Pfade bis tief ins Wurzelelement erstreckt und der Mountpoint direkt oberhalb vom Wurzelelement.
      Als ich die neue Box bekommen habe blieb mir nur übrig dort dieses System nachzubilden. Ansonsten hätte ich in der VideoDB alle Pfade anpassen müssen.
      Die Platten sind nicht auf der Fritzbox gemounted, wüsste auch gar nicht wie das gehen soll. Lediglich auf dem PC als Netzlaufwerke eingebunden.
      PlugIn's: AMS, Autotimer, Seriesplugin, Cool Guide, Epgrefresh/backup, SerienRecorder, MediaPortal
    • Data Recovery Wizard hat zwar nach einer durchlaufenen Nacht jede Menge Daten gefunden, leider aber nicht viel brauchbares.
      Alle wiederhergestellten Videofiles (egal welches Format) ließen sich nicht abspielen und die zugehörigen Cover (jpg und png) waren zu großen Teilen zerschossen. Lediglich ca. 1/3 der Cover war in Ordnung.

      Da die Daten aber anscheinend alle da sind und nur nicht gelesen werden können vermute ich nach wie vor einen defekten Header. Ist zwar sehr komisch, dass der bei drei Platten gleichzeitig zerschossen wird, aber ...

      @Fred Bogus Trumper
      Kannst du mir etwas mehr zu dem Befehl "extundelete" sagen. Kenne ihn nicht und da ich keinen Speicherplatz für Abbilder habe will ich keinen Fehler beim Zugriff machen.
      PlugIn's: AMS, Autotimer, Seriesplugin, Cool Guide, Epgrefresh/backup, SerienRecorder, MediaPortal