Bootvideo`s für OE2.5/2.6

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Das Video Startet aber beim Booten nicht ---- wenn ich über putty systemctl stop enigma2 mache und dann systemctl start bootvideo startet das Video und dann e2 wieder

      vielleicht ist beim Bootvorgang schon e2 gestartet und deswegen startet Video nicht ( bin newbie was Betriebssystem angeht ) ist nur meine Vermutung ?

      ich höre nur ein Knacken schwarzes Bild und das wars 4 sec später kommt Bild vom Tuner !

      Nachtrag:

      systemctl stop enigma2

      im Skript eingefügt leider keine Änderung alles wie gehabt !:)
    • Nein der script wird neu geschrieben wenn du Änderungen im Plugin machst.

      Mach bitte jetzt nochmal wenn e2 aktiv ist

      Source Code

      1. gst-launch-1.0 playbin uri=file:///usr/share/dreambox-bootvideo/bootvideo.mp4

      sollte ein Video gespielt werden bleiben Reste zurück nach umschalten sind die weg.

      Dann bitte

      Source Code

      1. systemctl status bootvideo
      2. systemctl enable bootvideo
      Alle Ausgaben Posten

      Box neustarten

      gruß pclin
      Die zwei Gemütszustände eines Programmierers
      0 ich hab keine Ahnung was ich hier mache
      1 ICH BIN GOTT
      ---
      Dreambox ONE, DM920UHD, DM900UHD, DM820HD HDD + USB-HUB, Stick 64GB, USB-HDD, Wireless Touch Keyboard K400r, Wlan-Stick 11n
      (Flash) DP-OE2.6 (BAXII) eigenes OE2.6, debian-stretch, Diverse
      (Flash) DP-OE2.5 (BAXII) eigenes OE2.5-e2+kodi+X, debian-stretch, Diverse
      ---
      AudioDSP: miniDSP 2x4HD
      TV: LG 65" SUHD
    • Script nicht geändert Eingabe über putty:

      Display Spoiler

      ##############################################################################
      # #
      # This is a Dreambox #
      # #
      # with newnigma2.to #
      # #
      # Unauthorized access to this system is prohibited ! #
      # #
      # This system is actively monitored and all connections may be logged. #
      # By accessing this system, you consent to this monitoring. #
      # #
      ##############################################################################
      root@dreamone:~$
      root@dreamone:~$ gst-launch-1.0 playbin uri=file:///usr/share/dreambox-bootvideo/bootvideo.mp4
      Setting pipeline to PAUSED ...
      Pipeline is PREROLLING ...
      Redistribute latency...
      Missing element: GStreamer element deinterlace
      WARNING: from element /GstPlayBin:playbin0/GstPlaySink:playsink: Missing element 'deinterlace' - check your GStreamer installation.
      Additional debug info:
      ../../../gst-plugins-base-1.10.4/gst/playback/gstplaysink.c(1494): gen_video_deinterlace_chain (): /GstPlayBin:playbin0/GstPlaySink:playsink:
      deinterlacing won't work
      Redistribute latency...
      Pipeline is PREROLLED ...
      Setting pipeline to PLAYING ...
      New clock: GstSystemClock
      Got EOS from element "playbin0".
      Execution ended after 0:00:07.673233015
      Setting pipeline to PAUSED ...
      Setting pipeline to READY ...
      Setting pipeline to NULL ...
      Freeing pipeline ...
      root@dreamone:~$
      root@dreamone:~$ systemctl status bootvideo
      ● bootvideo.service - Start a script
      Loaded: loaded (/etc/systemd/system/bootvideo.service; enabled; vendor preset: enabled)
      Active: inactive (dead) since Thu 2019-07-11 15:00:24 CEST; 19min ago
      Process: 444 ExecStart=/usr/script/bootvideo.startscript (code=killed, signal=TERM)
      Main PID: 444 (code=killed, signal=TERM)
      Jul 11 15:00:12 dreamone systemd[1]: Started Start a script.
      Jul 11 15:00:22 dreamone bootvideo.startscript[444]: [Bootvideo] starte video auf der One: /data/dreambox-bootvideo/bootvideo4.mp4
      Jul 11 15:00:22 dreamone bootvideo.startscript[444]: [Bootvideo] showiframe-backdrop wird 2x neu gestartetJob for showiframe-backdrop.service failed because the control process exited with error code.
      Jul 11 15:00:22 dreamone bootvideo.startscript[444]: See "systemctl status showiframe-backdrop.service" and "journalctl -xe" for details.
      Jul 11 15:00:24 dreamone bootvideo.startscript[444]: Job for showiframe-backdrop.service failed because the control process exited with error code.
      Jul 11 15:00:24 dreamone bootvideo.startscript[444]: See "systemctl status showiframe-backdrop.service" and "journalctl -xe" for details.
      Jul 11 15:00:24 dreamone bootvideo.startscript[444]: [Bootvideo] enigma2 wird neu gestartet
      Jul 11 15:00:24 dreamone systemd[1]: Stopping Start a script...
      Jul 11 15:00:24 dreamone systemd[1]: Stopped Start a script.
      root@dreamone:~$
      root@dreamone:~$ systemctl enable bootvideo
      root@dreamone:~$


      aber kein Video gesehen da TV Bild lief

      ICH habe eine Vermutung !!!! Wenn ich die Box neu Starte dann steht am TV die Einstellung auf 3840X2160p kann das damit zusammen hängen das er das nicht kann ? weil die Videos 1920X1080p haben !

      The post was edited 2 times, last by gluecksbaerchen ().

    • Nein deine Vermutung stimmt nicht, ist bei mir auch so.

      Source Code

      1. apt install gstreamer1.0-plugins-good-deinterlace
      dann wieder bei gestartetem e2

      Source Code

      1. gst-launch-1.0 playbin uri=file:///usr/share/dreambox-bootvideo/bootvideo.mp4
      Ausgabe Posten

      gruß pclin
      Die zwei Gemütszustände eines Programmierers
      0 ich hab keine Ahnung was ich hier mache
      1 ICH BIN GOTT
      ---
      Dreambox ONE, DM920UHD, DM900UHD, DM820HD HDD + USB-HUB, Stick 64GB, USB-HDD, Wireless Touch Keyboard K400r, Wlan-Stick 11n
      (Flash) DP-OE2.6 (BAXII) eigenes OE2.6, debian-stretch, Diverse
      (Flash) DP-OE2.5 (BAXII) eigenes OE2.5-e2+kodi+X, debian-stretch, Diverse
      ---
      AudioDSP: miniDSP 2x4HD
      TV: LG 65" SUHD
    • Eingabe Putty: apt install gstreamer1.0-plugins-good-deinterlace

      Display Spoiler

      root@dreamone:~$ apt install gstreamer1.0-plugins-good-deinterlace
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      The following NEW packages will be installed:
      gstreamer1.0-plugins-good-deinterlace
      0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
      Need to get 33,9 kB of archives.
      After this operation, 0 B of additional disk space will be used.
      Get:1 feed.newnigma2.to/daily/oe2.6/aarch64 ./ gstreamer1.0-plugins-good-deinterlace 1.10.4-r0.2 [33,9 kB]
      Fetched 33,9 kB in 0s (49,8 kB/s)
      Selecting previously unselected package gstreamer1.0-plugins-good-deinterlace:arm64.
      (Reading database ... 23993 files and directories currently installed.)
      Preparing to unpack .../gstreamer1.0-plugins-good-deinterlace_1.10.4-r0.2_arm64.deb ...
      Unpacking gstreamer1.0-plugins-good-deinterlace:arm64 (1.10.4-r0.2) ...
      Setting up gstreamer1.0-plugins-good-deinterlace:arm64 (1.10.4-r0.2) ...
      root@dreamone:~$



      Eingabe Putty: gst-launch-1.0 playbin uri=file:///usr/share/dreambox-bootvideo/bootvideo.mp4
      Display Spoiler

      root@dreamone:~$ gst-launch-1.0 playbin uri=file:///usr/share/dreambox-bootvideo/bootvideo.mp4
      Setting pipeline to PAUSED ...
      Pipeline is PREROLLING ...
      Redistribute latency...
      Redistribute latency...
      Pipeline is PREROLLED ...
      Setting pipeline to PLAYING ...
      New clock: GstSystemClock
      Got EOS from element "playbin0".
      Execution ended after 0:00:07.679025003
      Setting pipeline to PAUSED ...
      Setting pipeline to READY ...
      Setting pipeline to NULL ...
      Freeing pipeline ...
      root@dreamone:~$
    • So jetzt keine 'Fehler' mehr drin, so soll das aussehen.

      Box jetzt mal neustarten.

      gruß pclin
      Die zwei Gemütszustände eines Programmierers
      0 ich hab keine Ahnung was ich hier mache
      1 ICH BIN GOTT
      ---
      Dreambox ONE, DM920UHD, DM900UHD, DM820HD HDD + USB-HUB, Stick 64GB, USB-HDD, Wireless Touch Keyboard K400r, Wlan-Stick 11n
      (Flash) DP-OE2.6 (BAXII) eigenes OE2.6, debian-stretch, Diverse
      (Flash) DP-OE2.5 (BAXII) eigenes OE2.5-e2+kodi+X, debian-stretch, Diverse
      ---
      AudioDSP: miniDSP 2x4HD
      TV: LG 65" SUHD
    • Bitte mal im start Script /usr/script/bootvideo.startscript

      Source Code

      1. >/dev/null 2>&1
      2. gegen
      3. >& /tmp/bootvideo.log
      Damit wird dann ein log in /tmp geschrieben, das Posten

      gruß pclin
      Die zwei Gemütszustände eines Programmierers
      0 ich hab keine Ahnung was ich hier mache
      1 ICH BIN GOTT
      ---
      Dreambox ONE, DM920UHD, DM900UHD, DM820HD HDD + USB-HUB, Stick 64GB, USB-HDD, Wireless Touch Keyboard K400r, Wlan-Stick 11n
      (Flash) DP-OE2.6 (BAXII) eigenes OE2.6, debian-stretch, Diverse
      (Flash) DP-OE2.5 (BAXII) eigenes OE2.5-e2+kodi+X, debian-stretch, Diverse
      ---
      AudioDSP: miniDSP 2x4HD
      TV: LG 65" SUHD
    • So Skript geändert:
      Display Spoiler

      #!/bin/sh
      NAME="bootvideo.startscript"
      VER="0.2-r0"
      OS="dreamOS 2.5/2.6"
      STRING="$NAME_$VER - $OS"
      bootvideo_file="/data/dreambox-bootvideo/bootvideo4.mp4"
      printf "\n[Bootvideo] starte video auf der One: $bootvideo_file"
      gst-launch-1.0 playbin uri=file://$bootvideo_file >& /tmp/bootvideo.log
      printf "\n[Bootvideo] showiframe-backdrop wird 2x neu gestartet"
      systemctl restart showiframe-backdrop
      sleep 2
      systemctl restart showiframe-backdrop
      printf "\n[Bootvideo] enigma2 wird neu gestartet\n"
      systemctl restart enigma2
      exit 0


      Box neu gestartet und hier der log aus dem tmp:
      Display Spoiler

      Setting pipeline to PAUSED ...
      Pipeline is PREROLLING ...
      Redistribute latency...
      Pipeline is PREROLLED ...
      Setting pipeline to PLAYING ...
      New clock: GstAudioSinkClock
      Redistribute latency...
      Got EOS from element "playbin0".
      Execution ended after 0:00:08.528535687
      Setting pipeline to PAUSED ...
      Setting pipeline to READY ...
      Setting pipeline to NULL ...
      Freeing pipeline ...


      Ich glaube ich werde mal Newenigma2 neu von ftp Server laden und neu Flashen ( vielleicht ist da was schief gegangen ) !!!!! und dann werde ich mit frischen System nochmal Bootvideo per tmp installieren vielleicht geht's dann !!!
      Files
      • bootvideo.log

        (377 Byte, downloaded 7 times, last: )

      The post was edited 1 time, last by gluecksbaerchen ().

    • Nein neu aufsetzen musst du nicht, ist so alles OK.

      Sende dir gleich ein file.

      gruß pclin
      Die zwei Gemütszustände eines Programmierers
      0 ich hab keine Ahnung was ich hier mache
      1 ICH BIN GOTT
      ---
      Dreambox ONE, DM920UHD, DM900UHD, DM820HD HDD + USB-HUB, Stick 64GB, USB-HDD, Wireless Touch Keyboard K400r, Wlan-Stick 11n
      (Flash) DP-OE2.6 (BAXII) eigenes OE2.6, debian-stretch, Diverse
      (Flash) DP-OE2.5 (BAXII) eigenes OE2.5-e2+kodi+X, debian-stretch, Diverse
      ---
      AudioDSP: miniDSP 2x4HD
      TV: LG 65" SUHD
    • Entpacken und nach /etc/systemd/system FTPen, das alte überschreiben.

      Box neustarten reicht aus, das 15 Sek. warten ist nie nötig.

      gruß pclin
      Files
      Die zwei Gemütszustände eines Programmierers
      0 ich hab keine Ahnung was ich hier mache
      1 ICH BIN GOTT
      ---
      Dreambox ONE, DM920UHD, DM900UHD, DM820HD HDD + USB-HUB, Stick 64GB, USB-HDD, Wireless Touch Keyboard K400r, Wlan-Stick 11n
      (Flash) DP-OE2.6 (BAXII) eigenes OE2.6, debian-stretch, Diverse
      (Flash) DP-OE2.5 (BAXII) eigenes OE2.5-e2+kodi+X, debian-stretch, Diverse
      ---
      AudioDSP: miniDSP 2x4HD
      TV: LG 65" SUHD
    • Was hast du gemacht?

      Was bedeutet zu spät schon neu drauf?

      Ich teste hier im Orginal Image alles bevor ich hier poste oder etwas bereit stelle.

      gruß pclin
      Die zwei Gemütszustände eines Programmierers
      0 ich hab keine Ahnung was ich hier mache
      1 ICH BIN GOTT
      ---
      Dreambox ONE, DM920UHD, DM900UHD, DM820HD HDD + USB-HUB, Stick 64GB, USB-HDD, Wireless Touch Keyboard K400r, Wlan-Stick 11n
      (Flash) DP-OE2.6 (BAXII) eigenes OE2.6, debian-stretch, Diverse
      (Flash) DP-OE2.5 (BAXII) eigenes OE2.5-e2+kodi+X, debian-stretch, Diverse
      ---
      AudioDSP: miniDSP 2x4HD
      TV: LG 65" SUHD
    • habe Box neues Image drauf: newnigma2-deb-daily-OE2.6-dreamone-11_07_2019.tar

      dann die Einstellungen gemacht und Datei ( enigma2-plugin-extensions-bootvideo_0.2-r0_all ) nach tmp über Packet Manager
      grüne taste offline installiert und dann Videos hochgeladen per tmp box Neustart .

      Video Einstellung vorgenommen Boot logo aus -- Video ein - Files ausgesucht grüne taste gespeichert dann box Neustart --- kein Video nur schwarzes Bild.

      Danach deine Datei runtergeladen -- Entpackt und mit dcc ins Verzeichnens box Neustart jetzt startet sie nicht mehr !
    • Hier mit dem file sollte es auf jeden Fall gehen.

      Konnte das Problem bei mir nachstellen.
      Die Box ist zu schnell, da konnte es zu dem Effekt kommen.

      @Hilfsbereit
      wird das Plugin anpassen.

      gruß pclin
      Files
      Die zwei Gemütszustände eines Programmierers
      0 ich hab keine Ahnung was ich hier mache
      1 ICH BIN GOTT
      ---
      Dreambox ONE, DM920UHD, DM900UHD, DM820HD HDD + USB-HUB, Stick 64GB, USB-HDD, Wireless Touch Keyboard K400r, Wlan-Stick 11n
      (Flash) DP-OE2.6 (BAXII) eigenes OE2.6, debian-stretch, Diverse
      (Flash) DP-OE2.5 (BAXII) eigenes OE2.5-e2+kodi+X, debian-stretch, Diverse
      ---
      AudioDSP: miniDSP 2x4HD
      TV: LG 65" SUHD