[gelöst] Nordvpn Plugin

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • [gelöst] Nordvpn Plugin

      Hi,

      hat jmd das Nordvpn Plugin auf der 920 zum laufen bekommen? Bekomme hier nur Fehlermeldungen uns greenscreens. Hab auch schon sämtlichr Befehle per Telnet versucht. Oder fehlen hier Abhängigkeiten auf NN Feed?
    • Poste die vollständigen Konsolenein- und ausgaben der Installation und häng den Crashlog an.


      edit:
      Geht problemlos:

      Display Spoiler

      root@dm920:~$ dpkg -i /tmp/*.deb
      Selecting previously unselected package enigma2-plugin-extensions-nordvpnconnector.
      (Reading database ... 20142 files and directories currently installed.)
      Preparing to unpack .../enigma2-plugin-extensions-nordvpnconnector_0.3-r4_all.deb ...
      Unpacking enigma2-plugin-extensions-nordvpnconnector (0.3-r4) ...
      dpkg: dependency problems prevent configuration of enigma2-plugin-extensions-nordvpnconnector:
      enigma2-plugin-extensions-nordvpnconnector depends on curl; however:
      Package curl is not installed.
      enigma2-plugin-extensions-nordvpnconnector depends on openvpn; however:
      Package openvpn is not installed.
      dpkg: error processing package enigma2-plugin-extensions-nordvpnconnector (--install):
      dependency problems - leaving unconfigured
      Errors were encountered while processing:
      enigma2-plugin-extensions-nordvpnconnector
      root@dm920:~$ apt-get update && apt-get -f install
      Ign feed.newnigma2.to ./ InRelease
      Ign feed.newnigma2.to ./ InRelease
      Ign feed.newnigma2.to ./ InRelease
      Ign feed.newnigma2.to InRelease
      Get:1 feed.newnigma2.to ./ Release.gpg [819 B]
      Get:2 feed.newnigma2.to ./ Release.gpg [819 B]
      Get:3 feed.newnigma2.to ./ Release.gpg [819 B]
      Ign feed.newnigma2.to Release.gpg
      Get:4 feed.newnigma2.to ./ Release [1.601 B]
      Get:5 feed.newnigma2.to ./ Release [1.601 B]
      Get:6 feed.newnigma2.to ./ Release [1.603 B]
      Ign feed.newnigma2.to Release
      Get:7 feed.newnigma2.to ./ Packages [25,8 kB]
      Get:8 feed.newnigma2.to ./ Packages [548 kB]
      Get:9 feed.newnigma2.to ./ Packages [125 kB]
      Ign feed.newnigma2.to Packages/DiffIndex
      Ign feed.newnigma2.to ./ Translation-de_DE
      Ign feed.newnigma2.to ./ Translation-de
      Ign feed.newnigma2.to ./ Translation-en
      Ign feed.newnigma2.to ./ Translation-de_DE
      Ign feed.newnigma2.to ./ Translation-de
      Ign feed.newnigma2.to ./ Translation-en
      Ign feed.newnigma2.to ./ Translation-de_DE
      Ign feed.newnigma2.to ./ Translation-de
      Ign feed.newnigma2.to ./ Translation-en
      Hit feed.newnigma2.to Packages
      Ign feed.newnigma2.to Translation-de_DE
      Ign feed.newnigma2.to Translation-de
      Ign feed.newnigma2.to Translation-en
      Fetched 707 kB in 6s (112 kB/s)
      Reading package lists... Done
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      Correcting dependencies... Done
      The following packages were automatically installed and are no longer required:
      enigma2-plugin-systemplugins-tubelib python-google-api-client python-httplib2 python-oauth2client python-uritemplate wget
      Use 'apt-get autoremove' to remove them.
      The following extra packages will be installed:
      curl liblzo2-2 openvpn
      The following NEW packages will be installed:
      curl liblzo2-2 openvpn
      0 upgraded, 3 newly installed, 0 to remove and 39 not upgraded.
      1 not fully installed or removed.
      Need to get 349 kB of archives.
      After this operation, 0 B of additional disk space will be used.
      Do you want to continue? [Y/n] y
      Get:1 feed.newnigma2.to/daily/oe2.5/deb/arm/ ./ curl 7.47.1-r0.1 [90,9 kB]
      Get:2 feed.newnigma2.to/daily/oe2.5/deb/arm/ ./ liblzo2-2 2.09-r0.1 [32,6 kB]
      Get:3 feed.newnigma2.to/daily/oe2.5/deb/arm/ ./ openvpn 2.4.7-r0.0 [226 kB]
      Fetched 349 kB in 0s (1.041 kB/s)
      Selecting previously unselected package curl.
      (Reading database ... 20168 files and directories currently installed.)
      Preparing to unpack .../curl_7.47.1-r0.1_armhf.deb ...
      Unpacking curl (7.47.1-r0.1) ...
      Selecting previously unselected package liblzo2-2.
      Preparing to unpack .../liblzo2-2_2.09-r0.1_armhf.deb ...
      Unpacking liblzo2-2 (2.09-r0.1) ...
      Selecting previously unselected package openvpn.
      Preparing to unpack .../openvpn_2.4.7-r0.0_armhf.deb ...
      Unpacking openvpn (2.4.7-r0.0) ...
      Setting up curl (7.47.1-r0.1) ...
      Setting up liblzo2-2 (2.09-r0.1) ...
      Setting up openvpn (2.4.7-r0.0) ...
      Setting up enigma2-plugin-extensions-nordvpnconnector (0.3-r4) ...
      root@dm920:~$

    • Du installierst die Abhängigkeiten nicht.
      Arbeiten mit der Konsole unter OE2.5 basierten Images

      dpkg -i /tmp/*.deb
      Installiert ein Paket, welches man vorher auf der Box im Verzeichnis /tmp per ftp abgelegt hat.

      Um die Abhängigkeiten dieses Paketes automatisch vom Feed zu installieren, wird im Anschluss folgendes ausgeführt:
      apt-get update && apt-get -y -f install
    • damit hatte ich es auch schon versucht.. hier nochmal mit dem Befehl...irgendwas blicke ich nicht oder mache ich falsche

      Display Spoiler
      *****************************
      * newnigma2.to *
      *****************************
      * the next step is done *
      *****************************


      opendreambox 2.5.0 dm920



      dm920 login: root


      ##############################################################################
      # #
      # This is a Dreambox #
      # #
      # with newnigma2.to #
      # #
      # Unauthorized access to this system is prohibited ! #
      # #
      # This system is actively monitored and all connections may be logged. #
      # By accessing this system, you consent to this monitoring. #
      # #
      ##############################################################################


      Last login: Mon May 6 16:48:19 +0200 2019 on /dev/pts/0.
      root@dm920:~$ apt-get update
      Ign feed.newnigma2.to ./ InRelease
      Ign feed.newnigma2.to ./ InRelease
      Ign feed.newnigma2.to ./ InRelease
      Hit feed.newnigma2.to ./ Release.gpg
      Hit feed.newnigma2.to ./ Release.gpg
      Hit feed.newnigma2.to ./ Release.gpg
      Hit feed.newnigma2.to ./ Release
      Hit feed.newnigma2.to ./ Release
      Hit feed.newnigma2.to ./ Release
      Hit feed.newnigma2.to ./ Packages
      Hit feed.newnigma2.to ./ Packages
      Hit feed.newnigma2.to ./ Packages
      Ign feed.newnigma2.to ./ Translation-de_DE
      Ign feed.newnigma2.to ./ Translation-de
      Ign feed.newnigma2.to ./ Translation-en
      Ign feed.newnigma2.to ./ Translation-de_DE
      Ign feed.newnigma2.to ./ Translation-de
      Ign feed.newnigma2.to ./ Translation-en
      Ign feed.newnigma2.to ./ Translation-de_DE
      Ign feed.newnigma2.to ./ Translation-de
      Ign feed.newnigma2.to ./ Translation-en
      Reading package lists... Done
      root@dm920:~$ dpkg -i /tmp/enigma2-plugin-extensions-nordvpnconnector_0.3-r4_all.deb
      (Reading database ... 16122 files and directories currently installed.)
      Preparing to unpack .../enigma2-plugin-extensions-nordvpnconnector_0.3-r4_all.deb ...
      Unpacking enigma2-plugin-extensions-nordvpnconnector (0.3-r4) over (0.3-r4) ...
      dpkg: dependency problems prevent configuration of enigma2-plugin-extensions-nordvpnconnector:
      enigma2-plugin-extensions-nordvpnconnector depends on python-requests; however:
      Package python-requests is not installed.
      enigma2-plugin-extensions-nordvpnconnector depends on curl; however:
      Package curl is not installed.
      enigma2-plugin-extensions-nordvpnconnector depends on openvpn; however:
      Package openvpn is not installed.


      dpkg: error processing package enigma2-plugin-extensions-nordvpnconnector (--install):
      dependency problems - leaving unconfigured
      Errors were encountered while processing:
      enigma2-plugin-extensions-nordvpnconnector
      root@dm920:~$ apt-get update && apt-get -y -f install
      Ign feed.newnigma2.to ./ InRelease
      Ign feed.newnigma2.to ./ InRelease
      Ign feed.newnigma2.to ./ InRelease
      Hit feed.newnigma2.to ./ Release.gpg
      Hit feed.newnigma2.to ./ Release.gpg
      Hit feed.newnigma2.to ./ Release.gpg
      Hit feed.newnigma2.to ./ Release
      Hit feed.newnigma2.to ./ Release
      Hit feed.newnigma2.to ./ Release
      Hit feed.newnigma2.to ./ Packages
      Hit feed.newnigma2.to ./ Packages
      Hit feed.newnigma2.to ./ Packages
      Ign feed.newnigma2.to ./ Translation-de_DE
      Ign feed.newnigma2.to ./ Translation-de
      Ign feed.newnigma2.to ./ Translation-en
      Ign feed.newnigma2.to ./ Translation-de_DE
      Ign feed.newnigma2.to ./ Translation-de
      Ign feed.newnigma2.to ./ Translation-en
      Ign feed.newnigma2.to ./ Translation-de_DE
      Ign feed.newnigma2.to ./ Translation-de
      Ign feed.newnigma2.to ./ Translation-en
      Reading package lists... Done
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      Correcting dependencies... Done
      The following extra packages will be installed:
      curl libcurl4 liblzo2-2 openvpn python-ndg-httpsclient python-pysocks python-requests python-urllib3
      The following NEW packages will be installed:
      curl libcurl4 liblzo2-2 openvpn python-ndg-httpsclient python-pysocks python-requests python-urllib3
      0 upgraded, 8 newly installed, 0 to remove and 0 not upgraded.
      1 not fully installed or removed.
      Need to get 1.121 kB of archives.
      After this operation, 0 B of additional disk space will be used.
      Get:1 feed.newnigma2.to/daily/oe2.5/deb/arm/ ./ python-urllib3 1.14-r0.1 [97,2 kB]
      Get:2 feed.newnigma2.to/daily/oe2.5/deb/arm/ ./ python-ndg-httpsclient 0.4.2-r0.1 [35,0 kB]
      Get:3 feed.newnigma2.to/daily/oe2.5/deb/arm/ ./ python-pysocks 1.5.7-r0.1 [16,7 kB]
      Get:4 feed.newnigma2.to/daily/oe2.5/deb/arm/ ./ python-requests 2.11.1-r0.1 [511 kB]
      Get:5 feed.newnigma2.to/daily/oe2.5/deb/arm/ ./ libcurl4 7.47.1-r0.1 [111 kB]
      Get:6 feed.newnigma2.to/daily/oe2.5/deb/arm/ ./ curl 7.47.1-r0.1 [90,9 kB]
      Get:7 feed.newnigma2.to/daily/oe2.5/deb/arm/ ./ liblzo2-2 2.09-r0.1 [32,6 kB]
      Get:8 feed.newnigma2.to/daily/oe2.5/deb/arm/ ./ openvpn 2.4.7-r0.0 [226 kB]
      Fetched 1.121 kB in 0s (1.405 kB/s)
      Selecting previously unselected package python-urllib3.
      (Reading database ... 16122 files and directories currently installed.)
      Preparing to unpack .../python-urllib3_1.14-r0.1_armhf.deb ...
      Unpacking python-urllib3 (1.14-r0.1) ...
      Selecting previously unselected package python-ndg-httpsclient.
      Preparing to unpack .../python-ndg-httpsclient_0.4.2-r0.1_armhf.deb ...
      Unpacking python-ndg-httpsclient (0.4.2-r0.1) ...
      Selecting previously unselected package python-pysocks.
      Preparing to unpack .../python-pysocks_1.5.7-r0.1_armhf.deb ...
      Unpacking python-pysocks (1.5.7-r0.1) ...
      Selecting previously unselected package python-requests.
      Preparing to unpack .../python-requests_2.11.1-r0.1_armhf.deb ...
      Unpacking python-requests (2.11.1-r0.1) ...
      Selecting previously unselected package libcurl4.
      Preparing to unpack .../libcurl4_7.47.1-r0.1_armhf.deb ...
      Unpacking libcurl4 (7.47.1-r0.1) ...
      Selecting previously unselected package curl.
      Preparing to unpack .../curl_7.47.1-r0.1_armhf.deb ...
      Unpacking curl (7.47.1-r0.1) ...
      Selecting previously unselected package liblzo2-2.
      Preparing to unpack .../liblzo2-2_2.09-r0.1_armhf.deb ...
      Unpacking liblzo2-2 (2.09-r0.1) ...
      Selecting previously unselected package openvpn.
      Preparing to unpack .../openvpn_2.4.7-r0.0_armhf.deb ...
      Unpacking openvpn (2.4.7-r0.0) ...
      Setting up python-urllib3 (1.14-r0.1) ...
      Setting up python-ndg-httpsclient (0.4.2-r0.1) ...
      Setting up python-pysocks (1.5.7-r0.1) ...
      Setting up python-requests (2.11.1-r0.1) ...
      Setting up libcurl4 (7.47.1-r0.1) ...
      Setting up curl (7.47.1-r0.1) ...
      Setting up liblzo2-2 (2.09-r0.1) ...
      Setting up openvpn (2.4.7-r0.0) ...
      Setting up enigma2-plugin-extensions-nordvpnconnector (0.3-r4) ...
      cp: can't stat '/usr/lib/enigma2/python/Plugins/Extensions/NordVPNConnector/configs/nn2/etc/init.d/openvpn': No such file or directory
      chmod: /etc/init.d/openvpn: No such file or directory
      cp: can't stat '/usr/lib/enigma2/python/Plugins/Extensions/NordVPNConnector/configs/nn2/etc/tmpfiles.d/openvpn.conf': No such file or directory
      chmod: /etc/tmpfiles.d/openvpn.conf: No such file or directory
      dpkg: error processing package enigma2-plugin-extensions-nordvpnconnector (--configure):
      subprocess installed post-installation script returned error exit status 1
      Errors were encountered while processing:
      enigma2-plugin-extensions-nordvpnconnector
      E: Sub-process /usr/bin/dpkg returned an error code (1)
      root@dm920:~$
    • sodele - box neu aufgesetzt und wie in #4 vorgegangen

      Display Spoiler

      *****************************
      * newnigma2.to *
      *****************************
      * the next step is done *
      *****************************


      opendreambox 2.5.0 dm920



      dm920 login: root


      ##############################################################################
      # #
      # This is a Dreambox #
      # #
      # with newnigma2.to #
      # #
      # Unauthorized access to this system is prohibited ! #
      # #
      # This system is actively monitored and all connections may be logged. #
      # By accessing this system, you consent to this monitoring. #
      # #
      ##############################################################################


      root@dm920:~$ dpkg -i /tmp/enigma2-plugin-extensions-nordvpnconnector_0.3-r4_all.deb
      Selecting previously unselected package enigma2-plugin-extensions-nordvpnconnector.
      (Reading database ... 14824 files and directories currently installed.)
      Preparing to unpack .../enigma2-plugin-extensions-nordvpnconnector_0.3-r4_all.deb ...
      Unpacking enigma2-plugin-extensions-nordvpnconnector (0.3-r4) ...
      dpkg: dependency problems prevent configuration of enigma2-plugin-extensions-nordvpnconnector:
      enigma2-plugin-extensions-nordvpnconnector depends on python-requests; however:
      Package python-requests is not installed.
      enigma2-plugin-extensions-nordvpnconnector depends on curl; however:
      Package curl is not installed.
      enigma2-plugin-extensions-nordvpnconnector depends on openvpn; however:
      Package openvpn is not installed.


      dpkg: error processing package enigma2-plugin-extensions-nordvpnconnector (--install):
      dependency problems - leaving unconfigured
      Errors were encountered while processing:
      enigma2-plugin-extensions-nordvpnconnector
      root@dm920:~$ apt-get update && apt-get -y -f install
      Ign feed.newnigma2.to ./ InRelease
      Ign feed.newnigma2.to ./ InRelease
      Ign feed.newnigma2.to ./ InRelease
      Hit feed.newnigma2.to ./ Release.gpg
      Hit feed.newnigma2.to ./ Release.gpg
      Hit feed.newnigma2.to ./ Release.gpg
      Hit feed.newnigma2.to ./ Release
      Hit feed.newnigma2.to ./ Release
      Hit feed.newnigma2.to ./ Release
      Hit feed.newnigma2.to ./ Packages
      Hit feed.newnigma2.to ./ Packages
      Hit feed.newnigma2.to ./ Packages
      Ign feed.newnigma2.to ./ Translation-de_DE
      Ign feed.newnigma2.to ./ Translation-de
      Ign feed.newnigma2.to ./ Translation-en
      Ign feed.newnigma2.to ./ Translation-de_DE
      Ign feed.newnigma2.to ./ Translation-de
      Ign feed.newnigma2.to ./ Translation-en
      Ign feed.newnigma2.to ./ Translation-de_DE
      Ign feed.newnigma2.to ./ Translation-de
      Ign feed.newnigma2.to ./ Translation-en
      Reading package lists... Done
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      Correcting dependencies... Done
      The following extra packages will be installed:
      curl libcurl4 liblzo2-2 openvpn python-ndg-httpsclient python-pysocks python-requests python-urllib3
      The following NEW packages will be installed:
      curl libcurl4 liblzo2-2 openvpn python-ndg-httpsclient python-pysocks python-requests python-urllib3
      0 upgraded, 8 newly installed, 0 to remove and 0 not upgraded.
      1 not fully installed or removed.
      Need to get 1.121 kB of archives.
      After this operation, 0 B of additional disk space will be used.
      Get:1 feed.newnigma2.to/daily/oe2.5/deb/arm/ ./ python-urllib3 1.14-r0.1 [97,2 kB]
      Get:2 feed.newnigma2.to/daily/oe2.5/deb/arm/ ./ python-ndg-httpsclient 0.4.2-r0.1 [35,0 kB]
      Get:3 feed.newnigma2.to/daily/oe2.5/deb/arm/ ./ python-pysocks 1.5.7-r0.1 [16,7 kB]
      Get:4 feed.newnigma2.to/daily/oe2.5/deb/arm/ ./ python-requests 2.11.1-r0.1 [511 kB]
      Get:5 feed.newnigma2.to/daily/oe2.5/deb/arm/ ./ libcurl4 7.47.1-r0.1 [111 kB]
      Get:6 feed.newnigma2.to/daily/oe2.5/deb/arm/ ./ curl 7.47.1-r0.1 [90,9 kB]
      Get:7 feed.newnigma2.to/daily/oe2.5/deb/arm/ ./ liblzo2-2 2.09-r0.1 [32,6 kB]
      Get:8 feed.newnigma2.to/daily/oe2.5/deb/arm/ ./ openvpn 2.4.7-r0.0 [226 kB]
      Fetched 1.121 kB in 0s (1.485 kB/s)
      Selecting previously unselected package python-urllib3.
      (Reading database ... 14850 files and directories currently installed.)
      Preparing to unpack .../python-urllib3_1.14-r0.1_armhf.deb ...
      Unpacking python-urllib3 (1.14-r0.1) ...
      Selecting previously unselected package python-ndg-httpsclient.
      Preparing to unpack .../python-ndg-httpsclient_0.4.2-r0.1_armhf.deb ...
      Unpacking python-ndg-httpsclient (0.4.2-r0.1) ...
      Selecting previously unselected package python-pysocks.
      Preparing to unpack .../python-pysocks_1.5.7-r0.1_armhf.deb ...
      Unpacking python-pysocks (1.5.7-r0.1) ...
      Selecting previously unselected package python-requests.
      Preparing to unpack .../python-requests_2.11.1-r0.1_armhf.deb ...
      Unpacking python-requests (2.11.1-r0.1) ...
      Selecting previously unselected package libcurl4.
      Preparing to unpack .../libcurl4_7.47.1-r0.1_armhf.deb ...
      Unpacking libcurl4 (7.47.1-r0.1) ...
      Selecting previously unselected package curl.
      Preparing to unpack .../curl_7.47.1-r0.1_armhf.deb ...
      Unpacking curl (7.47.1-r0.1) ...
      Selecting previously unselected package liblzo2-2.
      Preparing to unpack .../liblzo2-2_2.09-r0.1_armhf.deb ...
      Unpacking liblzo2-2 (2.09-r0.1) ...
      Selecting previously unselected package openvpn.
      Preparing to unpack .../openvpn_2.4.7-r0.0_armhf.deb ...
      Unpacking openvpn (2.4.7-r0.0) ...
      Setting up python-urllib3 (1.14-r0.1) ...
      Setting up python-ndg-httpsclient (0.4.2-r0.1) ...
      Setting up python-pysocks (1.5.7-r0.1) ...
      Setting up python-requests (2.11.1-r0.1) ...
      Setting up libcurl4 (7.47.1-r0.1) ...
      Setting up curl (7.47.1-r0.1) ...
      Setting up liblzo2-2 (2.09-r0.1) ...
      Setting up openvpn (2.4.7-r0.0) ...
      Setting up enigma2-plugin-extensions-nordvpnconnector (0.3-r4) ...
      root@dm920:~$


      Verbindung zu Host verloren.


      Drücken Sie eine beliebige Taste, um den Vorgang fortzusetzen...


      Bei Verbindung zu Host verloren habe ich den Neustart gemacht.
      Dann wollte ich das Plugin öffnen und zack greenscreen. Siehe Crashlog im Anhang...blick echt nicht weiter...?
      Files
    • Hmm - hab diverse Skins durch aber crasht immernoch. Welchen Skin hast du ? Und kann ich theoretisch das Plugin konfigurieren und danach wieder auf einen anderen Skin wechseln(der eigentlich crash) und es läuft dann im Hintergrund weiter ?
      Files
    • bei boxpirates.to hat der plugin Ersteller einen Support Thread

      PS: ich sehe gerade, du hast den Thread schon gefunden...

      The post was edited 1 time, last by Hilfsbereit ().