NAS in Dreambox eintragen

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • NAS in Dreambox eintragen

      Hallo,

      ich weiß das Thema ist bereits zigmal abgehandelt worden, aber für mein spezifisches Problem konnte ich keine Lösung finden

      Ich habe mir ein QNAP TS-431x2 zugelegt und möchte dies natürlich in meinen Boxen einbinden. Soweit so gut.
      Im Netzwerkbrowser das NAS mit dem entsprechenden Freigabeverzeichnis ausgewählt, Benutzerkennung eingegeben.
      Eintrag wurde erstellt, unter Media ist ein Verzeichnis angelegt, in der fstab und der Automount ein entsprechender Eintrag angelegt worden.

      Eigentlich alles ok, nur wenn ich versuche über die Movielist auf die Freigabe zuzugreifen, sagt er (in dem Fall AMS) mir "Verzeichnis existiert nicht",
      über einen Dateiexplorer wie Dream-Explorer öffnet er zwar die Freigabe, zeigt aber nichts an.
      Wenn ich im DCC den Ordner öffnen will, passiert gar nichts.

      Wo liegt der Fehler? Hab bisher alles nur über CIFS gemacht, ist im NFS vielleicht ein Fehler oder woran kann es liegen?

      "fstab:"

      rootfs / rootfs rw,relatime 0 1
      proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
      sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
      devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620 0 0
      tmpfs /dev/shm tmpfs rw,nosuid,nodev,relatime 0 0
      tmpfs /run tmpfs rw,nosuid,nodev,relatime,mode=755 0 0
      tmpfs /tmp tmpfs rw,relatime 0 0
      tmpfs /var/volatile tmpfs rw,relatime,mode=755 0 0
      /dev/disk/by-label/dreambox-data /data auto noauto,x-systemd.automount,nofail 0 0
      /dev/disk/by-uuid/2f1da50b-3805-4476-bf9c-863d0d6ecd5a /media/hdd auto auto,nofail 0 0
      //192.168.178.101/Media /media/DM7020HD cifs x-systemd.automount,x-systemd.device-timeout=15,username=*****,noauto,rw,password=*****,x-systemd.idle-timeout=60,soft,nofail 0 0
      //192.168.178.10:/FileServer/--- Videos --- /media/Videobearbeitung nfs udp,x-systemd.automount,retrans=4,noauto,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,timeo=5,vers=3,soft,nofail 0 0
      192.168.178.10:/FileServer/---\040Videos\040--- /media/Videobearbeitung nfs udp,x-systemd.automount,retrans=4,noauto,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,timeo=5,vers=3,soft,nofail 0 0
      192.168.178.200:/Erotik /media/Erotik nfs udp,x-systemd.automount,retrans=4,noauto,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,timeo=5,vers=3,soft,nofail 0 0
      192.168.178.200:/Multimedia /media/Mediathek nfs udp,x-systemd.automount,retrans=4,noauto,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,timeo=5,vers=3,soft,nofail 0 0


      "automount.xml"

      <?xml version="1.0" encoding="UTF-8"?>
      <mountmanager>
      <nfs>
      <mount>
      <active>True</active>
      <hdd_replacement>False</hdd_replacement>
      <ip>192.168.***.***</ip>
      <sharename>Videobearbeitung</sharename>
      <sharedir>/FileServer/--- Videos ---</sharedir>
      <options>rw</options>
      </mount>
      </nfs>
      <nfs>
      <mount>
      <active>True</active>
      <hdd_replacement>False</hdd_replacement>
      <ip>192.168.***.***</ip>
      <sharename>Erotik</sharename>
      <sharedir>/Erotik</sharedir>
      <options>rw</options>
      </mount>
      </nfs>
      <nfs>
      <mount>
      <active>True</active>
      <hdd_replacement>False</hdd_replacement>
      <ip>192.168.***.***</ip>
      <sharename>Mediathek</sharename>
      <sharedir>/Multimedia</sharedir>
      <options>rw</options>
      </mount>
      </nfs>
      <cifs>
      <mount>
      <active>True</active>
      <hdd_replacement>False</hdd_replacement>
      <ip>192.168.***.***</ip>
      <sharename>DM7020HD</sharename>
      <sharedir>Media</sharedir>
      <options>rw</options>
      <username>*****</username>
      <password>*****</password>
      </mount>
      </cifs>
      </mountmanager>


      Wieso ist bei den NFS-Freigaben kein Username und Passwort hinterlegt? Ist das normal so?
      PlugIn's: AMS, Autotimer, Seriesplugin, Cool Guide, Epgrefresh/backup, SerienRecorder, MediaPortal
    • Das Berechtigungskonzept von NFS basiert auf der IP. Du musst also in der QNAP die IP der Dreambox oder dein ganzes Heimnetz eintragen und die jeweiligen Freigaben dafür freigeben.

      P.S.: Wenn dein Heimnetz dem Standardaufbau entspricht, kann niemand was schädliches mit den privaten IP Adressen anfangen. Die musst du also nicht maskieren ;)
    • Hallo,

      bin noch Neu im Umgang mit dem QNAP.
      Vielleicht kannst du mir eine Menge Zeit ersparen und kurz sagen wie und wo ich die IP im NAS eintragen muss.

      Ich blick durch die Menüführung echt noch nicht durch.
      PlugIn's: AMS, Autotimer, Seriesplugin, Cool Guide, Epgrefresh/backup, SerienRecorder, MediaPortal
    • Hallo,

      du geht´s in der Qnap auf die Freigabeordner, dann den jeweiligen Ordner, am besten gleich einen eigenen machen für die Dreambox, hier kannst du dann gleich Backup´s Filme usw ablegen und hast immer alles an einer stelle :-). Freigabe bearbeiten und dann ein bisschen "versteckt" Berechtigunstype, ganz oben bei dem jeweiligen Ordner "NFS-Hostzugriff" und hier dann die IP der Dreambox mit lese und schreibrechte vergeben.
      Dann sollte alles einwandfrei funktionieren.
    • @ comchris

      Danke, stimmte zwar nicht ganz mit meinem System überein, aber hat mir sehr weitergeholfen. Habs hinbekommen
      PlugIn's: AMS, Autotimer, Seriesplugin, Cool Guide, Epgrefresh/backup, SerienRecorder, MediaPortal

      The post was edited 1 time, last by MarkoP ().