[gelöst] NFS Client auf DM8000 einrichten

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • [gelöst] NFS Client auf DM8000 einrichten

      New

      Hallo,

      ich möchte mit meiner DM8000 auf Filme, die auf meiner DM7020HD und/oder auf einer Gigablue Quad4K liegen, zugreifen.
      Auf der DM8000 ist newnigma2-daily 2020-03-20 drauf.

      Auf allen drei Boxen läuft nfs. Ich kann auch von der Gigablue auf die Platten der DM8000 und der DM7020 zugreifen - also in dieser Richtung funktioniert das schon mal...

      Ich bekomme es aber nicht hin, mit der DM8000 auf die anderen Boxen zuzugreifen.
      in der auto.network der DM8000 habe ich eingetragen:

      Source Code

      1. DM7020HD -fstype=cifs,rw,soft,tcp,retry=0 192.168.0.20:media/hdd/movie
      Doch die DM8000 meldet " Verzeichnis media/net/DM7020HD/ existiert nicht "

      Wie bekomme ich den Zugriff hin?
    • New

      rschz wrote:

      Source Code

      1. DM7020HD -fstype=cifs,rw,soft,tcp,retry=0 192.168.0.20:media/hdd/movie
      du vermischt CIFS/Samba und NFS! Das kann so nicht funktionieren ...


      entweder mounten über NFS:

      Source Code

      1. DM7020HD -fstype=nfs,rw,soft,tcp,retry=0 192.168.0.20:/media/hdd/movie




      oder über CIFS - wobei du noch den Freigabenamen aus in der smb.confg aus der Serverbox auslesen müsstest, vermutlich "Harddisk

      Source Code

      1. DM7020HD -fstype=cifs,rw,soft,user=yourUsername,pass=yourPassword ://192.168.0.20/Harddisk
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox

      The post was edited 2 times, last by Fred Bogus Trumper ().

    • New

      @Fred Bogus Trumper: Ich werde Deine Vorschläge mal so ausprobieren.

      @Oorschwerbleede: Auf der 7020 habe ich keine expots Datei, lediglich ein exports Verzeichnis, das aber leer ist. Auf der Gigablue habe ich noch nicht nachgesehen, aber wenn ich ersat mal die Verbindung zur 7020 geschafft habe, bekomme ich das andere bestimmt auch hin. Auf der Gigablue ist auch ein openhdf Image, auf den beiden DM newnigma.
    • New

      Die samba.config der 7020 ist so

      Source Code

      1. [global]
      2. load printers = no
      3. guest account = root
      4. log file = /tmp/smb.log
      5. log level = 1
      6. security = share
      7. server string = Dreambox %h network services
      8. workgroup = Dream
      9. netbios name = %h
      10. case sensitive=yes
      11. preserve case=yes
      12. short preserve case=yes
      13. socket options = TCP_NODELAY
      14. preferred master = no ;(These stop the machine being master browser, which means that it doesn't waste time there.)
      15. oplocks = no
      16. [Configuration]
      17. comment = Configuration files - take care!
      18. path = /var
      19. read only = no
      20. public = yes
      21. guest ok = yes
      22. [Harddisk]
      23. comment = The harddisk
      24. path = /media/hdd
      25. read only = no
      26. public = yes
      27. guest ok = yes
      Display All

      Den Eintrag in der auto.network der 8k habe ich so abgeändert:

      Source Code

      1. DM7020HD -fstype=cifs,rw,soft ://192.168.0.20/media/hdd
      Leider ohne Erfolg... :(
    • New

      du musst auch lesen - und verstehen

      CIFS mountet man nicht über einen absoluten Pfad sondern über den Freigabenamen, lt. deiner smb.conf lautet dieser Harddisk


      also

      Source Code

      1. DM7020HD -fstype=cifs,rw ://192.168.0.20/Harddisk
      username=root,password=xxxx wirst du vermutlich auch mitgeben müssen

      Besuch mal den FAQ Bereich im Board oder nutze die Boardsuche
      Das Thema wurde gefühlt schon 1.000.000x besprochen

      Dann wirst du auch herausfinden, das ein NFS mount dem CIFS mount vorzuziehen ist
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox
    • New

      Nun habe ich es hinbekommen, der für mich richtige Eintrag lautet

      Source Code

      1. DM7020HD -fstype=cifs,rw,user=root,pass= ://192.168.0.20/Harddisk
      Die Einbindung der gigablue läuft genauso. Bin zufrieden damit.

      Fred, du hast bestimmt recht, daß nfs besser als cifs ist, aber für meine Zwecke reicht es, wenn es nun einfach funktioniert.
      Vielen Dank für die Hilfe. :thumbsup: