Bitte um Hilfe! Mount auf Interne Festplatte verstellt - nur noch Zugriff auf Festplatte von anderer Dreambox im Heimnetzwerk

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Bitte um Hilfe! Mount auf Interne Festplatte verstellt - nur noch Zugriff auf Festplatte von anderer Dreambox im Heimnetzwerk

      Hallo zusammen,

      ich habe Zuhause drei Dreambox mit jeweils einer internen Festplatte, die miteinander vernetzt sind:
      Arbeitszimmer DM920 (192.168.103.26), Wohnzimmer DM900 (192.168.103.25) und Schlafzimmer DM800se (192.168.103.20)

      Nun wollte ich es heute am Feiertag so einrichten, dass ich von jeder Dreambox aus auf die anderen Festplatten zugreifen kann.
      Hierbei habe ich aber irgendeinen dummen Fehler gemacht und komme bei allen Dreamboxen nur noch auf die interne Festplatte der DM800se.
      Gerne würde ich jeweils wieder auf meine interne Festplatte zugreifen können.

      Vermutlich liegt der Fehler in der jeweiligen fstab Datei.

      fstab der DM920 (192.168.103.26, mit interner HDD):
      Display Spoiler

      rootfs /rootfs rw,relatime0 1
      proc /procproc rw,nosuid,nodev,noexec,relatime0 0
      sysfs /syssysfs rw,nosuid,nodev,noexec,relatime0 0
      devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620 0 0
      tmpfs /dev/shm tmpfs rw,nosuid,nodev,relatime0 0
      tmpfs /runtmpfs rw,nosuid,nodev,relatime,mode=7550 0
      tmpfs /tmptmpfs rw,relatime0 0
      tmpfs /var/volatile tmpfs rw,relatime,mode=7550 0
      /dev/disk/by-label/dreambox-data /data auto noauto,x-systemd.automount,nofail 0 0
      //192.168.103.25/Harddisk /media/DM900 cifs rw,x-systemd.device-timeout=15,guest,noauto,x-systemd.automount,x-systemd.idle-timeout=60,soft,nofail 0 0
      192.168.103.20:/media/hdd/movie /media/movie nfs udp,x-systemd.automount,retrans=4,noauto,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,timeo=5,vers=3,soft,nofail 0 0
      192.168.103.20:/media/hdd /media/hdd nfs ,udp,x-systemd.automount,retrans=4,noauto,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,timeo=5,vers=3,soft,nofail 0 0
      192.168.103.26:/export/hdd /media/DM900Wohnzi nfs ,udp,x-systemd.automount,retrans=4,noauto,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,timeo=5,vers=3,soft,nofail 0 0


      fstab der DM900 (192.168.103.25, mit interner HDD):
      Display Spoiler

      rootfs /rootfs rw,relatime0 1
      proc /procproc rw,nosuid,nodev,noexec,relatime0 0
      sysfs /syssysfs rw,nosuid,nodev,noexec,relatime0 0
      devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620 0 0
      tmpfs /dev/shm tmpfs rw,nosuid,nodev,relatime0 0
      tmpfs /runtmpfs rw,nosuid,nodev,relatime,mode=7550 0
      tmpfs /tmptmpfs rw,relatime0 0
      tmpfs /var/volatile tmpfs rw,relatime,mode=7550 0
      /dev/disk/by-label/dreambox-data /data auto noauto,x-systemd.automount,nofail 0 0
      //192.168.103.26/Harddisk /media/DM920Daniel cifs x-systemd.automount,x-systemd.device-timeout=15,guest,noauto,rw,x-systemd.idle-timeout=60,soft,nofail 0 0
      //192.168.103.20/Harddisk /media/DM800seSchlafzimmer cifs x-systemd.automount,x-systemd.device-timeout=15,guest,noauto,rw,x-systemd.idle-timeout=60,soft,nofail 0 0
      192.168.103.20:/media/hdd /media/hdd nfs ,udp,x-systemd.automount,retrans=4,noauto,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,timeo=5,vers=3,soft,nofail 0 0
      //192.168.103.20/Harddisk /media/DM800se cifs rw,x-systemd.device-timeout=15,guest,noauto,x-systemd.automount,x-systemd.idle-timeout=60,soft,nofail 0 0
      192.168.103.26:/media/hdd/movie /media/movie nfs udp,rw,x-systemd.device-timeout=15,retrans=4,timeo=5,noauto,x-systemd.automount,vers=3,x-systemd.idle-timeout=60,soft,retry=0,nolock,nofail 0 0


      fstab der DM800se (192.168.103.20, mit interner HDD mit zusätzlichem USB-Stick für flodder):
      Display Spoiler

      /dev/root /rootfs noatime0 1
      none/procproc nodev,noexec,nosuid0 0
      none/proc/bus/usb usbfs nodev,noexec,nosuid0 0
      none/syssysfs nodev,noexec,nosuid0 0
      none/dev/pts devpts noexec,nosuid,mode=0620,gid=5 0 0
      none/dev/shm tmpfs nosuid,nodev0 0
      none/var/volatile tmpfs mode=07550 0
      /dev/mtdblock2 /bootjffs2 ro0 0
      /dev/disk/by-uuid/eaff452b-e858-48f7-920f-c2c714841905 /media/hdd auto auto 0 0
      /dev/disk/by-uuid/7c12f147-cf7e-4dae-a85b-a80be59da9c9 /media/usb auto auto 0 0


      Wie schaffe ich es, dass die jeweilige Dreambox wieder auf ihre interne HDD zugreift? Konkrete Befehle und/oder Schritte im Menü?

      Ganz herzlichen Dank für Eure Hilfe! :)
    • Wenn du auf die Platten der anderen Boxen zugreifst, darfst du diese NICHT als HDD Ersatz oder nach /media/hdd/(movie) mounten! Dann wird die entfernte Platte nach /media/hdd "über" den Inhalt der lokalen HDD gemountet

      in der dm920 hast du die dm820 gleich doppelt gemountet ...
      nach /media/hdd/movie UND /media/hdd

      Source Code

      1. 192.168.103.20:/media/hdd/movie /media/movie nfs udp,x-systemd.automount,retrans=4,noauto,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,timeo=5,vers=3,soft,nofail 0 0
      2. 192.168.103.20:/media/hdd /media/hdd nfs ,udp,x-systemd.automount,retrans=4,noauto,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,timeo=5,vers=3,soft,nofail 0 0


      und auf der dm900 sieht es auch nicht viel besser aus ...
      nfs und CIFS sind durcheinandergewirbelt, entscheide dich besser für ein Protokoll - ich würde nfs nehmen


      Am besten du machst alles Platt und fängst von vorne - und die shares NICHT nach /media/hdd lokal mounten!
      Entweder mühsam über die GUI im Netzwerbrowser wieder alles löschen oder per telnet/ssh.

      Allerdings ist der Netzwerkbrowser etwas buggy, da kann es sein, dass "Reste" übrigbleiben die die einen Strich durch die Rechnung machen könnten. Also besser über telnet/ssh im Terminal:
      Einfach folgende commands auf der dm900 und dm920 nacheinander ausführen und rebooten: die automouts.xml wird gelöscht, die fstab von den multiplen bzw. falschen network mounts bereinigt:


      Source Code

      1. rm /etc/enigma2/automounts.xml
      2. cp -a /etc/fstab /etc/fstab.old
      3. grep -v "cifs\|nfs" /etc/fstab.old > /etc/fstab
      4. reboot


      Nach dem reboot der beiden Boxen startest du wieder bei Null und der Inhalt der lokalen Platten müsste wieder sichtbar sein.
      Die automounts.xml wir dann wieder neu erstellt, wenn du Freigaben hinzufügst
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox
    • Herzlichen Dank! Ich kann jetzt wieder auf die eingebauten HDDs zugreifen! :)

      Leider stehe ich jetzt allerdings wieder am Anfang da und schaffe es nicht von meiner DM920 auf meine DM800se Festplatte (und umgekehrt) zu zugreifen.

      Automounts.xml auf meiner DM800se (192.168.103.20):
      Display Spoiler

      <?xml version="1.0" ?>
      <mountmanager>
      <nfs>
      <mount>
      <active>True</active>
      <hdd_replacement>False</hdd_replacement>
      <ip>192.168.103.26</ip>
      <sharename>DM920</sharename>
      <sharedir>Harddisk</sharedir>
      <options>rw,nolock,tcp</options>
      </mount>
      </nfs>
      <nfs>
      <mount>
      <active>True</active>
      <hdd_replacement>False</hdd_replacement>
      <ip>192.168.103.25</ip>
      <sharename>DM900</sharename>
      <sharedir>Harddisk</sharedir>
      <options>rw,nolock,tcp</options>
      </mount>
      </nfs>
      </mountmanager>


      Automounts.xml auf der DM920 (192.168.103.26):
      Display Spoiler

      <?xml version="1.0" encoding="UTF-8"?>
      <mountmanager>
      <nfs>
      <mount>
      <active>True</active>
      <hdd_replacement>False</hdd_replacement>
      <ip>192.168.103.26</ip>
      <sharename>DM920</sharename>
      <sharedir>/media/hdd</sharedir>
      <options></options>
      </mount>
      </nfs>
      <nfs>
      <mount>
      <active>True</active>
      <hdd_replacement>False</hdd_replacement>
      <ip>192.168.103.20</ip>
      <sharename>DM800</sharename>
      <sharedir>/media/hdd</sharedir>
      <options></options>
      </mount>
      </nfs>
      <nfs>
      <mount>
      <active>True</active>
      <hdd_replacement>False</hdd_replacement>
      <ip>192.168.103.20</ip>
      <sharename>movie</sharename>
      <sharedir>/media/hdd/movie</sharedir>
      <options></options>
      </mount>
      </nfs>
      </mountmanager>



      Eine exports Datei habe ich manuell unter /etc/ mit folgendem Inhalt und Rechte 644 erstellt:
      /media/hdd/movie/ *(rw,sync,no_subtree_check,no_root_squash)
    • sieh dir mal die automounts.xml der DM800se genau an

      Du vermischt CIFS und NFS!

      Du hast das Protokoll NFS angeben und versuchst über den sharename "Harddisk" zu mounten - das funktioniert nicht


      NFS verlangt einen absoluten Pfad: z.B. /media/hdd oder /media/hdd/movie - was eben über die exports freigegeben ist
      CIFS verlange den Freigabenamen, also z.B. "Harddisk"

      Wenn du auf der SE OE2.0 am laufen hast, würde ich anstatt über den Netzwerkbrowser mit autofs mounten

      Am besten du macht eine Box nach der anderen, einlesen in das Thema wäre auch kein Nachteil.

      Lösch mal wieder alles wie in Post #2 beschrieben - auf der DM800SE reicht es die /etc/enigma2/automounts.mxl zu löschen

      läuft auf allen drei Boxen der NFS Server?
      poste mal die Ausgabe des folgenden Befehles auf allen drei Boxen ausgeführt


      exportfs -v
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox
    • Danke für Deine weitere Hilfe!!! :)

      Ich habe mittels "exportfs -v" festgestellt, dass auf der DM900 und DM920 der NFS Server gar nicht lief.

      Folgende Schritte habe ich dann durchgeführt:
      apt-get update
      apt-get install nfs-utils-mount
      apt-get install nfs-utils
      apt-get install nfs-utils-client
      apt-get install rpcbind

      Anschließend über den Netwerkbrowser per NFS verbunden und nun kann ich auf die jeweils andere Festplatte zugreifen. :)

      Automounts.xml der DM920 (192.168.103.26):
      Display Spoiler

      <?xml version="1.0" encoding="UTF-8"?>
      <mountmanager>
      <nfs>
      <mount>
      <active>True</active>
      <hdd_replacement>False</hdd_replacement>
      <ip>192.168.103.20</ip>
      <sharename>DM800seSchlafzi</sharename>
      <sharedir>/media/hdd/movie</sharedir>
      <options></options>
      </mount>
      </nfs>
      <nfs>
      <mount>
      <active>True</active>
      <hdd_replacement>False</hdd_replacement>
      <ip>192.168.103.25</ip>
      <sharename>DM900Wohnzi</sharename>
      <sharedir>/media/hdd/movie</sharedir>
      <options></options>
      </mount>
      </nfs>
      </mountmanager>



      Bei der DM800se (OE 2.0) kann ich auch auf die jeweils anderen HDDs der anderen Dreamboxen zugreifen,
      obwohl im Netwerkbrowser ein x vor dem jeweiligen NFS Laufwerk angezeigt.

      Wie genau sollte ich bei der DM800se (OE 2.0) " mit autofs mounten"? Hast Du da noch einen Tipp für mich?
    • lösche wieder erstmal die automountx.xml komplett und trag die folgenden Zeilen mit einem unix konformen Eitor in die Datei /etc/auto.network ein:


      Source Code

      1. DM900 -fstype=nfs,rw,soft,nolock,tcp,rsize=16384,wsize=16384 192.168.103.25:/media/hdd
      2. Dm920 -fstype=nfs,rw,soft,nolock,tcp,rsize=16384,wsize=16384 192.168.103.26:/media/hdd
      Wenn du nur auf den movie Odner zugreifen möchtest, dann eben 192.168.103.25:/media/hdd/movie etc. - oder was eben auf der Severbox freigegegben wurde

      Nach dem reboot solltest du in /media/net/DM900 bzw. /media/net/DM920 den Inhalt der Freigaben sehen


      Wenn du dann etwas ändern möchtest reicht es in den meisten Fällen die Änderung in der /etc/auto.network zu machen und dann den autofs Dienst neu zu laden;

      /etc/init.d/autofs reload


      sonst einfach nach der Änderung rebooten
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox