[gelöst] Netzwerk-Browser Mount Problem mit SMB Festplatten am Asus RT Router

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • [gelöst] Netzwerk-Browser Mount Problem mit SMB Festplatten am Asus RT Router

      Hallo

      Ich habe einen neuen Router Asus RT-AC86U und nun mountet der NN2 Netzwerk-Browser die angeschlossenen Festplatten nicht mehr.
      Wenn ich die Asus Cifs Freigabe auswähle, fragt er ob ich ein Passwort vergeben will. Ich gebe User und Passwort ein, dann passiert nichts mehr wenn ich die Freigabe anwähle.

      Bei einem Aufruf der Freigabe mit Linuxmint über Thunar (smb://192.168.1.1), werden nicht wie beim alten Asus RT-N18U (Fresh Tomato), die 2 Hds angezeigt, sondern nur die Ordner beider Hds zusammen. Die einzelnen Dateien im Hauptverzeichnis der Hds werden nicht angezeigt, nur die Dateien innerhalb der einzelnen Ordner.

      Wenn ich die 192.168.1.1 mit FTP aufrufe werden die 2 Hds normal angezeigt. Ich kann sie einzeln auswählen und durch die Ordner Struktur navigieren, so wie es beim alten Router auch mittels SMB möglich war.

      Beim RT-AC86U gibt es die Möglichkeit mit SSH in /jffs/configs eine smb.conf.add anzulegen. Diese wird nach einem reboot statt der originalen smb.con in /etc verwendet.
      Dort habe ich den Inhalt der smb.conf vom funktionierenden rt-N18U rein kopiert. Funktioniert leider nicht.

      Wie schaffe ich es nun die Festplatten mit der DM900 normal zu mounten, dass ich wieder darauf aufnehmen kann?

      ASUS RT-AC86U original SMB Config in /etc:

      [global]
      netbios name = ASUS
      server string = RT-AC86U
      workgroup = WORKGROUP
      username level = 20
      unix charset = UTF8
      display charset = UTF8
      load printers = no
      printing = bsd
      printcap name = /dev/null
      log file = /var/log/samba.log
      log level = 0
      max log size = 5
      security = USER
      guest ok = no
      map to guest = Bad User
      encrypt passwords = yes
      pam password change = no
      null passwords = yes
      force directory mode = 0777
      force create mode = 0777
      max connections = 5
      socket options = IPTOS_LOWDELAY TCP_NODELAY SO_KEEPALIVE
      obey pam restrictions = no
      use spnego = yes
      client use spnego = no
      disable spoolss = yes
      host msdfs = no
      strict allocate = no
      wide links = no
      bind interfaces only = yes
      interfaces = lo br0 192.168.1.1/255.255.255.0
      use sendfile = yes
      map archive = no
      map hidden = no
      map read only = no
      map system = no
      store dos attributes = no
      dos filemode = yes
      oplocks = yes
      level2 oplocks = yes
      kernel oplocks = no
      enable core files = no
      deadtime = 30
      load printers = no
      printable = no
      max protocol = SMB2
      smb encrypt = disabled
      min receivefile size = 16384
      passdb backend = smbpasswd
      smb passwd file = /etc/samba/smbpasswd
      [Ordner123 (at ElementsUSB4TB)]
      comment = ElementsUSB4TB's Ordner123 in WD Elements 25A1
      path = /tmp/mnt/ElementsUSB4TB/Ordner123
      dos filetimes = yes
      fake directory create times = yes
      valid users = admin
      invalid users =
      read list = admin
      write list = admin
      [Ordner XYZ (at ElementsUSB4TB)]
      comment = ElementsUSB4TB's OrdnerXYZ in WD Elements 25A1
      path = /tmp/mnt/ElementsUSB4TB/OrdnerXYZ
      dos filetimes = yes
      fake directory create times = yes
      valid users = admin
      invalid users =
      read list = admin
      write list = admin

      ... und so werden ca 30 weitere Ordner fortlaufend in der smb.conf aufgeführt



      Gruß
      Nerdy

      The post was edited 1 time, last by nerdy ().

    • Das Problem ist das ich die Netzwerkfreigabe nicht speichern kann über dem Netzwerk-Browser und von daher nicht editieren kann ;)
      Der Mount steht nur in der Benutzerverwaltung mit den Login Daten.

      Wenn ich nur wüsste in welcher Config-Datei auf dem Router das festgelegt ist, dass den Clients beim Aufruf nur die Ordner angezeigt werden und nicht die HD selbst voll zur Verfügung gestellt wird. Dann könnte man es vielleicht ändern. Wobei ich gemerkt habe, wenn ich z.B. die original smb.conf mit Vi ändere, ist die Änderung nach einem reboot wieder verschwunden. Auf einer Festplatte liegen im Hauptverzeichnis eine menge Text und Video Dateien, die werden über cifs und FTP einfach nicht angezeigt. Nur innerhalb der angezeigten Ordner kann ich einzelne Dateien sehen und aufrufen.

      So wie es aussieht werden auch über NFS nur die Ordner exportiert und angezeigt. Ist echt komisch.




      Hier noch zum Vergleich die SMB.CONF vom Asus RT-N18U (Fresh Tomato):

      [global]
      interfaces = br0
      bind interfaces only = yes
      enable core files = no
      deadtime = 30
      smb encrypt = disabled
      min receivefile size = 16384
      workgroup = WORKGROUP
      netbios name = unknown
      server string = TomatoUSB
      dos charset = ASCII
      unix charset = UTF8
      display charset = UTF8
      guest account = nobody
      security = user

      guest ok = no
      guest only = no
      browseable = yes
      syslog only = yes
      timestamp logs = no
      syslog = 1
      passdb backend = smbpasswd
      encrypt passwords = yes
      preserve case = yes
      short preserve case = yes
      load printers = no
      printing = bsd
      printcap name = /dev/null
      map archive = no
      map hidden = no
      map read only = no
      map system = no
      store dos attributes = no
      dos filemode = yes
      strict locking = no
      oplocks = yes
      level2 oplocks = yes
      kernel oplocks = no
      use sendfile = yes
      max protocol = SMB2
      socket options = TCP_NODELAY SO_KEEPALIVE IPTOS_LOWDELAY SO_RCVBUF=65536 SO_SNDBUF=65536
      use sendfile = no

      [jffs]
      path = /jffs
      writable = yes
      delete readonly = yes
      force user = root
      comment = JFFS

      [root$]
      path = /
      browseable = no
      comment = Hidden Root

      [dreambox]
      path = /tmp/mnt/dreambox
      comment = dreambox
      writable = yes
      delete readonly = yes
      force user = root

      [ElementsUSB4TB]
      path = /tmp/mnt/ElementsUSB4TB
      comment = ElementsUSB4TB
      writable = yes
      delete readonly = yes
      force user = root

      Wenn ich die im RT-AC86U verwende wird nur eine leere Seite angezeigt oder es kommt eine Fehlermeldung wg Verzeichnis nicht gefunden, Verbindung abgelehnt ...

      Ich würde den Router gern behalten, weil die openvpn geschwindigkeit im Down- und Upload quasi genauso schnell ist wie ohne VPN. Der alte Router hat nur einen Bruchteil davon geschafft.
      Nur ohne richtige cifs / nfs NAS-Funktion macht es nicht wirklich Sinn.
    • In der Fstab und automount.xml stehen nur die alten Einträge vom rt-N18U, die aber quasi identisch sein müssten mit dem neuen Router. Die Router IP und HD-Orte haben sich nicht geändert.
      Er findet ja die Freigabe, klappt sie aber nicht aus wie bei der Freigabe von anderen Geräten und somit kann er sie nicht abspeichern.

      Wenn er die Freigabe ausklappen würde, müsste er dann ja ca 30+ Ordner anzeigen, die alle einzeln gemountet werden müssten?

      Wenn die DM900 da nicht gleich mal mit einem GS abraucht? :/ ;)
    • hmich wrote:

      Die alten Mounts aus der automounts manuell löschen, Neustart und anschließend mit dem Netzwerkbrowser neu mounten.


      Das selbe in grün. Wenn ich auf die Freigabe gehe und OK drücke passiert nicht. Habe noch die Hds am Router abgeklemmt, über SSH die Mounts und autocreated-dir gelöscht und einen Usb-Stick und eine SSD über das WebIf vom Asus formatiert.
      Dachte es liegt vielleicht daran das Asus kein ext unterstützt, weil in den Format-Optionen nur Fat/Ntfs und HFS angeboten werden. Aber auch mit Fat oder Ntfs werden nur die Ordner im Netzwerk angezeigt und nicht die HD an sich inkl Rootverzeichnis. Die frisch formatierte HD-Freigabe ist auch erst im Netzwerk sichtbar wenn über das Webif mindestens ein Ordner darauf erstellt wird. Wenn man 100 Ordner und mehr erstellt, die werden alle automatisch vom System sofort in die smb.conf eingetragen.
    • Das ist definitiv ein Eigenart des Asus Routers. So eine merkwürdige SMB Darstellung habe ich bis jetzt noch nicht gesehen. Aber ob das jetzt mit der Stromversorgung zusammen hängt? Die Geräte laufen ja.
      Die 2 Seiten in der Bedienungsanleitung die auf Deutsch sind, enthalten nur Bilder, was die Anschlüsse zu bedeuten haben. Vor dem Kauf habe ich mich noch beim Verkäufer und beim Asus Support wg Linux-Unterstützung (ext) erkundigt. Konnten mir beide nicht beantworten.

      Also weiter suchen... :)

      Danke euch.