Aufnahme auf NAS nicht möglich mit Automount

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Aufnahme auf NAS nicht möglich mit Automount

      Hallo,

      ich bitte um Hilfe bei meinem Problem.
      Da ich anfangs nicht wusste, ob das Problem in Richtung NAS oder Dreambox geht, hatte ich das Thema bereits im Qnap Forum und bin auch schon ein Stück weiter.
      Nun denke ich jedoch, das das Problem in Richtung Dreambox bzw. meinen Einstellungen darin geht.
      Daher setze ich das Thema nun auch hier rein, mit der bisherigen Erkenntnis.

      Worum geht es:
      Seit mehreren Monaten funktionierte bei mir die Aufnahme von der Dreambox auf das NAS problemlos.
      Nachdem ich nun aber bei mir im Netzwerk ein paar Sachen umgestellt habe ( Unifi USG mit Aufteilung verschiedener VLAN's und damit neuen IP Adressen, will die Aufnahme nicht mehr funktionieren. Will ich einen Aufnahmepfad einstellen kommt beim speichern immer der Fehler:

      "Das Verzeichnis /media/Record/ ist nicht beschreibbar."

      Wichtig:
      - IP Dreambox: 10.1.2.3
      - IP NAS 192.168.1.4
      Beide Systeme können sich untereinander anpingen.

      Was habe ich nach der Umstellung getan:
      - Im Qnap den bei den NFS Freigaben für /Record die neue IP Adresse der Dreambox eingetragen.
      - in der Dreambox bei der Aufnahme Freigabe die IP NAS geändert.

      a) Manueller Mount mit einem Test Verzeichnis: nfs
      Ich hatte bereits mal versucht manuell ein test-Verzeichnis zu mounten über die Konsole:
      mkdir /media/nfs
      mount -t nfs 192.168.1.4:/Record /media/nfs
      Hier kam keine Fehlermeldung.

      b) Versuch ob nfs-Verzeichnis ist beschreibbar
      root@dm920:/media/nfs$ touch /media/nfs/test.txt
      root@dm920:/media/nfs$ ls
      @Recycle test.txt
      Also, das Verzeichnis ist beschreibbar.

      c) Manueller Mount des eigentlichen Aufnahmeverzeichnisses
      Warum klappt der automatische Mount von /Record nicht über den Mount Manager?
      root@dm920:/media/nfs$ touch /media/Record/test.txt
      touch: /media/Record/test.txt: No such device
      root@dm920:/media$ ls
      Aufnahme QNAP463 Record hdd hdd-int nfs

      Mounte ich /Record wieder manuell, klappt es auf einmal auch mit dem Anlagen der Aufnahmepfade.

      root@dm920:/media$ cd Record/
      -bash: cd: Record/: No such device
      root@dm920:/media$ mount -t nfs 192.168.1.4:/Record /media/Record/
      root@dm920:/media$ touch /media/Record/test.txt
      root@dm920:/media$ cd Record/
      root@dm920:/media/Record$ ls
      @Recycle test.txtSo sieht es im Mount Manager aus:



      Die Freigabeoptionen habe ich nicht verändert.


      Hat jemand eine Idee, warum der automatische Mount nicht funktioniert, bzw. was ich weiter testen kann?

      Danke schonmal!

      The post was edited 1 time, last by Mosconi ().

    • sorry für die späte Rückmeldung.
      Hier erstmal die automounts.xml

      root@dm920:/etc/enigma2$ vi automounts.xml

      <?xml version="1.0" encoding="UTF-8"?>
      <mountmanager>
      <nfs>
      <mount>
      <active>False</active>
      <hdd_replacement>False</hdd_replacement>
      <ip>192.168.0.1</ip>
      <sharename>Sharename</sharename>
      <sharedir>/export/hdd</sharedir>
      <options>rw,tcp,nolock,no_squash</options>
      </mount>
      </nfs>
      <nfs>
      <mount>
      <active>True</active>
      <hdd_replacement>False</hdd_replacement>
      <ip>192.168.1.4</ip>
      <sharename>Record</sharename>
      <sharedir>/Record</sharedir>
      <options>rw,tcp,nolock,no_root_squash</options>
      </mount>
      </nfs>
      </mountmanager>


      Hier der Inhalt der fstab:

      root@dm920:/etc$ vi fstab

      rootfs / rootfs rw,relatime 0 1
      proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
      sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
      devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620 0 0
      tmpfs /dev/shm tmpfs rw,nosuid,nodev,relatime 0 0
      tmpfs /run tmpfs rw,nosuid,nodev,relatime,mode=755 0 0
      tmpfs /tmp tmpfs rw,relatime 0 0
      tmpfs /var/volatile tmpfs rw,relatime,mode=755 0 0
      /dev/disk/by-label/dreambox-data /data auto noauto,x-systemd.automount,nofail 0 0
      192.168.1.4:/Record /media/Record nfs udp,x-systemd.automount,retrans=4,tcp,noauto,x-systemd.idle-timeout=60,retry=0,nolock,no_root_squash,rw,x-systemd.device-timeout=15,t
      ~
    • sieht eigentlich gut aus

      was mir auffällt:
      Im Screenshot des Freigabemanagers steht bei Server Freigabe: /media/Record

      in der automounts.xml und fstab aber nur /Record

      ist das jetzt auch noch so?

      Sonst lösch mal die automounts.xml und die Zeile(n) mit den nfs mounts aus der fstab und starte die Box neu und mach dann nochmal alles neu
      Wie gesagt, der Mountmanager ist manchmal etwas buggy ...

      Alternativ nur über die fstab mounten und den Netzwerkbrowser/Mountmanager aussen vor lassen, dann wird auch keine automounts.xml erstellt bzw. befüllt.
      Die mount points muss man aber selbst erstellen - das übernimmt sonst der Netzwerkbrowser/Mountmanager oder wie man das Tool auch immer nennen mag
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox
    • Ja, gehe ich über den Netzwerkbrowser findet dieser das Verzeichnis unter /Record
      Über SSH auf der Dreambox finde ich das Verzeichnis unter /media/Record. So war es auch vor der Umstellung immer und hatte funktioniert.

      Dann mach ich mich mal ans Werk deines ersten Vorschlags und schaue, was rauskommt.Ich melde mich wieder.

      Danke
    • /media/Record entsteht, weil du als "Lokaler Freigabename" "Record" angeben hast. Das ist dann dein lokaler Mountpunkt.

      Die Frage ist aber, wie der Pfad auf dem NAS heißt? Das kann zufällig auch /media/Record sein, ist bei den meisten NAS aber eher was anderes ;)
    • Sodoele, wie wir im Schwabenland sagen ....

      1. automounts.xml wurde gelöscht.
      2. fstab Eintrag gelöscht.
      3. Neustart.
      4. Habe dann versucht über den Netzwerkmanager das Ursprüngliche Verzeichnis "Aufnahme" zu mounten.
      5. Ein erster Test, die Aufnahmepfade zu ändern, war leider erfolglos.
      6. Habe dann den Mount nochmal manuell nachgezogen."mount -t nfs 192.168.1.4:/Aufnahme /media/Aufnahme"
      7. Die Aufnahmepfade waren dann speicherbar. Hurra
      8. Box neugestartet und gehofft, dass der mount bestehen bleibt, so wie es bei /Record war. Leider hatte ich keinen Zugriff mehr auf das Verzeichnis /media/Aufnahme.

      Nochmal der Auszug aus der automounts.xml:
      <?xml version="1.0" encoding="UTF-8"?>
      <mountmanager>
      <nfs>
      <mount>
      <active>True</active>
      <hdd_replacement>False</hdd_replacement>
      <ip>192.168.1.4</ip>
      <sharename>Aufnahme</sharename>
      <sharedir>/Aufnahme</sharedir>
      <options>rw,tcp,nolock,no_root_spuash</options>
      </mount>
      </nfs>
      </mountmanager>

      Hier der Auszug aus der fstab:

      GNU nano 2.2.5 File: fstab Modified

      rootfs / rootfs rw,relatime 0 1
      proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
      sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
      devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620 0 0
      tmpfs /dev/shm tmpfs rw,nosuid,nodev,relatime 0 0
      tmpfs /run tmpfs rw,nosuid,nodev,relatime,mode=755 0 0
      tmpfs /tmp tmpfs rw,relatime 0 0
      tmpfs /var/volatile tmpfs rw,relatime,mode=755 0 0
      /dev/disk/by-label/dreambox-data /data auto noauto,x-systemd.automount,nofail 0 0

      192.168.1.4:/Aufnahme /media/Aufnahme nfs udp,x-systemd.automount,retrans=4,tcp,noauto,no_root_spuash,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,timeo=5,vers=3,soft,nofail 0 0

      Ich bin ratlos. Würde es etwas bringen, das Vorhaben ohne die automounts.xml umzusetzen?
      Gibt es ein Log, wo man mehr draus lesen kann?
    • Hi,

      Also viele haben immer wieder das Problem mit der Aufnahme auf das NAS.

      Wie ist die NAS HDD Konfig. Raid ?

      Sollte es ein Raid sein da fehlt etwas beim Mount Point (volume oder volume1).

      Normal sieht es anders aus. (siehe Bild)
      Am NAS die Freigaben auch eingerichtet richtig ?

      Bei mir handelt es sich um ein Synology NAS mit Raid 5, eingerichtet wurde alles mit dem Netzwerkbrowser v. Feed.
      Diese settings sind bei mir Aktiv bei DM800v2, DM820; DM900, DMTwo

      Kannst du aus dem VLAN wo die DM steht auch das NAS pingen,tracert ?
      Kann es sein das dein VLAN Tag nicht vorhanden ist !!!
      Schreibberechtigungen auf dem NAS, da die Box aus einem anderen Netz kommt !!!
      Ich frage nur deswegen weil die UniFi Software viele dinge von selbst macht, der User klickt nur ein hackerl an.

      Auszug der Datei "automounts.xml"

      XML Source Code

      1. <?xml version="1.0" encoding="UTF-8"?>
      2. <mountmanager>
      3. <nfs>
      4. <mount>
      5. <active>True</active>
      6. <hdd_replacement>True</hdd_replacement>
      7. <ip>XXX.XXX.XXX.XXX</ip>
      8. <sharename>NASAufnahmen</sharename>
      9. <sharedir>/volume1/Aufnahmen/Wohnzimmer/</sharedir>
      10. <options>rw,nolock,tcp</options>
      11. </mount>
      12. </nfs>
      13. </mountmanager>
      Display All
      Images
      • mount.JPG

        24.85 kB, 520×166, viewed 19 times
      • freigabe.JPG

        29.84 kB, 522×194, viewed 17 times
      • aufnahmepfade.JPG

        23.68 kB, 519×139, viewed 18 times
      • NAS.JPG

        69.14 kB, 819×242, viewed 20 times
      Kannst Du nicht, willst Du nicht.......hast Du schon :P
      Zitat: »Wer zu lesen versteht, besitzt den Schlüssel zu großen Taten, zu unerträumten Möglichkeiten.«

      The post was edited 3 times, last by Darksniper ().

    • Ich glaube nicht, dass es an den Schreibberechtigungen liegt

      Beim manuellen mount kann auf den share ja schreiben, nur nicht dann wenn er den Share über den Netzerkbrowser mountet - zumndest lt. Beitrag #1

      Ich vermute einen logischen Fehler, er hat ja die Netzwerkwerkkonfiguration geändert - danach ging es nicht mehr
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox

      The post was edited 1 time, last by Fred Bogus Trumper ().

    • @Darksniper: Ich habe zwar auf dem NAS (Qnap) eine Raid Verbund laufen, dies betrifft aber andere Festplatten.
      Auch hatte es zuvor ja problemlos funktioniert.Raid hin, Raid her....
      Anpingen kann ich von der Dreambox das NAS und auch andersrum.
      Im Netzwerkbrowser der Dreambox kann ich ja auch die Freigabeverzeichnisse vom NAS alle sehen, wenn ich die NAS IP eingebe und durchsuchen lasse.
      Mein Baugefühl sagt mir, dass das Problem wahrscheinlich nicht auf der NAS Seite liegt. Denn über einen manuellen mount klappt das einbinden der Verzeichnisse ja. Komisch war nur, als ich noch das Test_Verzeichnis /Record (NAS) angelegt hatte, hat der automatische mount anfangs auch nicht funktioniert. Nachdem ich dann aber einmal das Verzeichnis manuell gemountet hatte, blieb der mount auch nach dem Box Neustart bestehen. Das will nur bei dem /Aufnahme Verzeichnis nicht klappen. Immer manuell mounten ist auch keine Lösung.
    • New

      Ich hatte mal ähnliche unerklärliche Phänomene. Versuch doch mal auf deinem Qnap unter Systemsteuerung / Netzwerk- und Dateiservices / Win_Mac_NFS in der Registerkarte NFS den NFS-V4-Dienst zu aktivieren. Auf der Dreambox fügst du dann noch im Mountmanager bzw. Freigabenverwaltung in der Zeile Freigabeoption "vers=4" ein.
      Mit NFS in der Version 4 lief es bei wieder, warum verstehe ich auch nicht, aber Hauptsache läuft.
    • New

      @Mosconi
      Ich frage nur die Basics ab. Sicher ist sicher.
      Wenn laut deinen angaben soweit alles passt an NAS usw. Wüsste ich nicht wo das Problem sein könnte.

      Was mir nur aufgefallen ist bei deiner ausgabe der Informationen ist folgendes:
      Bei "<sharedir>/Aufnahme</sharedir>"
      Normal sollte es so aussehen "<sharedir>/Aufnahme/</sharedir>"

      Ist der "movie" Ordner vorhanden ?


      Die Info von "goliath" ist auch eine gute Info, aber "vers=4" ist ja schon länger vorhanden. Ich gehe davon aus das dieses aktiv ist. Aber laut aussage passt das NAS ja !!!


      Ich habe extra meine Bilder und Infos dazu gepostet.


      Absolut sicher das alles richtig eingestellt ist ? Abgesehen davon, Netzwerk änderungen ?


      Aber man kann es ja ganz einfach Testen. Die DM in das NW direkt hängen wo das NAS ist. Wenn alles geht gut.
      Wenn nicht fehler generell vorhanden.

      Ansonsten einfach Backup der DM erstellen, Neu flashen und Testen.

      Dann kann man schritt für schritt fehler ausschließen. Sonst ist das wie Rätselraten.
      Kannst Du nicht, willst Du nicht.......hast Du schon :P
      Zitat: »Wer zu lesen versteht, besitzt den Schlüssel zu großen Taten, zu unerträumten Möglichkeiten.«
    • New

      vermutlich wird mit unterschiedlichen (default) Optionen gemountet, ich glaub Enigma2 gibt da etwas anderes mit als über die Konsole gemountet
      Jedenfalls verwendet der Netzwerkbrowser default das udp Protokoll und mount in der Konsole tcp - wenn ich mich richtig erinnere
      vielleicht gibt es auch noch andere Unterschiede


      Box mit eingerichtetem Network share booten - falls nötig
      dann das mount Verzeichnis des shares betreten und die mount Optionen abfragen

      Source Code

      1. root@dm900:~# cd /media/DHS/vol2
      2. root@dm900:/media/DHS/vol2# mount|grep vol2
      3. systemd-1 on /media/DHS/vol2 type autofs (rw,relatime,fd=37,pgrp=1,timeout=60,minproto=5,maxproto=5,direct)
      4. 192.168.178.9:/media/vol2 on /media/DHS/vol2 type nfs (rw,relatime,vers=3,rsize=524288,wsize=524288,namlen=255,soft,nolock,proto=tcp,timeo=5,retrans=4,sec=sys,mountaddr=192.168.178.9,mountvers=3,mountport=46204,mountproto=tcp,local_lock=all,addr=192.168.178.9)
      5. root@dm900:/media/DHS/vol2#

      dann denn nfs share nochmal manuell z.B. nach /tmp/nfstest mit mount -t nfs mounten und dann wieder mit mount die verwendeten Optionen abfragen wenn der Schreibzugriff funktioniert und dann die beiden Ausgaben vergleichen

      vielleicht findest du so den Unterschied und kannst dann die mountoptionen im Netzwerkbrowser/automounts.xml anpassen - oder gleich in der fstab

      ich mounte übrigens manuell nur über die fstab - und lasse die Netzwerkbrowser/automounts.xml Baustelle aussen vor
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox

      The post was edited 1 time, last by Fred Bogus Trumper ().

    • New

      erstmal Danke für eure Hilfestellung.

      @goliath: Hatte gleich mal nachgeschaut, welche Einstellung bei mir im NAS vorhanden war. NFS2/3 war deaktiviert und nfs4 war aktiviert. Hatte nun mal vorsichtshalber nfs V2/3 aktiviert und für nfs V4 der Baustein in die Freigabeoption mit übernommen. Aber auch nach einem Neustart konnte er noch nicht auf das Verzeichnis zugreifen.

      @Darksniper: Habe sicherheitshalber in der automounts.xml nochmal die Anpassung gemacht:
      <sharedir>/Aufnahme/</sharedir>
      Leider hat das aber auch keine Veränderung gebracht.

      Bzgl. "movie" Ordner: Wo sollte der sein? Bzw. wie komme ich da hin?
      Ich denke schon, dass ich alles im NAS richtig eingestellt habe. So viel ist das ja schließlich auch nicht.
      Werde morgen nochmal das NAS und die Dream ins gleiche Subnetz hängen um das Thema auszuschließen.

      @Fred Bogus Trumper:
      Ausgabe (manuell mount von Aufnahme)
      root@dm920:/media/Aufnahme$ mount|grep Aufnahme
      systemd-1 on /media/Aufnahme type autofs (rw,relatime,fd=27,pgrp=1,timeout=60,minproto=5,maxproto=5,direct)
      192.168.1.4:/Aufnahme on /media/Aufnahme type nfs4 (rw,relatime,vers=4.2,rsize=524288,wsize=524288,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=10.1.2.3,local_lock=none,addr=192.168.1.4)

      Ausgabe (manuell mount von nfstest)
      root@dm920:/tmp/nfstest$ mount|grep nfstest
      192.168.1.4:/Aufnahme on /tmp/nfstest type nfs4 (rw,relatime,vers=4.2,rsize=524288,wsize=524288,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=10.1.2.3,local_lock=none,addr=192.168.1.4

      Aus der rot markierten Zeile werde ich zwar nicht richtig schlau, aber mehr weil ich nicht verstehe, warum diese Zeile nicht im unteren Teil von nfstest steht. Obwohl ich mit dem manuellen mount auf beide Verzeichnisse zugreifen kann. Kann mir das jemand erklären?
    • New

      der rote Teil betrifft den systemd mount, d.h. der fstab Eintrag wurde automatisch beim boot von systemd gemountet, das fehlt beim manuellen mount

      letzer Versuch

      lösche oder benenne automounts.xml mal um reboote die Box oder starte das remote-fs.target mal neu


      cd /etc/enigma2
      mv automounts.xml automounts.xml.off
      systemctl restart remote-fs.target



      Ist der eingebundene share dann beschreibar?

      Wenn nicht kannst du ja die automounts.xml wieder umbennen

      sonst poste auch noch den aktuellen Eintrag in der fstab für den mount
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox
    • New

      nochmal vielen Dank für die Hilfe, die mir hier zuteil wird. Einfach großartig.

      @Fred Bogus Trumper:
      Habe alles so gemacht, wie von Dir beschrieben.
      Leider hat auch das nicht zum Erfolgt geführt.

      Hier noch der Auszug aus der fstab:


      Source Code

      1. root@dm920:/etc$ nano fstab
      2. GNU nano 2.2.5 File: fstab Modified
      3. ........Habe das mal eingekürzt........
      4. 192.168.1.4:/Aufnahme /media/Aufnahme nfs
      5. udp,x-systemd.automount,retrans=4,tcp,noauto,no_root_squash,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,timeo=5,vers=3,vers=4,soft,nofail 0 0
    • New

      Das wäre mein auszug aus der "fstab" DM900

      Source Code

      1. rootfs / rootfs rw,relatime 0 1
      2. proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
      3. sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
      4. devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620 0 0
      5. tmpfs /dev/shm tmpfs rw,nosuid,nodev,relatime 0 0
      6. tmpfs /run tmpfs rw,nosuid,nodev,relatime,mode=755 0 0
      7. tmpfs /tmp tmpfs rw,relatime 0 0
      8. tmpfs /var/volatile tmpfs rw,relatime,mode=755 0 0
      9. /dev/disk/by-label/dreambox-data /data auto noauto,x-systemd.automount,nofail 0 0
      10. XXX.XXX.XXX.XXX:/volume1/Aufnahmen/Wohnzimmer/ /media/NASAufnahmen nfs udp,x-systemd.automount,retrans=4,tcp,noauto,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,timeo=5,vers=3,soft,nofail 0 0

      Auszug aus der "fstab" DMTwo

      Source Code

      1. rootfs / rootfs rw,relatime 0 1
      2. proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
      3. sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
      4. devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620 0 0
      5. tmpfs /dev/shm tmpfs rw,nosuid,nodev,relatime 0 0
      6. tmpfs /run tmpfs rw,nosuid,nodev,relatime,mode=755 0 0
      7. tmpfs /tmp tmpfs rw,relatime 0 0
      8. tmpfs /var/volatile tmpfs rw,relatime,mode=755 0 0
      9. /dev/dreambox-data /data auto noauto,x-systemd.automount,nofail 0 0
      10. XXX.XXX.XXX.XXX:/volume1/Aufnahmen/Schlafzimmer/ /media/NASAufnahmen nfs udp,x-systemd.automount,retrans=4,tcp,noauto,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,timeo=5,vers=3,soft,nofail 0 0
      Kannst Du nicht, willst Du nicht.......hast Du schon :P
      Zitat: »Wer zu lesen versteht, besitzt den Schlüssel zu großen Taten, zu unerträumten Möglichkeiten.«
    • New

      @Darksniper: Danke für deinen Auszug.

      Auch bei meinen SMB Freigaben, die ich am Mac mounte, steht nirgends das Volume davor. Ich denke, dass das evtl. eine Unterschied QNAP/Synology ist.
      Ansonsten sehe ich erstmal keinen großen Unterschied, oder? NFSV4 nehme ich erstmal wieder raus. Aber auch ohne hatte es ja nicht getan.
      Auch das ändern, dass beide Geräte im gleichen Subnetz sind, brachte keine Verbesserung. ( IP Adressen wurden natürlich in beiden Systemen angepasst.)

      Da das Image aus einem Backup stammt, glaube ich zwar erstmal nicht dran, das das ein Problem ist, aber wer weiß schon....
      Ich werde nachher mal ein neues Image installieren und schauen, ob es dann klappt.
      Ich berichte....