[gelöst] Kein Zugriff mehr auf NAS <My Cloud EX2 Ultra>

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • [gelöst] Kein Zugriff mehr auf NAS <My Cloud EX2 Ultra>

      Hallo,
      ich bin mal wieder am verzweifeln :mauer: .
      Seit ein paar Wochen kann ich von meiner DM920 nicht mehr auf meinen NAS zugreifen. Es handelt sich um einen "My Cloud Expert Series EX2 Ultra" von WD.
      Das ganze lief bestimmt 2 Jahre ohne Probleme, von jetzt auf gleich bekomme ich nur noch einen leeren Ordner angezeigt also außer <Speichergeräteliste> habe ich keine Ordner.
      IP Adresse, Zugangsdaten und Freigaben habe ich jetzt mehrfach kontrolliert.

      Weil das alles keine Besserung brachte und Zeitgleich auch die Timeshift Funktion trotz korrekter Pfade nicht funktioniert hat habe ich gestern die Box einmal komplett neu aufgesetzt (newnigma2-deb-weekly-OE2.5-dm920-02_05_2021.tar.xz).
      Timeshift funktioniert. NAS immer noch das gleiche Problem.

      Ich habe den Server über den Netzwerkbrowser gefunden und eingerichtet und wieder genau das gleiche Problem.
      Finde die Anleitung vom letzten mal leider nicht mehr. Aber laut dem YouTube Video von Dreamscreencast müsste es funktionieren.

      Ich will nicht auf den NAS aufnehmen oder sonst was. Ich möchte nur auf Videos die ich dort abgelegt habe zugreifen.

      Liebe Grüße und schon mal danke für die Mühe die ich mache. :denk:

      EDIT: Timeshift funktioniert nur wenn man vorher umgeschaltet hat
      Der Weg ist das Ziel

      Wer Schreibfehler findet, darf sie behalten

      The post was edited 4 times, last by Wolli2014 ().

    • Teste das mal "interaktiv" in einer telnet/ssh Session:


      Source Code

      1. mount -t cifs //192.168.1.163/02-Filme/ /mnt -o user=dreambox-dm920
      Dann sollte interaktiv das Passwort abgefragt werden. Wenn das klappt, dann sollte was unter /mnt gemountet sein.
      /mnt ist erstmal nur ein temporärer Mountpunkt zum testen.

      Was passiert dann?

      Im übrigen würde ich für eine Dreambox das Protokoll NFS vom NAS benutzen.
    • Hallo,

      sowas hatte ich schonmal bei meinem QNAP-NAS. Das Problem war aber nicht die dreambox mit newnigma2, sondern die NAS Konfiguration. Es reichte nicht aus, der dreambox einfach nur ein allgemeines Zugriffsrecht auf das NAS zu gewähren, sondern jeder einzelne Ordner benötigte eine spezielle Freigabe für die dreambox, den man mit der dreambox nutzen möchte. Da du nicht der erste Nutzer mit derartigen Problemen bist, gibts hier ´ne ganze Menge zu lesen, was dir da weiterhelfen kann. So nutzen auch einige Forenmitglieder ein NAS von WD. Geh doch mal über die Boardsuche.
      Übrigens, wenn dein NAS das NFS Protokoll beherrscht, dann würde ich dieses anstelle von CFIS verwenden. Bin der Meinung, dass NFS einfacher in der Handhabung und ein wenig besser in der perfomance ist. GGfs. muss das im NAS aber erst freigeschaltet werden und vielleicht auch bei der dreambox der NFS-Client als plugin nachinstalliert werden. Kannst ja mal nachsehen über den Paketmanager, ob NFS auf deiner dreambox vorhanden ist. Aber vielleicht haben andere Forenmitglieder da noch bessere Tips.
      Viel Erfolg.

      Edit: AlBundy001 war mit der NFS Empfehlung schneller ^^
      Grüsse aus dem "ganz Nahen Osten" vom Burkhardtsdorfer

      Spendet Rechnerzeit und helft mit bei der Forschung gegen das Coronavirus!
      Macht mit bei Rosetta@home - join rosetta@home
    • Danke für die schnellen Antworten.

      Er will das Passwort haben aber ich kann nichts eingeben:

      Source Code

      1. root@dm920:~$ mount -t cifs //192.168.1.163/02-Filme/ /mnt -o user=dreambox-dm920
      2. sh: systemd-ask-password: command not found
      3. Password for dreambox-dm920@//192.168.1.163/02-Filme/:

      Wenn ich auf Enter drücke kommt:

      Source Code

      1. mount error(95): Operation not supported
      2. Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
      Über NFS habe ich es auch versucht aber auch das habe ich nicht hin bekommen.

      Bei der MyCloud sind die Ordner freigegeben, mehr geht nicht.
      Die Suchfunktion habe ich auch benutzt, aber die Lösung im passendem Thread war das er sich einen anderen Server gekauft hat.
      Der Weg ist das Ziel

      Wer Schreibfehler findet, darf sie behalten

      The post was edited 5 times, last by Wolli2014 ().

    • Grad mal mit meiner DM900 getestet (ich hab das 1. Beispiel von meiner Linux Kiste - das passt wohl nicht exakt zur DM900, da kommt auch "systemd-ask-password: command not found"). Bei mir hat dies funktioniert (für dich angepasst):

      Wie gesagt: Auf meiner Box nutze ich nur NFS.

      Aber so klappt es bei mir mit CIFS:

      Source Code

      1. mount -t cifs //192.168.1.163/02-Filme/ /mnt -o user=dreambox-dm920,password=<dein passwort>,vers=2.0

      Kannst auch mal mit "vers=1.0" oder "vers=3.0" versuchen.


      Über NFS habe ich es auch versucht aber auch das habe ich nicht hin bekommen.
      Naja - mit "nicht hinbekommen" kann man nicht viel anfangen um zu helfen. Bei NFS muss man eigentlich nur die exports für das Netzwerk (oder einzelne IPs) freigeben. User/Passwort gibt es da nicht.
    • Bei mir kommt:

      Source Code

      1. root@dm920:~$ Mount -t cifs //192.168.1.163/02-Filme/ /mnt -o user=dreambox-dm920,password=xxxxxx,vers=2.0
      2. -bash: Mount: command not found
      3. root@dm920:~$ Mount -t cifs //192.168.1.163/02-Filme/ /mnt -o user=dreambox-dm920,password=xxxxxx,vers=1.0
      4. -bash: Mount: command not found
      5. root@dm920:~$ Mount -t cifs //192.168.1.163/02-Filme/ /mnt -o user=dreambox-dm920,password=xxxxxx,vers=3.0
      6. -bash: Mount: command not found

      AlBundy001 wrote:

      Naja - mit "nicht hinbekommen" kann man nicht viel anfangen um zu helfen. Bei NFS muss man eigentlich nur die exports für das Netzwerk (oder einzelne IPs) freigeben. User/Passwort gibt es da nicht.
      Mit NFS habe ich das gleiche Problem. Ordner und Ip ist im Server freigegeben

      Der Weg ist das Ziel

      Wer Schreibfehler findet, darf sie behalten

      The post was edited 1 time, last by Wolli2014 ().

    • mount ... NICHT "Mount ..." !

      Linux unterscheidet groß/klein Schreibung. Das ist ein Kommando des Betriebssystems.


      Test mount NFS im telnet

      mount -t nfs 192.168.1.163:/02-Filme /mnt -o defaults

      Beispiel bei mir:

      Source Code

      1. root@dm900:~# mount -t nfs 192.168.188.21:/NAS /mnt -o defaults
      2. root@dm900:~# df -hT /mnt
      3. Filesystem Type Size Used Avail Use% Mounted on
      4. 192.168.188.21:/NAS nfs4 8.2T 6.3T 1.6T 81% /mnt

      The post was edited 1 time, last by AlBundy001 ().

    • Oh das hat mein Word wohl beim bearbeiten geändert
      CIFS:

      Source Code

      1. root@dm920:~$ mount -t cifs 192.168.1.163/02-Filme/ /mnt -o user=dreambox-dm920,password=xxxxxxx,vers=3.0
      2. mount.cifs: bad UNC (192.168.1.163/02-Filme/)
      3. root@dm920:~$ df -hT /mnt
      4. Filesystem Type Size Used Available Use% Mounted on
      5. //192.168.1.163/02-Filme/
      6. cifs 5.4T 5.4T 13.4G 99% /mnt

      NFS:

      Source Code

      1. root@dm920:~$ mount -t nfs 192.168.1.163:/02-Filme /mnt -o defaults
      2. mount.nfs: access denied by server while mounting 192.168.1.163:/02-Filme
      Danke schon mal für die Unterstützung
      Also liegt es auf jeden Fall am Server oder? Hat jemand Erfahrungen mit der My Cloud?
      Ich finde zwar in einem anderem Forum das Problem aber leider ohne Lösung.
      Die Benutzeroberfläche des Servers lässt leider kaum Einstellungen zu, zumindest finde ich den Fehler nicht.
      Der Weg ist das Ziel

      Wer Schreibfehler findet, darf sie behalten
    • Du musst auch mal *genau* lesen, was ich schreibe! ;)

      Mein Beispiel:

      Source Code

      1. mount -t cifs //192.168.188.1/fritzbox/Dokumente /mnt -o user=<meinuser>,password=<mein passwort>,vers=3.0
      Dein Beispiel:

      Source Code

      1. mount -t cifs 192.168.1.163/02-Filme/ /mnt -o user=dreambox-dm920,password=xxxxxxx,vers=3.0
      Na? Was ist anders? Bei CIFS fängt der Pfad mit "//" an!



      Zu deinen NFS Freigaben am NAS hast Du ja noch keine Angaben gemacht. Das geht doch alles via GUI. Egal welcher Hersteller. Das Protokoll ist ja überall RFC konform. Die Hersteller erfinden da ja nix Neues.
    • Oh sorry. Das kann ich mir auch nicht erklären =O war eigentlich copy and paste

      Source Code

      1. root@dm920:~$ mount -t cifs //192.168.1.163/02-Filme/ /mnt -o user=dreambox-dm920,password=xxxxxxxxx,vers=3.0
      2. root@dm920:~$ df -hT /mnt
      3. Filesystem Type Size Used Available Use% Mounted on
      4. //192.168.1.163/02-Filme/
      5. cifs 5.4T 5.4T 13.4G 99% /mnt

      AlBundy001 wrote:

      Zu deinen NFS Freigaben am NAS hast Du ja noch keine Angaben gemacht. Das geht doch alles via GUI. Egal welcher Hersteller. Das Protokoll ist ja überall RFC konform. Die Hersteller erfinden da ja nix Neues.
      Was brauchst du da an Angaben? Wie gesagt am NAS habe ich sehr wenig Auswahl Möglichkeiten. Habe in der Ordnerfreigabe das Häkchen für NFS Zugriff gesetzt und als Host einmal mit "*" (für alle IP Adressen zulassen) und auch direkt mit der IP von der Dream versucht und ich habe das gleiche Fehlerbild.

      Im GUI habe ich es auch über den Netzwerkbrowser eingerichtet. Da findet er auch alles.
      Der Weg ist das Ziel

      Wer Schreibfehler findet, darf sie behalten
    • CIFS hat einen Freigabenamen (bei Dir 02-Filme). Der manuelle Mount klappt ja nun auch.
      Warum es über den Netzwerkbrowser nicht mag - keine Ahnung.

      NFS will den kompletten Pfad der Freigabe. Müsste dann laut den Screenshots in der telnet Session eigentlich so klappen:


      Source Code

      1. mount -t nfs 192.168.1.163:/nfs/02-Filme /mnt -o defaults
      Wenn das geht, dann sollte auch über den Browser klappen.
    • Danke für die Hilfe. es hat funktioniert. :freu:
      Wenn ich im GUI die Freigabe über den Browser erstelle setzt er mir die Server Freigabe automatisch auf "/02-Filme" muss aber in dem Fall in "/nfs/02-Filme" geändert werden.
      So ähnlich hatte ich es zwar schon mal versucht, allerdings habe ich ein "/" zu wenig gehabt. :mauer:

      Danke an AlBundy für die Mühe die ich dir gemacht hab :thumbsup:
      Der Weg ist das Ziel

      Wer Schreibfehler findet, darf sie behalten