Zugriff auf aufgenommene Filme sehr langsam

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Zugriff auf aufgenommene Filme sehr langsam

      Moin Zusammen,

      ich bin Umsteiger von der DM7020HD auf die Two. Funktioniert alles super. Bis auf:

      Ich habe mein Synologie-NAS per NFS-Mount als Aufnahmespeicher eingebunden. Auch das funktioniert, Aufnahme und Abspielen. Allerdings dauert der Zugriff auf die aufgenommenen Filme (Also nach Druck auf die PVR-Taste) extrem lange. Erst vergehen 15 Sekunden ohne das etwas passiert, dann kommen die Zahnräder und dann nochmal 10 Sekunden später die Filmliste. Das ging bei der 7020HD wesentlich schneller. Ich hab keine Idee, woran das liegen kann.
      Achso: Das NAS ist nicht im Sleep-Mode.

      Gruß Jörg
    • Könnte an der Anzahl der Filme liegen. Ich nutze AMS und da dauert es auch fast 10 Sekunden bis die Liste kommt. Habe ca. 700 Filme im entsprechenden Verzeichnis.
      Kann mit nicht vorstellen, dass dies auf der 7020HD schneller war. Welches Plugin nutzt Du denn? Wie gemounted - NFS oder CIFS (obwohl das nicht soooo einen Unterschied machen wird)?
    • Hallo,

      ich habe ebenfalls zu große Verzögerungen bei der Filmliste vom NAS (Synology DS211). Bei 66 Filmen dauert es ca. 5s, bis die Liste mal geladen ist. Aus einem anderen Grund (GS bei Neustarts und Idle) habe ich ein älteres Images aus 12-2020 (newnigma2-deb-weekly-OE2.5-dm920-06_12_2020.) geflasht und siehe da, die Liste wurde nun in einer Sekunde geladen. Dann habe ich irgend ein Plugin installiert, ich glaube es war "MovieSelectionQuickButton", und danach dauerte es wieder diese 5s. Ein Update auf das aktuelle Image, das Deinstallieren des Plugin und auch das komplette Löschen und Neuinstallieren der Mounts brachte keinen Erfolg.
      Ich werde demnächst das Ganze noch mal austesten.

      In der aktuellen fstab steht:
      Display Spoiler

      192.168.178.3:/volume1/movie /media/DS_movie nfs x-systemd.automount,rsize=8192,tcp,noauto,wsize=8192,timeo=200,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,retrans=1,soft,nofail 0 0

      192.168.178.3:/volume1/episoden /media/episoden nfs x-systemd.automount,rsize=8192,timeo=200,noauto,wsize=8192,tcp,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,retrans=1,soft,nofail 0 0

      Die Einträge "timeo=200" habe ich später hinzugefügt, die hatten aber keinen Einfluß.

      Da ich häufig auf die Liste des NAS zugreife, nervt mich das natürlich schon... :whistling:

      Im übrigen bin ich von der DM920 doch eher entäuscht, überhaupt was den Bedienungsablauf mit aufgenommen Videos angeht, aber das wurde schon an anderer Stelle beschriebn. Die Stabilität ist ebenfalls unbefriedigend. Meine DM7080 war dagegen ein Musterbeispiel an Stabilität.
      Von den Vorteilen der DM920 gegenüber der DM7080 ist nur noch der wirklich gute FBC-Tuner (DVB-C) und die bessere Reichweite der Fernbedienung übrig geblieben. Das UHD kann ich eh nicht gebrauchen, aus Ermangelung einer 4k-Glotze ;)

      Gruß
      Classic
    • die mountoptionen sind suboptimal, rsize/wsize sind zu gering, zudem handeln sich das NFS Server und Client selbst aus.
      mit r/wsize sollte man erst rumspielen, wenn die performance nicht passt
      timeo würde ich estmal auf 5 setzen

      da der mountmanager gerne bei Änderungen rumzickt (doppelte fstab einträge etc.), beschreibe ich den manuellen weg

      /etc/enigma2/automounts.xml unbennen (z.B. automounts.xml.off)
      eine Sicherungskopie der fstab ertelllen (/etc/fstab.bak)

      dann in der fstab mit einem linux Editor die beiden NFS mount Einträge editieren auf:

      Source Code

      1. 192.168.178.3:/volume1/movie /media/DS_movie nfs x-systemd.automount,tcp,noauto,timeo=5,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,retrans=1,soft,nofail 0 0
      2. 192.168.178.3:/volume1/episoden /media/episoden nfs x-systemd.automount,timeo=5,noauto,tcp,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,retrans=1,soft,nofail 0 0

      danach Box rebooten oder alternativ:
      systemctl daemon-reload
      systemctl restart remote-fs.target




      Wenn die Änderung keine Abhilfe schafft, kann man so einfach wieder zurück:

      automounts.xml.off wieder unbennen in automounts.xml
      die /etc/fstab aus der fstab.bak wieder herstellen (einfach überschreiben)

      dann entweder wieder die beiden systemctrl commands ausführen oder in dem Fall besser rebooten
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox

      The post was edited 1 time, last by Fred Bogus Trumper ().

    • Jo_man wrote:

      Es ist der gleiche Ordner mit den gleichen Freigaben wie auf der vorherigen Box
      Und das sind wie viele Filme?

      Sind auch alle Einstellungen gleich? Ist es auch die gleiche Filmliste?
      Da gibt es massive Unterschiede. Einige lesen beim Start alle Infos aller Filme aus, andere haben eine Datenbank dafür und überhaupt kann man dieses Verhalten in fast allen Fällen konfigurieren.
    • Hallo Fred Bogus Trumper,

      danke für deine Mühe mit den Tipps. Ich habe sie ausprobiert, aber leider hat sich der volle Erfolg nicht eingestellt. Allerdings ist die "Wartezeit" von 5s auf 4s heruntergegangen. Mehr war nicht drin.
      Ich bin so vorgegangen:

      1. Deine Empfehlungen befolgt
      2. beide Lesezeichen entfernt
      3. Nach dem Neustart waren keine Einträge im Mountmanager zu finden
      4. Per Netzwerkbrowser beide Freigaben ausgesucht und aktiviert
      5. Neue Lesezeichen per PVR gesetzt
      PS: Nach ein paar Neustarts, waren die alten Werte wsize und rsize wieder drin. Obwohl ich die auch per Hand schon gelöscht hatte, kamen sie nach einem Neustart wieder... Was für´n tolles System...
      Hier die aktuelle automounts.xml
      Display Spoiler

      <?xml version="1.0" encoding="UTF-8"?>
      <mountmanager>
      <nfs>
      <mount>
      <active>True</active>
      <hdd_replacement>False</hdd_replacement>
      <ip>192.168.178.3</ip>
      <sharename>movie</sharename>
      <sharedir>/volume1/movie</sharedir>
      <options>rw,nolock,tcp</options>
      </mount>
      </nfs>
      <nfs>
      <mount>
      <active>True</active>
      <hdd_replacement>False</hdd_replacement>
      <ip>192.168.178.3</ip>
      <sharename>episoden</sharename>
      <sharedir>/volume1/episoden</sharedir>
      <options>rw,nolock,tcp</options>
      </mount>
      </nfs>
      </mountmanager>


      und hier noch die aktuelle fstab:
      Display Spoiler


      rootfs / rootfs rw,relatime 0 1
      proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
      sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
      devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620 0 0
      tmpfs /dev/shm tmpfs rw,nosuid,nodev,relatime 0 0
      tmpfs /run tmpfs rw,nosuid,nodev,relatime,mode=755 0 0
      tmpfs /tmp tmpfs rw,relatime 0 0
      tmpfs /var/volatile tmpfs rw,relatime,mode=755 0 0
      /dev/disk/by-label/dreambox-data /data auto noauto,x-systemd.automount,nofail 0 0
      /dev/disk/by-uuid/40085129-8e26-41cc-ace0-1fd8f711512e /media/hdd auto auto,nofail 0 0
      192.168.178.3:/volume1/episoden /media/episoden nfs x-systemd.automount,retrans=1,tcp,noauto,wsize=8192,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,timeo=2,timeo=5,rsize=8192,soft,nofail 0 0
      192.168.178.3:/volume1/movie /media/movie nfs x-systemd.automount,retrans=1,tcp,noauto,wsize=8192,retry=0,x-systemd.idle-timeout=60,nolock,rw,x-systemd.device-timeout=15,timeo=2,rsize=8192,soft,nofail 0 0


      Wenn du noch Tipps hast, dann probiere ish sie gerne aus.
      Hinweis noch: Mit der 7080 gab es keine Problem und mit dem Image aus Dez2021 für die DM920 auch nicht, wie oben beschrieben.
      Ich werde über das Wochenende auch noch mal das ältere Image flashen und hier wieder berichten.

      Gruß
      Classic
    • die Blocksize rsize=8182, wsize=8192 steht ja noch immer in der fstab ...

      ich mounte seit der dm800hd die shares meines linux servers inkl. dm7080 und dm9x0 und kenne die Probleme nicht - und mounte alle Boxen mit den selben Optionen über die fstab - den Mountmanager lasse ich aussen vor - die automounts.xml ist also leer

      mein nfs server unterstützt aktuell auch nur NFS Version 3,. vers=3 kann man also wegglassen, wenn der NFS Server eine höhere Version unterstützt

      Source Code

      1. oot@dm7080:~# grep DHS /etc/fstab
      2. 192.168.1.9:/media/vol2 /media/DHS/vol2 nfs ,tcp,rw,x-systemd.device-timeout=15,retrans=4,timeo=5,noauto,x-systemd.automount,vers=3,x-systemd.idle-timeout=60,soft,retry=0,nolock,nofail 0 0
      3. 192.168.1.9:/media/vol3 /media/DHS/vol3 nfs ,tcp,rw,x-systemd.device-timeout=15,retrans=4,timeo=5,noauto,x-systemd.automount,vers=3,x-systemd.idle-timeout=60,soft,retry=0,nolock,nofail 0 0
      4. 192.168.1.9:/media/vol4 /media/DHS/vol4 nfs ,tcp,rw,x-systemd.device-timeout=15,retrans=4,timeo=5,noauto,x-systemd.automount,vers=3,x-systemd.idle-timeout=60,soft,retry=0,nolock,nofail 0 0
      5. root@dm7080:~#
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox
    • Hallo Fred,

      Fred Bogus Trumper wrote:

      die Blocksize rsize=8182, wsize=8192 steht ja noch immer in der fstab ...
      Hatte ich geschrieben, dass die Blocksize bei irgendwelchem Neustart von allein wieder eingetragen wurden. Mit der fstab stehe ich eh auf dem Kriegsfuß, weil Einträge manchmal doppelt oder sogar alte wieder drin stehen.

      Fred Bogus Trumper wrote:

      den Mountmanager lasse ich aussen vor - die automounts.xml ist also leer
      Muß ich dazu irgendeinen Dienst entfernen?
      Denn nachdem ich deine Einträge in die fstab schrieb waren nach einem Reboot keine Einträge im Mountmanager zu finden. Ich mußte sie erst per Netzwerkbrowser suchen und freigeben.

      Für mich fehlen bestimmte Zusammenhänge zwischen Automount, Mount Manager usw. Wenn die Mounts in der fstab eingetragen werden, wozu ist dann noch die automounts.xml nötig? Scheinbar muß man bei Änderungen bestimmte Vorgänge oder Reihenfolgen einhalten. Das finde ich schon verwirrend.
      Mir wäre es persönlich viel lieber, wenn es nur eine Konfigurationsdatei geben würde und Abhängigkeiten vermieden werden würden.
      Ich kriege es ja immer irgendwie auf die Reihe, meine Netzlaufwerke zu mounten, aber manchmal gibt es, wie jetzt bei der DM920, Probleme oder unbefriedigende Zustände. Auch das es Unterschiede in den Images gibt, erklärt sich mir nicht. Vllt. sind es unterschiedliche NFS-Treiber o.ä.?

      Gruß
      Classic
    • lies die nochmal meinen ersten Beitrag durch - von "Lesezeichen" entfernen stand da nichts geschrieben, ich weiß auch nicht 100% was du damit gemeint hast

      Der Mountmanager/Netzwerkbrowser schreibt die mount Optionen zuerst in die /etc/enigma2/automounts.mxl und daraus wird der Eintrag in der fstab generiert. De Netzwerkfreigaben werden dann mit system-d mit den Einträgen in der fstab gemountet. system-d interessiert die automounts.xml überhaupt nicht ...

      D.h. wenn du die automounts.xml wie beschrieben nicht unbenennst oder löscht, wird der Eintrag in der fstab bei jedem Enigma2 Neustart überprüft und gegebenenfalls aus der automounts.xml neu geschrieben und im worst case werden doppelte und sogar abweichende Einträge generiert


      Deshalb nochmal: automounts.xml komplett löschen oder umbenennen. Alternativ alle mounts im Netzwerbrowser löschen - dann sind aber auch die Einträge in der automounts.xml und in der fstab weg - also vorher sichern

      die fstab wie beschrieben ändern - also die r/wize Einträgen entfernen, rebooten

      nach reboot kontrollieren, ob die fstab Einträge unverändert sind, also ohne r/wsize Optionen - dann handeln sich der NFS Server und Client die beste blocksize selbst aus. Erst wenn das nicht wie gewünscht funktioniert, sollte man an der blocksize in den Optionen über rsize= , wsize= "schrauben" um die Performance zu optimieren.

      d.h. man kann wie früher im OE2.0 mit autofs im OE2.5/OE2.6 mit system-d über die fstab mounten - ohne GUI und Netzwerkbrowser. Dieser sollte alles vereinfachen, tut es aber im Grunde nicht, weil er immer wieder komische Sachen macht. Wie z.B. default mit rsize=8182, wsize=8192 zu mounten. Das kommt aus Enigma2 - in deiner automounts.xml steht das nicht ...
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox

      The post was edited 2 times, last by Fred Bogus Trumper ().

    • Hallo Fred,

      ich bin deinen Vorschägen natürlich genauesten gefolgt. Die "Lesezeichen" habe ich erst später, als sich keine Besserung einstellte, testweise gelöscht und wieder neu gesetzt.
      Nach dem ersten Reboot waren die Einstellungen in der fastb noch ok, aber nach einem Neustart waren wieder die Blocksize ohne mein Zutun eingetragen.
      Ich werde die Tage das von mir erwähnte ältere Imgage von 12/2020 testen.

      Vielen Dank für deine Mühe... :thumbup:

      Gruß
      Classic
    • Hallo Fred,

      ich habe es noch mal getestet.
      1. automounts.xml umbenannt
      2. fstab editiert
        - die r/wize Einträge entfernt
        - und zusätzl. noch vers=3 hinzugefügt (hatte ich irgendwo gelesen ;)
      3. Nach einem Neustart sind in der fstab meine Änderungen erhalten geblieben.
        Allerdings ist jetzt nach einem Neustart keine neue automounts.xml erstellt worden
      Fazit: Nun baut sich die Filmliste in 1,5s auf - SUPER.. :thumbup:

      Hier der aktuelle Inhalt der fstab:
      Display Spoiler

      rootfs / rootfs rw,relatime 0 1
      proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
      sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
      devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620 0 0
      tmpfs /dev/shm tmpfs rw,nosuid,nodev,relatime 0 0
      tmpfs /run tmpfs rw,nosuid,nodev,relatime,mode=755 0 0
      tmpfs /tmp tmpfs rw,relatime 0 0
      tmpfs /var/volatile tmpfs rw,relatime,mode=755 0 0
      /dev/disk/by-label/dreambox-data /data auto noauto,x-systemd.automount,nofail 0 0
      /dev/disk/by-uuid/40085129-8e26-41cc-ace0-1fd8f711512e /media/hdd auto auto,nofail 0 0
      192.168.178.3:/volume1/episoden /media/episoden nfs x-systemd.automount,retrans=1,tcp,noauto,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,timeo=2,timeo=5,vers=3,soft,nofail 0 0
      192.168.178.3:/volume1/movie /media/movie nfs x-systemd.automount,retrans=1,tcp,noauto,x-systemd.idle-timeout=60,retry=0,nolock,rw,x-systemd.device-timeout=15,timeo=2,vers=3,soft,nofail 0 0


      Vielen Dank noch mal...

      @Jo_man
      Entschuldige bitte, dass ich deinen Thread gekapert habe, aber vllt. hilft das Ergebnis dir ja auch.. :blumen2:

      Gruß
      Classic

      The post was edited 1 time, last by Classic ().