NSF Freigaben, wo werden sie gespeichert

    • NSF Freigaben, wo werden sie gespeichert

      Hallo, habe ein kleines Problem und komme nicht so recht weiter. Habe in meinen Netzwerk einige Geräte und ein neues NAS hinzugefügt und wollte nun die neuen IP Adressen auf der Box (DMOne) Händisch anpassen. Leider finde ich aber die entsprechenden Einträge nicht.

      In den üblichen "Verdächtigen" etc/fstab, etc/enigma2/automount.xml bzw. etc/autonetwork steht nichts drin bzw. hatte ich vorher mal alles raus gelöscht. Nun ist dort wie gesagt alles leer.

      Aber in/unter media/ werden die Mountpunkte dennoch angezeigt und sind auch erreichbar (bis eben die neuen die ich gern Händisch hinzufügen wollte). Box wurde auch komplett neu gestartet nach den besagten Entfernen und steht jetzt auch nichts drin. Woher holt er sich denn dann die Mountpunkte bzw. wo kann ich sie finden um dann eben händisch die neuen noch hinzufügen zu können? Beim bearbeiten/rauslöschen hatte ich vorher mit systemctl stop enigma2 das Enigma gestoppt.

      Sag schon mal Danke. Vielleicht hat ja einer den "Richtigen" Tipp für mich und kann mir sagen wo ich suchen muss.
    • Joey wrote:

      Ein Mountpunkt ist ein Verzeichnis. Das kannst du erstellen oder löschen und hat erstmal nichts damit zu tun ob dort etwas eingehängt ist oder nicht oder was in der fstab oder automounts steht:

      mkdir /media/sdcard
      rm -r /media/sdcard
      das ist mir schon klar. Ich hatte ein "altes" NAS entfernt und habe nun ein neues NAS das ich aber gern händisch, also ohne über die Box gehen zu müssen wie z.B. Netzwerkbrowser etc. hinzufügen. Könnte es ja auch direkt an der Box über den Freigabemanager machen und eine neue Freigabe hinzufügen, wollte ich aber bewußt nicht so machen.

      Die Box muss doch irgendwoher die Mounteinträge herholen, da ja unter media wie gesagt alle ehemaligen Mountpunkte (die mal in der fstab oder unter etc/enigma2 in der automount.xml standen, jetzt aber alle raus sind) standen. Er muss sie also noch woanders abspeichern/herholen. Wie gesagt Box wurde auch komplett neu gestartet (nicht nur Enigma2) und nach Neustart sind oben besagte Verzeichnisse auch leer. Dennoch sind die Mountpunkte unter media noch alle da und auch erreichbar.

      Also wo werden sie noch abgespeichert ? Danke

      PS: wenn ich die gemounteteten Verzeichnisse lösche, werden auch die Daten gelöscht in den Verzeichnissen, da sie ja gemountet sind. Das möchte ich unbedingt aber vermeiden.

      PSS: Sorry, Joey Wie man mountet ist mir schon bewußt. Mounts funktionieren ja und kann Problemlos darauf zugreifen, Filme abspielen etc. Meine Frage war aber, wo auf der DMOne bzw. in welchen Verzeichniss der DMOne werden eben diese Mountpunkte abgelegt? Dachte immer in der fstab bzw. in etc/enigma2 in der automount.xml Datei. Beide sind aber leer. Es muss also noch in einen anderen Verzeichniss auf der Box abgelegt sein, ansonsten würden die Mounts ja nicht funktionieren.
      Images
      • mountpunkte.jpg

        201.25 kB, 528×360, viewed 54 times
      • etc-enigma2.jpg

        378.22 kB, 521×602, viewed 49 times
      • fstab.jpg

        122.64 kB, 718×161, viewed 51 times

      The post was edited 2 times, last by magnum1795 ().

    • Sorry, Joey Wie man mountet ist mir schon bewußt. Mounts funktionieren ja und kann Problemlos darauf zugreifen, Filme abspielen etc. Meine Frage war aber, wo auf der DMOne bzw. in welchen Verzeichniss der DMOne werden eben diese Mountpunkte abgelegt? Dachte immer in der fstab bzw. in etc/enigma2 in der automount.xml Datei. Beide sind aber leer. Es muss also noch in einen anderen Verzeichniss auf der Box abgelegt sein, ansonsten würden die Mounts ja nicht funktionieren.
    • Habe es nun selbst hinbekommen. Also erstes Enigma2 stoppen in telnet mit systemctl stop enigma2. Nun per FTP auf die Box nach etc und die nfsmount.config öffnen und nach den Eintrag [ NFSMount_Global_Options ] suchen. Dieser sollte nicht auskommentiert sein. Jetzt diesen Eintrag auskommentieren mit #. Box danach einmal komplett neu starten. Nach Neustart und wieder systemctl stop enigma2 kann man nun in media alle Verzeichnisse löschen die nicht benötigt werden. Jetzt in etc die fstab und in etc/enigma2 auch die automounts.xml Datei bearbeiten. In meinen Fall habe ich das neue NAS hinzugefügt. Anschließend wurde per Telnet die Box wieder komplett neu gestartet. Dazu einfach reboot eingeben und Enter drücken. Nachdem die Box dann komplett neu gestartet wurde, waren alle neu bearbeiten Einträge wieder in media vorhanden und auch richtig gemountet. Zugriff war wieder auf alles möglich inkl. den neu angelegten Einträgen in der fstab und automount.xml.
    • Fred Bogus Trumper wrote:

      anstatt eines reboots kann man die geänderten shares in der /etc/fstab mit systemd einfach neu einlesen

      systemctl restart remote-fs.target

      gilt natürlich nur für Boxen die mit Dream OS / systemd laufen
      Danke dir Fred. Kannst du mir auch eventuell sagen wo die shares noch gespeichert werden wenn in der fstab und automounts.xml keine Einträge vorhanden sind, diese aber vorher mal gespeichert waren und in der nfsconfig der Punkt NFSMount_Global_Options nicht auskommentiert war/ist?

      Hatte nämlich erst die Einträge in beiden Dateien drin, diese dann aber rausgelöscht und Box neu gestartet. Die ganzen (alten) shares waren aber dennoch unter media zu finden und auch aktiv. Heißt also ich konnte darauf zugreifen. Woher hat er sich diese dann geholt? In welcher Datei sind sie denn noch gespeichert? Danke

      PS: im Cache sollten sie doch normalerweise nicht mehr sein wenn Box komplett über Menü neu gestartet wurde. Was hat es mit dem Eintrag NFSMount_Global_Options auf sich? Heißt ja das sie irgendwo noch lokal gespeichert werden.
    • Mir ist kein weiterer Speicherort für systemd mounts bekannt. Der Networkbrowser/Manager schreibt in die automaunts.xml und daraus werden die fstab Einträge generiert

      Der Networkbrowser/Manager ist nach wie vor etwas buggy, d.h. bei (mehrfachen) Änderungen können die Eintrage mehrmals in der fstab stehen - anstatt einmal die letzte Version

      Hast du vielleicht alte settings mit autofs mounst importiert? Schau mal ob du mount Einträge in der /etc/auto.network findest
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox