host key type "ssh-rsa"

    • host key type "ssh-rsa"

      Wie komme ich von Ubuntu (die neue LTS-Version vom April 2022) auf eingma²? Wenn ich die ssh-Verbindung aufbauen möchte, kommt folgendes:

      Source Code

      1. micha@ubuntu:~$ sudo su
      2. [sudo] Passwort für micha:
      3. root@ubuntu:/home/micha# ssh dm920
      4. Unable to negotiate with 192.168.178.19 port 22: no matching host key type found. Their offer: ssh-rsa
      5. root@ubuntu:/home/micha#
      Kann ich einen key vom Typ ssh-rsa auf enigma² erstellen und wenn ja, wie? Früher klappte das, beim erstmaligen Aufruf der ssh-Verbindung wurde das Passwort abgefragt und der key automatisch gespeichert.
    • Auf der Ubuntu Kommandozeile:


      Source Code

      1. ssh-keygen
      Einfach alle Fragen mit "Enter" bestätigen. Es sei, denn Du willst noch ein Passwort für den privaten Schlüssel. Das muss aber IMHO nicht sein.
      Dann findest Du im Verzeichnis ".ssh" die Datei "id_rsa.pub".
      Diesen Inhalt (ist Text) komplett per Copy & Paste in die Datei wie von @Fred Bogus Trumper beschrieben einfügen.
    • ich glaube die uralte Dropbear Version auf der Box macht da die troubles. der beschriebene Weg ermöglichlicht einen ssh login ohne password nur mit dem rsa Schlüssel

      Ich vermute die untuntuversion lässt kein Verbindung zu, weil der rsa host key der dropbear Version auf der Box zu alt ist bzw. rsa von der ubuntu ssh Version nicht mehr supported wird

      versuch mal folgendes - notfalls den hostnamen dm900 durch die IP ersetzen

      ssh -o HostKeyAlgorithms=+ssh-rsa root@dm900

      oder

      ssh -i rsa_id root@dm900


      Edit:
      editire mal die ~/.ssh/config des users oder von root - wobei das letzere nicht zu empfehlen ist

      Source Code

      1. Host dm900
      2. HostkeyAlgorithms +ssh-rsa
      3. PubkeyAcceptedAlgorithms +ssh-rsa
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox

      The post was edited 4 times, last by Fred Bogus Trumper ().

    • Also ich hab das eben mal getestet von meinem NAS mit Debian 11 (ok - kein Ubuntu). Ich habe auf der DM900 kein root PW gesetzt. Dort existiert auch keine "authorized_keys" Datei.
      Klappt aber ohne Probleme - hier die komplette Ausgabe:

      Source Code

      1. omv@omv:~$ cat /etc/os-release | grep PRETTY_NAME
      2. PRETTY_NAME="Debian GNU/Linux 11 (bullseye)"
      3. omv@omv:~$ ssh root@dm900
      4. root@dm900:~# id
      5. uid=0(root) gid=0(root) groups=0(root)
    • das hat nichts mit der authorized_keys zu tun - das hatte ich inital verwechselt, weil ich mich vom "ssh-rsa auf enigma² erstellen" auf die falsche Fährte leiten lies

      ssh am ubuntu verweigert den zugriff auf den dropbear client weil rsa disabled wurde

      forum.manjaro.org/t/unable-to-negotiate-with-ssh/87091/3

      openssh.com/txt/release-8.8

      unter "Potentially-incompatible changes" ist der workaround in meinem letzen Beitrag zu finden



      Incompatibility is more likely when connecting to older SSHimplementations that have not been upgraded or have not closely trackedimprovements in the SSH protocol. For these cases, it may be necessaryto selectively re-enable RSA/SHA1 to allow connection and/or userauthentication via the HostkeyAlgorithms and PubkeyAcceptedAlgorithmsoptions. For example, the following stanza in ~/.ssh/config will enableRSA/SHA1 for host and user authentication for a single destination host:

      Host old-host
      HostkeyAlgorithms +ssh-rsa
      PubkeyAcceptedAlgorithms +ssh-rsa
      also am besten über die ~/.ssh/config im userprofil am ubunturechner lösen - für ssh benötigt man weder su noch root Rechte ...
      ein Beispiel kann ich später posten
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox

      The post was edited 5 times, last by Fred Bogus Trumper ().