Sender ARD-Alpha (Livestream) hat keinen Ton!

    • Sender ARD-Alpha (Livestream) hat keinen Ton!

      Moin liebe Gemeinde!

      In meiner letzten Verzweiflung wende ich mich an Euch!
      Bis vor einigen Tagen konnte ich den Sender ARD-Alpha via Livestream noch mit klarem Bild und gutem Ton sehen.
      Dann zeigte mir die 920er den Hinweis, dass es sich um einen „Unbekannten Medientyp“ handelt.
      Ich habe daraufhin neue Livestream-Adressen ausfindig gemacht, die im VLC-Player meines Windoof-Rechners den Ton sauber ausgeben. Nur meine Box kneift dabei! Dort sehe ich nur das Bild! Was ist bei der der ARD los? Hat es möglicherweise etwas mit dem neuen Tonformat „Klare Sprache“ zu tun?

      Die Box betreibe ich mit einer DVB-T2-Antenne…
      Alle anderen Sender die ich zusätzlich noch mit IP-Adressen eingepflegt habe, laufen fehlerfrei (ServusTV, Radio Bremen TV, RBB Brandenburg, Kronehit TV etc.)! Kann mir jemand helfen?

      Mit der iOS-App e2remote Pro kann ich übrigens den Ton von der Dreambox korrekt streamen…

      Einen schönen Sonntag!

      The post was edited 1 time, last by Wuschel789 ().

    • Das ist ja ein interessantes Forum hier! Gibt es denn keine einzige Person, die dazu etwas zu berichten hätte? Das war vor 10 Jahren noch komplett anders! Da konnte man helfen, es wurde geholfen.
      Ist das Thema Dreambox denn schon so gut wie tot?
    • Ich bedanke mich recht herzlich für die Antwort! Von einem „scheiß Forum“ wollte ich jedoch nicht sprechen bzw. schreiben! Und das ich zu diesem Thema in der Vergangenheit schon einmal etwas gepostet habe, ist mir persönlich gedanklich total unter den Tisch gefallen! Ich bitte höflich um Entschuldigung!!! Ich wollte mit meinen Zeilen keinesfalls gegen die Nettikette verstoßen. Ich war nur selbst etwas zu sehr gefrustet, dass ich mit dem Thema nicht so recht weiterkam. Mag sein, dass sich das auf meinen Text ein wenig zu sehr übertragen hat…
      Sorry!!!

      Herzlichen Dank für den Link!!!
    • Man kann mit ffmpeg (ist auf dre dm9x0 in der regel installiert) HLSv4-7 Streams (video und audio getrenntes manifest) video m3u8 und audio m3u8 schön mergen und als ts ausgeben, was die dm9x0 dann mit Bild+Ton ausspielt.

      Das ist der aktuelle Inhalt der master.m3u8 von ARD Alpha -> mcdn.br.de/br/fs/ard_alpha/hls/de/master.m3u8
      #EXTM3U
      #EXT-X-VERSION:4
      #EXT-X-INDEPENDENT-SEGMENTS
      #EXT-X-STREAM-INF:BANDWIDTH=2182400,AVERAGE-BANDWIDTH=1900800,CODECS="avc1.4d401f,mp4a.40.2",RESOLUTION=960x540,FRAME-RATE=50.000,AUDIO="program_audio",SUBTITLES="subs"
      master_960p_1600.m3u8
      #EXT-X-STREAM-INF:BANDWIDTH=4224000,AVERAGE-BANDWIDTH=3660800,CODECS="avc1.640020,mp4a.40.2",RESOLUTION=1280x720,FRAME-RATE=50.000,AUDIO="program_audio",SUBTITLES="subs"
      master_1280p_3200.m3u8
      #EXT-X-STREAM-INF:BANDWIDTH=1672000,AVERAGE-BANDWIDTH=1460800,CODECS="avc1.4d401f,mp4a.40.2",RESOLUTION=640x360,FRAME-RATE=50.000,AUDIO="program_audio",SUBTITLES="subs"
      master_640p_1200.m3u8
      #EXT-X-STREAM-INF:BANDWIDTH=1034000,AVERAGE-BANDWIDTH=910800,CODECS="avc1.4d401e,mp4a.40.2",RESOLUTION=480x270,FRAME-RATE=50.000,AUDIO="program_audio",SUBTITLES="subs"
      master_480p_700.m3u8
      #EXT-X-MEDIA:TYPE=SUBTITLES,NAME="Deutsch",DEFAULT=YES,AUTOSELECT=YES,FORCED=NO,LANGUAGE="de",GROUP-ID="subs",URI="master_subs_webvtt.m3u8"
      #EXT-X-MEDIA:TYPE=AUDIO,LANGUAGE="de",NAME="Deutsch",AUTOSELECT=YES,DEFAULT=YES,GROUP-ID="program_audio",URI="master_audio1_128.m3u8"
      #EXT-X-MEDIA:TYPE=AUDIO,LANGUAGE="klare sprache",NAME="Klare Sprache",AUTOSELECT=YES,DEFAULT=YES,GROUP-ID="program_audio",URI="master_audio2_KS_128.m3u8"

      Dieses Kommando auf Kommandozeilenebene starten, Video und Audio spielt synchron:
      ffmpeg -i mcdn.br.de/br/fs/ard_alpha/hls/de/master_1280p_3200.m3u8 -i mcdn.br.de/br/fs/ard_alpha/hls/de/master_audio1_128.m3u8 -copyts -vcodec copy -acodec copy -f mpegts udp://192.168.x.x:3434
      In der Bouquetliste IPTV Sender udp://ip-der-box:3434 anlegen.
    • Ich bedanke mich ganz herzlich für alle Bemühungen! Ich bin technisch in der Umsetzung allerdings noch etwas unbedarft! Ich habe es gerade einmal geschafft, beim Sender ServusTV zum Livestream den EPG der Freenet-Variante einzupflegen. Und dieser Groschen dauerte recht lange, bis er fiel!

      Ich werde mich in den nächsten Wochen in die Materie einarbeiten und dann vermutlich nochmals mit einigen vermutlich dilettantischen Fragen aufwarten, wenn es noch zu ertragen ist…
    • Moin Zusammen!

      Endlich einmal Zeit gefunden, habe ich einen halben Tag damit verbracht, die Telnet-Befehle via Putty oder DCC einzugeben. Leider klappt‘s nicht! Die Antwort: -bash: ffmpeg: command not found

      Sehr wahrscheinlich ist bei meiner 920er der FFMPEG-Player nicht installiert im NewNigma2…

      Falls noch eine Idee besteht, dann wäre ich unendlich dankbar…

      Vielleicht bin ich aber auch zu unterbelichtet…?!
    • Moin Zusammen,

      ich habe den Adventssonntag genutzt, um so schöne Dinge zu tun, wie das Folgende:
      Ich habe „ffmpeg“ gefunden und installiert. Damit hört meine Erfolgsgeschichte aber leider auch schon auf, denn wenn ich „ffmpeg -i mcdn.br.de/br/fs/ard_alpha/hls/de/master_1280p_3200.m3u8 -i mcdn.br.de/br/fs/ard_alpha/hls/de/master_audio1_128.m3u8 -copyts -vcodec copy -acodec copy -f mpegts“ eingebe, dann meckert Telnet über die Adresse der Videospur! Muss da noch ein https:// vorweg angegeben werden? Die Videospur läuft im VCL-Player jedoch vollkommen korrekt!

      ich gehe davon aus, dass ich irgendeinen Bock schieße, bei dem ich nicht verstanden habe, was ich da genau mache…

      Ich habe die Zeilen zwischen den „“ einfach kopiert und genauso bei Telnet eingegeben! Natürlich habe ich die IP-Adresse meiner Box entsprechend angepasst.

      Ist denn der Port in diesem Fall richtig? Ist vermutlich ein klassischer Udp-Port, bei dem 3434 der Standard ist, genau wie der Port 21 beim FTP-Zugang Standard ist……oder etwa doch nicht….???

      ich bedanke mich schon einmal ganz herzlich im voraus!!!

      Lieben Gruß!
    • Ich hab ne Lösung, die Vogelwild ist, aber funktioniert. :thumbup:
      Ich hab leider nur wenig Zeit...
      Ich werde es sobald ich Zeit finde hier posten. Ist ein mini-skript von mir selbst, da kann dann jeder der mehr Ahnung von DreamOS hat eine schönere Lösung erweiter/umbauen.
      Damit kann man HLSv5 und HLSv7 (getrennte Video und Audio m3u8) aus der normalen Bouquet Kanalliste auf dm9x0 abspielen, wahrscheinlich auch dm5x0. Streams von ARD,ZDF,Zattoo,1&1 etc. laufen damit Bild+Ton. Wenn der youtube-dl nicht so schweine langsam wäre bei get-url wäre es noch schöner, so resolve ich selber das manifest, unschön aber geht.
    • Hier meine Lösung, ich nenne sie hlsv5 proxy.
      Vorab, bevor mich die Experten in der Luft zerreissen, was ich da gemacht habe. Ich bin kein Programmierer und gehe sehr pragmtisch heran. Ein bisschen bash kann ich noch.

      Zunächst ist es sinnvoll, dass man sich die HLSv5 m3u8 URL verkürzt, z.B. mit Tiny URL. Ich habe aus der ZDF URL
      "https://zdf-hls-15.akamaized.net/hls/live/2016498/de/high/master.m3u8" -> diese tinyURL "https://tinyurl.com/zdfhlsv5" generiert. Die funktioniert auch.


      Für meine Lösung ist es hilfreich sehr kurze URls zu haben, wenn man sehr lange URLs hat, könnten diese abgeschnitten werden, was natürlich dann dazu führt, dass es nicht funktionert.

      Im Anhang findet ihr ein zip, da sind im
      usr/bin Ordner eine udpxy binary für armhf (dm9x0) und eine neuere ffmpeg 5.0 version binary für armhf (dm9x0.
      Die ffmpeg die im DreamOS standardmässig mitgeliefert wird kann kein "https://", was doof ist, da nahezu alle URLs im Internet https erfordern. Die im zip file mitgelieferte ffmpeg ist ein static build und hat keine dependencies. Daher tauscht die auf der dream gegen diese aus.
      Kopiert auch udpxy in usr/bin, udpxy ist ein tool, das mpeg-ts udp/rtp in mpeg-ts http umwandelt, und für die Umsetzung in meiner Lösung das entscheidende Element. Nicht vergessen chmod 755 den zwei binaries zu geben.

      Zudem findet ihr im Ordner usr/script das Skript, kopiert das in Euer usr/script und gebt chnmod 755.

      Dann habe ich noch eine bouquet.tv im Ordner /etc/enigma2 reinkopiert, damit man sieht, wie die service ref darin aussehen muss. Die zwei Sender darin ZDF und ARD sollten funktionieren. Ich habe mit noch wesentlich mehr Sendern getestet.

      Wenn alles an Ort und Stelle, das Skript ausführen. ./proxy_dam72.sh Ich habe einen Cronjob der das Skript einmal in der Nacht killed und dann wieder neu startet.

      Schwächen sind, man sollte nicht zu schnell zappen, und manchmal ist Bild und Ton doch versetzt, da muss man einfach paar mal hin und her schalten, am besten auf einen SAT oder KABEL Kanal.

      Wie gesagt, das war ne private Lösung für mich und mir reicht die. Nachdem auch andere Bedarf haben, teile ich gerne meine Lösung. Nutzung auf eigenes Risiko.

      Wenn jemand das Skript verbessern, verändern will, kann das sehr gerne getan werden, mit der Bitte Optimierungen dann auch mit der Community zu teilen.

      VG dam72
      Files
      • HLSv5_proxy.zip

        (12.9 MB, downloaded 25 times, last: )

      The post was edited 2 times, last by dam72 ().

    • Sender ARD-Alpha (Livestream) hat keinen Ton!

      Ok das schaut wirklich etwas wild aus @dam72
      Das sollte sich eigentlich mit eServiceUri lösen lassen ohne dass das permanent im Hintergrund läuft (ffmpeg braucht man trotzdem, udpxy weiß ich nicht, was war der Grund dafür?)
      Falls ich mal zuviel Zeit hab schau ich es mir an. :D

      The post was edited 1 time, last by dhwz ().

    • @dhwz: Ja, optimierungen sind willkommen. Mit dem udxpy aufruf schicke ich huckepack die tinyurl mit vom HLSv5 Sender mit, die ich dann im journctl log abfange und das skript dann abgearbeitet wird. Zudem fängt der udpxy den mcast vom ffmpeg ab, den der HW player abpsielt. Hinten durch die Brust. Ich kann so der dream sagen lausche auf diese mcast Adresse und noch die info schicken welche HLSv5 URL aufgerufen werden soll, dazwischen ist das Skript das ffmpeg startet. Zwei Fliegen mit einer Klatsche. Funktioniert trotz der a-typischen herangehensweise sehr gut. :D

      The post was edited 1 time, last by dam72 ().

    • Sender ARD-Alpha (Livestream) hat keinen Ton!

      Hm ok dann ist das wohl nicht nötig, weil die URL kann ich ja direkt im Resolver handlen und downloaden, die tinyurl brauche ich da nicht.
      Ich muss nur nur mal überlegen wie ich da ffmpeg starten und vor allem auch wieder stoppen kann wenn man den Sender verlässt im Bouquet.

      Das wäre dann eine halbwegs akzeptable Lösung, auch wenn ich das mit ffmpeg etwas gefrickelt ansehe (so wie den Streamlink Kram).
      Aber anders wird es sich nicht lösen lassen.

      Und ich müsste DP noch überzeugen den ffmpeg auch auf den OE2.5 Feeds zu aktualisieren.
    • Ja das war auch mein Problem, wie rufe ich den Sender so auf, dass der HW Player spielt, das HLS manifest an ffmpeg übergeben wird, und wie starte ich ffmpeg und stoppe es. Im Skript checke ich ob ein bestimmter [playing] typ beim zappen kommt, wenn dann... Zum resolven habe ich zuerst youtube-dl benutzt mit get-url, aber da kannst du nebenbei kaffee holen gehen bis der was aufgedröselt hat. Hab dann kurzerhand das manifest selbst resolved. Eigentlich relativ simple.
      Auf der anderen Seite wird die Funktion (HLSv5 und HLSv7 mit getrennten AV m3u8) immer wichtiger, da das in Kürze nur noch verwendet wird, die öffis sind schon kompett auf HLSv5, auch Zattoo Streams laufen damit. Daher wäre es gut wenn wir das als eine "prof." Lösung hätten. Wenn du da was machst bin ich guter Dinge. Würde sicherlich vielen helfen.
      So jetzt kann ich wieder für paar Jahre untertauchen.