[gelöst] Autofs - systemd - NAS startet ungewollt automatisch

    • [gelöst] Autofs - systemd - NAS startet ungewollt automatisch

      Hallo,

      Ich verwende "Autofs", weil bei mir mit "systemd" in der fstab "Dauerspinner-Probleme" (Synology DS214) auftreten. Bei mir liegt die Autofs Konfiguration im "/etc/auto.master.d" Verzeichnis.

      "auto.nas"
      DS214-1 -fstype=nfs,tcp,rw,soft,nolock,_netdev,retry=0 192.168.178.12:/volume1/DS214-Ordner1

      "nas.autofs"
      /media/hdd/movie/NET/DS214 /etc/auto.master.d/auto.nas --ghost --timeout=300


      Soweit funktioniert der Zugriff auf das Synology NAS einwandfrei. Problemlos ist auch ein versehentlicher Zugriff wenn das NAS offline ist. Sind nur wenige Sekunden Dauerspinner.

      Aaaaber, immer wenn ich die DM920 starte, geht automatisch mein NAS in den Betrieb, was es NICHT soll. Scheint so, als wenn ein WOL-Signal von der Box kommt. Kann man das irgendwie verhindern ?


      Gruß Gundo
      Dreambox DM920 + Newnigma2
    • Autofs für Netzwerkfreigaben wurde bewusst deaktiviert, weil es nicht fehlerfrei funktioniert und wird weder von Dream noch von uns weiter unterstützt.

      Ghost - Dev@DP wrote:

      Wir supporten kein autofs... eben weil es alt ist und nicht mehr gepflegt wird.
      Das ist der Grund wieso wir systemd automounts nehmen.


      Wie du richtig mounten kannst, findest du dort: How To DreamOS: NFS Freigaben einbinden
    • Ok, dann eben mit "systemd."

      fstab:
      192.168.178.12:/volume1/DS214-Ordner1 /media/hdd/movie/NET/DS214 nfs vers=4,tcp,rw,x-systemd.device-timeout=15,retrans=4,timeo=5,noauto,x-systemd.automount,x-systemd.idle-timeout=300,soft,retry=0,nolock,nofail,_netdev 0 0

      Auch hier startet das NAS wenn die Box in Betrieb geht.
      Dreambox DM920 + Newnigma2
    • Moin,

      bei meiner DS211 schicke ich nur die internen Laufwerke nach 2h in den Ruhezustand. Der erste Zugriff dauert dann höchstens 1-2s länger. Die Elektronik bleibt dauerhaft an. So kann die Dreambox auch nach einem Neustart sofort darauf zugreifen.
      Den Energieverbrauch habe ich aber ohne FP noch nicht gemessen. :whistling:

      Gruß
      Classic
    • Es geht bei mir um mein Synology DS214 NAS. Das schalte ich aus wenn es nicht gebraucht wird. Und wenn das NAS anlaufen soll, schicke ich "manuell" über die DM920 per Script ein WOL.
      Es soll aber nicht sein, das automtisch das NAS "immer" aufgeweckt wird, wenn die DM920 eingeschaltet wird. D.h, die BOX schickt ungefragt an mein NAS ein WOL (wake on lan). Warum ist das so, und wie kann das deaktiviert werden ?
      Dreambox DM920 + Newnigma2
    • Mal eine Frage am Rande, denn ich habe hier auch ein NAS im Dauerbetrieb. Für WOL Start ist das NAS doch nicht vollständig ausgeschaltet, denn es muss doch auf WOL "lauschen". Bei meinem NAS gehen die darin verbauten WD red Server-HDDs nach kurzer Zeit in den Ruhezustand / Bereitschaft. Gleiches beim NAS auch selbst. Hat irgendjemand Kenntnis, wie viel größer die Energieersparnis ist, wenn ein NAS soweit runterfährt und nur noch auf WOL achtet?
      Grüsse aus dem "ganz Nahen Osten" vom Burkhardtsdorfer

      Dreimal geimpft und noch am Leben!
    • Gundo wrote:

      D.h, die BOX schickt ungefragt an mein NAS ein WOL (wake on lan). Warum ist das so, und wie kann das deaktiviert werden ?
      Das kann ich mir nicht vorstellen, aber das könnte ich mal testen - ich hätte das noch nicht bemerkt.

      Ich tippe eher auf eine Einstellung am Synology DS214, dass Sie anläuft wenn ein access request ankommt. D.h, das NAS lauscht auf Anfragen und springt bei einem request an
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox
    • War auch mein Gedanke. Aber ich habe das entsprechende Setting in der "DiskStation" noch nicht gefunden.

      Mein NAS hat inaktive 2 Zustände.
      1. Das NAS ist "aus", keine LED ist an. Es reagiert auf WOL damit es startet. Nach dem Start ist es voll aktiv.
      2. Nach 10 Min. Inaktivität schalten sich die HDD ab, und nur die StandBy LED blinkt. In diesem Zustand kann auf die Freigaben zugegriffen werden, das NAS ist nach einigen Sekunden wieder voll betriebsbereit und die HDD laufen.

      Zustand 2 soll auf den "access request" reagieren, was auch funktioniert.
      Zustand 1 soll NICHT auf den "access request" reagieren.


      Mal sehen ob ich in den Tiefen der Settings was finde um das zu konfigurieren.
      Dreambox DM920 + Newnigma2
    • In der Fritz.box gibt es Einstellungen: "Mit der Funktion "Wake on LAN" können Sie einen Computer, der sich im Standby-Modus befindet, über das Netzwerk starten."

      Und das Elektroplugin kann auch so eingestellt werdem, das WOL beim Start der Box geschickt werden.
      .
      Mein Qnap TS-832X ist mit ca. 20 W im Betrieb angegeben. Bei einschaltetem WOL wird etwas über 1W verbraucht.
    • Mein NAS soll im Zustand 1 (NAS aus, keine LED leuchtet) NICHT auf einen "access request" reagieren. Sonst startet das NAS immer, wenn es NICHT soll, also wenn die Box startet. Nur bei WOL soll es hochfahren, was ja auch funktioniert. Ich finde kein Setting beim NAS wo das konfiguriert werden kann. Oder der DM920 müsste man beibringen beim Hochfahren keinen "access request" zu schicken. Vielleicht ist es aber auch ein WOL was die Box schickt, was sie aber nicht soll.
      Dreambox DM920 + Newnigma2
    • Ich habe jetzt mal meine dm900 neu gestartet und dann im journal nach der IP meines Servers und nach ether-wake (in anderen Images könnte es etherwake sein) durchsucht, ich finde da nichts

      Der Box bzw. systemd bzw. autofs müsste ja die MAC Addresse oder der hostname des QNAP bekannt sein, um ein magic packet über den broadcast zu versenden, aber ich finde auch keinen eintrag mit der IP oder der MAC des Servers im Journal. Und soweit ich weiß, ist ether(-)wake nicht standardmäßig in allen DreamOS Images vorinstalliert.

      Ich kann gerade nicht testen, ob es sich hier auch so verhält. Aber Ich höre auch zum ersten mal, das autofs bzw. systemd der Dreambox einen Server über WOL wecken (versuchen) soll, wenn dieser offline ist. Wenn das so wäre, hätten wir schon öfters darüber gelesen.

      \\EDIT
      ich habe mal gegoogelt wie man autofs konfigurieren müsste, damit versucht wird, einen Server über WOL zu wecken, wenn er offline ist. Ich denke ohne manuelles zutun geht da nichts

      dj-does.medium.com/nfs-mounts-and-wake-on-lan-25c0c1d55c90
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox

      The post was edited 1 time, last by Fred Bogus Trumper ().

    • Ein weiterer Test:

      Eine zweite DM920 (nagelneu) frisch installiert. Automount mit "systemd" und fstab. NAS ist ein Synology DS216j. Und wieder startet das NAS wenn die Box hochgefahren ist. Kann doch nicht wahr sein. ?(
      Dreambox DM920 + Newnigma2
    • Jetzt hab ich am Switch, an dem meine DM920 hängt, eine VU+DUO4K mit ATV 7.2 angeschlossen. Und wenn ich DIESE Box hochfahre, bleibt das NAS aus. Schalte ich die DM920 an, fährt das NAS wieder hoch. Das deutet doch darauf hin, das die DM920 irgendwas ins Netz schickt, und das NAS meint dann anlaufen zu müssen.
      Dreambox DM920 + Newnigma2
    • falls die Box etwas schickt, müsste man das sniffern oder aus dem journal loggen können
      Mit den default Plugins und Funktionen der Dreambox wird meines Wissens kein WOL für Server beim NFS mount unterstützt.

      ist auf der VU+ auch das NAS per autofs bzw. systemd eingebunden?

      hast du vielleicht zusätzliche Plugins installiert wie z.B. das WakeOnLan Plugin von Aladin? Das macht genau das was du beschreibst

      computerabc.de/index.php?wakeo…down---mount---plugin-en/
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox
    • Ich habe die Ursache gefunden, die Ursache war natürlich ein Plugin. Um eigene Scripte bei Bedarf auszuführen, ist das "Benutzerscripte Plugin von OoZooN" installiert. Mit dem entsprechenden Script soll dann das NAS aufgeweckt werden. Was ich nicht wusste ist, das ein Setting für das automatische Ausführen von Scripten aktiviert war (default). :mauer:
      Nun ist es deaktiviert, und mein NAS bleib im Ruhezustand wenn die Box hochfährt.

      Gruß Gundo
      Dreambox DM920 + Newnigma2