[gelöst] Linux NAS als OSCam Server?

    • Oh Mann... Ich muss zugeben, dass ich nix mehr blicke.

      @TheMatrix
      >>Needint -> cccam Protokoll sieht keine Karte.
      Wo siehst Du das? Welche Zeile meinst Du da in dem Client Log? Und was muss ich wo ändern?

      >>Auf der Serverbox bzw Nas auch alle Group und anderes richtig für (joerg, au=auto (1 reader)) ?
      Ich hoffe es...
      Ich hänge nun mal meine Server (Debian 11 NAS) und Client Konfigs (DM900) hier rein. Scheiß auf die Klartext-Passwörter - ist ja eh alles intern. Ich lese und lese und raffe nix mehr. Ich komme mir grad wie ein Trottel vor...
      Wäre super, wenn sich jemand die Konfigs mal ansehen würde.

      PS: DVBAPI - Ich habe keine Ahnung, was das ist oder wozu man das brauchen kann. Aber wie es verstanden habe, ist das ja wohl nicht mein Problem.

      Danke für jede weitere Hilfe.
      Files
    • [Blocked Image: https://i.ibb.co/SrW3r0R/Screenshot-2024-05-05-212031.png]

      Keine Ahnung wo da bei Dir der Wurm drin steckt.

      Wenn ich mir so Deine Config anschaue:

      Source Code

      1. [cccam]
      2. #port = 22765
      3. nodeid = C1D3070510AA148E
      4. port = 12000
      5. version = 2.3.0
      6. #build = 1234
      7. #reshare = 2 -> ?? kein reshare ;-)

      Könnte da was nicht passen, lege die Config so an:

      [cccam]
      nodeid = C1D3070510AA148E
      port = 12000
      version = 2.3.0
      reshare = 2
      Config Receiver Standort 1: DM900UHD ; DM820HD ; Vodafone Kabel; Server: Raspberry Pi 3; Nas: Synology DS620 Slim 10TB
      Config Receiver Standort 2: DM900UHD ; DM525HD; DM520HD; Orbit 13,0;16,0;19,2,;23,5

      The post was edited 4 times, last by TheMatrix ().

    • Auf deiner DM900 (Client) ist in der oscam.conf DVBAPI ausgeschaltet

      [dvbapi]
      enabled = 0
      au = 1

      hier muss :
      enabled = 1

      stehen, Sonst fragt die DM900 auf dem Server auch nicht an.

      Und ich würde auf deinem Server zwei User anlegen. Die 900 und die 520.
      Auf der 520 auch einen Reader anlegen mit den notwendigen Daten zum Server.

      Gruß
      :)
    • Könnte da was nicht passen, lege die Config so an:

      [cccam]
      nodeid = C1D3070510AA148E
      port = 12000
      version = 2.3.0
      reshare = 2
      Das mit der "nodeid" habe ich auch noch nicht verstanden. Ich habe einfach die gleiche verwendet, wie die DM900, wenn sie als Server eingerichtet ist.
      Ich werde nachher mal erneut testen.

      Danke für Deine Geduld.
    • Auf deiner DM900 (Client) ist in der oscam.conf DVBAPI ausgeschaltet

      [dvbapi]
      enabled = 0
      au = 1

      hier muss :
      enabled = 1

      stehen, Sonst fragt die DM900 auf dem Server auch nicht an.

      Und ich würde auf deinem Server zwei User anlegen. Die 900 und die 520.
      Auf der 520 auch einen Reader anlegen mit den notwendigen Daten zum Server.
      Ah. OK. Auch das werde ich dann heute Abend testen.

      Danke Dir.
    • Heureka!!! Endlich klappt es.

      Es war der Hinweis von @Jacki415. :thumbsup:

      @TheMatrix. Habe auch hier mal die Gegenprobe gemacht. in meinem Fall macht "reshare" keinen Unterschied. Geht auch, wenn die Zeile auskommentiert ist.

      Ich hatte halt den Sinn von "dvbapi" auf Clientseite nicht begriffen.

      Nun ist alles prima. :D

      Besten Dank für eure Geduld.

      Grüße