[gelöst] Linux NAS als OSCam Server?

    • [gelöst] Linux NAS als OSCam Server?

      Hi ihr,

      Ich habe momentan eine DM900 im Wohnzimmer mit einer Vodafone G9 Karte (DVB-C) laufen. Diese bedient per OSCam meine kleine DM520 im Schlafzimmer, um Privatsender in HD sehen zu können. Die DM900 verbrät aber fast 25 W im Standby.
      Ich betreibe aber auch ein Eigenbau-NAS (Debian 11 mit Openmediavault/Nextcloud/PiHole und Plex) im 24x7 Betrieb. Dies verbraucht ~15W im Dauerbetrieb. (Für Kenner: Intel ITX J4205 mit ausschließlich SSD's ^^ ).

      Hat jemand einen Vorschlag, welche Hardware geeignet wäre, um mein NAS als OSCam Server für DVB-C zu betreiben? Somit könnte ich die DM900 (wenn nicht verwendet) per ElektroPowerSave in den Standby Mode setzen und bin im Schlafzimmer nicht mehr darauf angwiesen, da ja das NAS immer läuft.

      Es gibt ja die "berühmten" Sundtek USB Tuner - aber da hab ich bis jetzt Null Plan und Ahnung von, ob das (welcher) eine Lösung sein könnte. ?(
      Vielen Dank für jeden Hinweis.

      Grüße
    • geht es Dir um Streaming bzw PartnerPlugin ? Weil die DM520 im Schlafzimmer kein Kabel zur verfügung hat ? oder nur weil die DM900 als Oscam Verteiler arbeitet.

      Wenn ja, setzte Dir einen TvHeadEnd Server auf einem zum Beispiel Raspi 3B der kann auch mit verschüsselten Sendern umgehen. Der Verbraucht inkusive USB Tuner wie Du Ihn erwähnst oder halt Haupauge Solo oder Dual TUSB Tuner laufen auch und ca. 4-6 Watt im Betrieb. Oder nur als OsCam Server ohne TVH geht es auch wenn Du nur die EMM/ECM`s durchreichen willst.

      Doch mal ehrlich für den Preis an Strom kannst Dir ja bald einen 2 oder 3 Karte für Privat HD bei VF buchen für einmalig 29,99 € *g* Und in die DM520 stecken.
      Config Receiver Standort 1: DM900UHD ; DM820HD ; Vodafone Kabel; Server: Raspberry Pi 3; Nas: Synology DS620 Slim 10TB
      Config Receiver Standort 2: DM900UHD ; DM525HD; DM520HD; Orbit 13,0;16,0;19,2,;23,5

      The post was edited 3 times, last by TheMatrix ().

    • Der OSCam Server benötigt keine Tuner um die Karten zu entschlüsseln.
      Die Clienten fragen an und der Server liefert den Key.

      Wenn dein NAS eh läuft, mach da doch OSCam drauf.

      Gruß

      edit: Die hier angebotenen OSCam Versionen werden wohl auf deinem NAS nicht laufen, da wirst du selber Hand anlegen müssen.
    • @TheMatrix : Ja. Die DM520 hängt am Kabel und nutzt die 900er als OSCam-Server.
      @jacki: Ah. War mir nicht klar, dass OSCam gar keinen Tuner benötigt.
      @Griffel: Ja. Ne 7590. Ich mach mich mal auf die Suche.
      @koepi: Danke für den Tipp. Das seh ich mir mal an.

      Vielen Dank für all die Hinweise. Ja, ich weiß: Der Stromverbrauch fällt wenig ins Gewicht. Aber wie gesagr. Das NAS läuft eh immer. Mal sehen ob das unter Debian (oder der 7590) hinbekomme.

      Danke und Gruß

      OSCam unter Debain 11 -> snapcraft.io/install/oscam/debian ^^
      Läuft soweit.

      Kann mir vielleicht jemand noch einen konkreten USB Reader nennen, welcher meine Vodafone G09 unterstützt?

      Grüße
    • Bei mir läuft oscam auf einem kleinen pi 3 server seit Jahren völlig stabil mit 3 karten (srg, orf, hd+ 02) in alten smargo readern. früher waren es sogar mal 5 Karten mit zusätzlich tivusat und sky de. Anleitungen gibt es genügend im Netz.
    • Da Du auf Deinem NAS OpenMediaVault hast und der Prozessor ein x86 ist, gibt es dafür auch fertig OSCam als Docker Image. So eines läuft bei mir in einem Container in meiner Synology mit AMD Proz.
      Ich habe aber noch keinen USB Smartcard Reader benutzt. Aber soweit ich gelesen habe, geht das auch.
    • Ich frag mal in die Runde: Habe heute EasyMouse 2 USB bekommen für meine G09 Vodafone Karte.

      Läuft auf auf Debain 11.

      1. OScam per snap mault rum via apparmor (das NAS ist installiert via OpenMediaVault Image) :
      omv kernel: [67742.963294] audit: type=1400 audit(1714836648.362:213): apparmor="DENIED" operation="open" profile="snap.oscam.oscam" name="/dev/ttyUSB0" pid=159582 comm="wr08-KDG09" requested_mask="wr" denied_mask="wr" fsuid=0 ouid=0

      Habe keine Ahnung von apparmor bzw. was ich dagegen machen kann. Egal... Den Mist deinstalliert.

      Habe mir dann OSCam selbst kompiliert und als systemd Dienst eingerichtet. Logfile siehe Anhang.

      Source Code

      1. root@omv:/usr/local/etc# systemctl status oscam.service
      2. ● oscam.service
      3. Loaded: loaded (/lib/systemd/system/oscam.service; enabled; vendor preset: enabled)
      4. Active: active (running) since Sat 2024-05-04 21:58:13 CEST; 15min ago
      5. Process: 65801 ExecStart=/usr/local/sbin/oscam -b (code=exited, status=0/SUCCESS)
      6. Main PID: 65803 (oscam)
      7. Tasks: 9 (limit: 9036)
      8. Memory: 2.0M
      9. CGroup: /system.slice/oscam.service
      10. ├─65803 /usr/local/sbin/oscam -b
      11. └─65804 /usr/local/sbin/oscam -b
      12. Mai 04 21:58:13 omv systemd[1]: Starting oscam.service...
      13. Mai 04 21:58:13 omv systemd[1]: Started oscam.service.
      Display All



      Läuft ja auch - aber: ABER: Die LED's bei Easymouse sind tot. Wenn ich minimal die Karte hin- und herschiebe, dann flackert kurz mal was auf (beim Anschluss an USB leuchtet rot und grün kurz auf).

      Liegt es an meiner Konfiguration oder ist die EasyMouse Hardware schuld? Ich habe die Einstellungen laut wiki.zebradem.com/wiki/index.p…Easymouse_2_Einstellungen vorgenommen.

      Weiß jemand, wo das Problem sein könnte?


      Grüße
      Files
      • oscam.log

        (3.29 kB, downloaded 12 times, last: )
      • oscam.server.txt

        (310 Byte, downloaded 10 times, last: )
      • oscam-version.txt

        (3.24 kB, downloaded 11 times, last: )
    • Eine Log deines Oscam Startvorgangs wäre noch nett... //Sorry... Attachments nicht gesehen....


      AppArmor würde ich nicht einfach "runter schmeißen", da es einen zentralen Bestandteil des Sicherheitskonzeptes von OpenMediaVault darstellt..

      Besser ist, du konfigurierst es einfach, dass du Oscam Lese/Schreibrechte auf /dev/ttyUSB0 gewährst...

      Dann darf die Oscam auch mit dem Cardreader sprechen...

      Source Code

      1. requested_mask="wr" denied_mask="wr"


      //Edit

      Laut Log spricht die Oscam aber sauber mit dem Reader...

      Source Code

      1. (reader) KDG09 [internal] Reader initialized (device=/dev/ttyUSB0, detect=cd, mhz=357, cardmhz=357)


      Es scheint an der Kommunikation mit der Karte im Reader zu hapern...

      Wenn du die Mouse mit 3,3V im Phoenix Mode betreibst, sollte mit dem Reader alles passen...

      The post was edited 1 time, last by JERKBALL ().

    • >>AppArmor würde ich nicht einfach "runter schmeißen", da es einen zentralen Bestandteil des Sicherheitskonzeptes von OpenMediaVault darstellt..

      Nee. Hab ich ja auch nicht. Habe "nur" snap und oscam via snap deinstalliert und dann oscam selber kompliliert. (digital-eliteboard.com/threads…eren.170663/#post-2492072). Hat ja auch geklappt.

      Die selbst kompilierte scheint ja auch OK mit dem Reader. Habe jetzt mal in der oscam.sever den Eintrag "protocol = mouse" geändert (ich wühle mich grad durch 1000 Seiten im I-Net :D ) Und nun habe ich dieses Log - sieht besser aus (Anhang).

      Der Eintrag "(dvbapi) ERROR: Could not detect DVBAPI version." verwirrt mich aber. Was soll mir das sagen? Ist das überhaupt relevant?
      Meine DM520 im Schalfzimmer kann noch immer nix decodieren. Privates HD-TV bleibt dunkel. Siehe Log.

      Verdammt - bin zu alt für diesen Scheiß. Was mache ich falsch? Mit meiner DM900 als OSCam-Server geht es ja. Aber ich würde es halt gern mit Easymouse USB an meinem NAS hinbekommen.


      Gute N8 für heute und alle die helfen möchten.

      Grüße
      Files
    • Ja, das sieht in der Tat besser aus... Karte wird nun laufen...

      Source Code

      1. (dvbapi) ERROR: Could not detect DVBAPI version.


      Hast du deine "server" oscam denn mit dvbapi support kompiliert?

      Nötig ist das ja eigentlich nicht, wenn deine DM520 der einzige Client ist und selbst die Oscam mit DVBapi zum entschlüsseln nutzt...

      Dann lieber aufm Server DVBApi in der Config deaktivieren und den dvbapi user löschen...

      DVBApi würde aufm Server Sinn machen, wenn auf deinem OMV noch parallel TVHeadEnd läuft und über Port 9000 per Oscam die Sender dekodiert...
    • Also... Ich bin irgendwie zu doof. Ich habe meine alte Server/Client Konfig mal von einem Bekannten machen lassen und nie selbst angepasst (Server DM900, Client DM520).

      Aber es wird momentan nicht hell auf den Clients (DM900 / DM520). Wo ist ja erstmal egal.

      Hier mal die Logs vom Server (meiner selbstkompilirten OSCam) und dem Client (DM900) incl. Screenshots vom Webinterface. Ich sehe 0 Fehler aber es wird nichts hell.
      Ich verstehe es nicht.

      Wer findet den Fehler?

      Danke und Gruß
      Images
      • oscam-server.png

        38.69 kB, 1,914×287, viewed 21 times
      • oscam-client.png

        46.21 kB, 1,905×327, viewed 22 times
      Files

      The post was edited 1 time, last by AlBundy001 ().

    • Was mir grad auffällt:

      Wenn die DM900 als Server läuft, dann muss dvbapi aktiviert sein. Sonst bleibt es auch auf der DM900 dunkel.

      Auf meinem NAS ist die OSCam durchaus mit DVBAPI Support kompiliert. Aber der Fehler ERROR: Could not detect DVBAPI version. (wenn ich es in der oscam.conf aktiviere) rührt ja wohl daher, dass auf meinem NAS das Device /dev/dvb/... gar nicht vorhanden ist. Nein: Auf dem NAS läuft kein Kodi/TVHeadend.

      Aber wenn ich @JERKBALL richtig verstehe, brauch ich das ja auch nicht.

      Naja, mal sehen, was die richtigen Profis finden. ;)

      Grüße
    • es steht doch beim Client ganz klar:

      Needint -> cccam Protokoll sieht keine Karte.

      Auf der Serverbox bzw Nas auch alle Group und anderes richtig für (joerg, au=auto (1 reader)) ?

      DVBAPI -> nutzt Du nur auf einem Linux Receiver, da Deine Nas nur ECM`s oder gesendete EMM`s abarbeitet, benötigt die Oscam auf der Nas keine API.
      Config Receiver Standort 1: DM900UHD ; DM820HD ; Vodafone Kabel; Server: Raspberry Pi 3; Nas: Synology DS620 Slim 10TB
      Config Receiver Standort 2: DM900UHD ; DM525HD; DM520HD; Orbit 13,0;16,0;19,2,;23,5

      The post was edited 1 time, last by TheMatrix ().