Syslog aktivieren und am PC ansehen

    • RE: Syslog aktivieren und am PC ansehen

      Original von mattla93
      Hallo,

      wie kann ich bei meinem Newnigma2 Image syslog aktivieren. Wo kann ich anschließend die logdatei abrufen?

      Wie kann ich diese dann am PC anschauen?



      config liegt unter /etc



      regards
    • In der Config steht das:

      Source Code

      1. DESTINATION="buffer" # log destinations (buffer file remote)
      2. MARKINT=20 # intervall between --mark-- entries
      3. LOGFILE=/var/log/messages # where to log (file)
      4. REMOTE=loghost:514 # where to log (syslog remote)
      5. REDUCE=no # reduce-size logging
      6. #ROTATESIZE=0 # rotate log if grown beyond X [kByte] (incompatible with busybox)
      7. #ROTATEGENS=3 # keep X generations of rotated logs (incompatible with busybox)
      8. BUFFERSIZE=64 # size of circular buffer [kByte]
      9. FOREGROUND=no # run in foreground (don't use!)


      Aber wie kann ich die Jetzt aktivieren?

      The post was edited 2 times, last by mattla93 ().

    • Source Code

      1. DESTINATION="buffer" # log destinations (buffer file remote)
      2. MARKINT=20 # intervall between --mark-- entries
      3. LOGFILE=/var/log/messages # where to log (file)
      4. REMOTE=IP-AdressePC:Port # where to log (syslog remote)
      5. DESTINATION="remote"
      6. REDUCE=no # reduce-size logging
      7. #ROTATESIZE=0 # rotate log if grown beyond X [kByte] (incompatible with busybox)
      8. #ROTATEGENS=3 # keep X generations of rotated logs (incompatible with busybox)
      9. BUFFERSIZE=64 # size of circular buffer [kByte]
      10. FOREGROUND=no # run in foreground (don't use!)


      regards
    • Original von mattla93
      Was soll ich aber da einsetzen:

      Source Code

      1. REMOTE=IP-AdressePC:Port


      Denn nur mit dieser Config, screibt er mir keine Logfile!


      Na die Ip-Adresse vom PC auf dem du loggen willst.

      regards
    • Na die Ip-Adresse vom PC auf dem du loggen willst.


      Hmm, da komm ich nicht ganz mit; da müsste ich ja ein Programm auf meinem PC gestartet haben, das einen Port überwacht und die Logfile schreibt.
      Kiwi; der Logviewer hat diese Funktion nicht(wie ich gesehen habe).

      Deshalb habe ich jetzt 2 Fragen anstatt eine :) :
      • Ich kann ja auch eine Logfile im Flash-Speicher erstellen lassen. Laut config in /var/log/messages ; dort befindet sich die Logfile aber nicht! Wie kann ich das aktivieren


      EDIT:
      Hab jetzt einen anderen Logveawer gefunden, mit dem man den Port kontrollieren kann.
      Aber das Problem, die Box loggt nicht; Config passt, muss man das noch irgendwo separat aktivieren?

      The post was edited 1 time, last by mattla93 ().

    • Jetzt hab ichs schon hinbekommen!
      Damit dann was geloggt wird, muss ich dann z.B. cccam mit den Parameter -v starten


      Aber dabei werden keine Systemprozesse geloggt usw. Kann ich die Syslogd mit einem Parameter starten dass alles geloggt wird?

      Bzw. wie muss ich die starten, dass auf die Datei in etc/logs/message loggt?

      Danke für die Antworten ;)
    • Original von mattla93
      Jetzt hab ichs schon hinbekommen!
      Damit dann was geloggt wird, muss ich dann z.B. cccam mit den Parameter -v starten


      Aber dabei werden keine Systemprozesse geloggt usw. Kann ich die Syslogd mit einem Parameter starten dass alles geloggt wird?

      Bzw. wie muss ich die starten, dass auf die Datei in etc/logs/message loggt?

      Danke für die Antworten ;)


      Wenn du local auf der box loggen willst musste halt destination ="file" nehmen.



      regards
    • Original von JERKBALL
      Syslogd wird beim booten automatisch mitgestartet


      Ist bei mir nicht der Fall, muss via terminal den Befhl

      Source Code

      1. syslogd -R MeiniP:MeinPort


      ausführn, CCcam killen, dann mit dn Paramter -v starten. Dann kommen abrauch NUR die CCcam Logs an, nicht aber Systemlogs und logs von anderen Prozessen!

      Warum?
    • ist vllt ne dumme frage aber bei mir läuft der daemon auch nicht automatisch es sei denn ich werfe ihn per hand an, gibts irgendwo eine config wo man das noch aktivieren muss? es wird auch nicht einfach remote geloggt wenn ales in der syslog.conf in /etc eingetragen ist, das läuft auch nur über den kompletten befehl mit ip:port
      gruß
      pregi