[gelöst] Brauche Hilfe mit SD Karte

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • [gelöst] Brauche Hilfe mit SD Karte

      Hallo, ich habe meine SD Karte wie hier beschrieben
      _________________________________________________________________________________________________________________________________________________________
      Wie verwende ich eine SD-Karte?
      (nur DM7080, DM9x0, ONE; der SD-Cardreader der DM820 ist im Treiber deaktiviert und kann derzeit nicht genutzt werden)

      Die SD-Karte ist im Gerätemanager blacklisted und muss manuell gemountet werden:
      - Karte in ext4 formatieren (mkfs.ext4 -L sd /dev/mmcblk1p1)
      - auf der Konsole: blkid
      Ausgabe sieht z.B. so aus: /dev/mmcblk1p1: LABEL="sd" UUID="5aa5fb10-2326-4033-b821-71c2f349fd51" TYPE="ext4" PARTUUID="000c7755-01"

      Verzeichnis anlegen per: mkdir /media/sdcard
      UUID aus der Ausgabe oben kopieren in einen Eintrag in der /etc/fstab nach folgendem Muster anlegen:

      /dev/disk/by-uuid/5aa5fb10-2326-4033-b821-71c2f349fd51 /media/sdcard auto auto,nofail 0 0
      __________________________________________________________________________________________________________________________________________________________


      versucht einzubinden. Leider ohne Erfolg. Wer kann mir bitte weiterhelfen? Irgendwie bin ich zu blöd dazu :tischkante:

      Bei blkid kommt bei mir nur in der Ausgabe: /dev/ mmcblk1: PTTYPE=„dos“



      BITTE um Hilfe
      Gruß
      Tom73

      The post was edited 1 time, last by Tom73 ().

    • Hilfsbereit wrote:

      Tom73 wrote:

      - Karte in ext4 formatieren (mkfs.ext4 -L sd /dev/mmcblk1p1)

      Tom73 wrote:

      Bei blkid kommt bei mir nur in der Ausgabe: /dev/ mmcblk1: PTTYPE=„dos“
      Fehler erkannt? ;)



      Was meinst du damit?

      PTTYPE=„dos“ bedeutet nur, das auf der SD ein MBR (DOS Partitonstabelle) und kein GPT installiert ist, was eigentlich egal ist, weil man Unterschied erst bemerkt, wenn man Partitionsgrößen > 2TB verwalten will


      sieht auf meiner SD nicht anders aus

      Source Code

      1. root@dm900:~# blkid|grep mmcblk1
      2. /dev/mmcblk1p1: LABEL="sd-card" UUID="e6e1f2b7-0e33-41e9-9be0-75e88ffa5623" TYPE="ext4"
      3. /dev/mmcblk1: PTTYPE="dos"
      4. root@dm900:~# parted /dev/mmcblk1 unit s print
      5. Model: SD SC16G (sd/mmc)
      6. Disk /dev/mmcblk1: 31116288s
      7. Sector size (logical/physical): 512B/512B
      8. Partition Table: msdos
      9. Disk Flags:
      10. Number Start End Size Type File system Flags
      11. 1 2048s 31116287s 31114240s primary ext4
      12. root@dm900:~# mount|grep mmcblk1
      13. /dev/mmcblk1p1 on /media/sd type ext4 (rw,relatime,data=ordered)
      14. root@dm900:~#
      Display All



      @Tom73
      was hast du bisher gemacht? Vermutlich ist noch keine Partktion auf der SD erstellt worden. Poste doch deine Eingabe und die Fehlermeldung als CODE (Icon </> im Foreneditor)
      das ist Aussgekräftiger das der Auszug


      poste auch mal die Ausgaben folgender Befehle:

      blkid|grep mmcblk1
      parted /dev/mmcblk1 unit s print
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox

      The post was edited 2 times, last by Fred Bogus Trumper ().

    • @Fred Bogus Trumper

      Vielen DANK das du mir hilfst! Ich werd morgen versuchen mal alles zu posten. Bin zeitlich leider ziemlich eingeschränkt. Auch technisch, bzw. programmier-mäßig hab ich nicht gerade viel Ahnung. Bin dir daher also ziemlich dankbar, das du mir hilfst!

      Bis morgen
      :prost:
      Gruß
      Tom73
    • @Fred Bogus Trumper


      Also bei blkid|grep mmcblk1 kommt nur /dev/mmcblk1: PTTYPE="dos"


      und bei parted /dev/mmcblk1 unit s print kommt folgendes:



      Model: SD SF128 (sd/mmc)
      Disk /dev/mmcblk1: 249737216s
      Sector size (logical/physical): 512B/512B
      Partition Table: msdos
      Disk Flags:

      Number Start End Size Type File system Flags
      1 63s 249730424s 249730362s primary




      Ich hab eigentlich alles nach Anleitung gemacht und hier.

      Und wenn ich das Verzeichnis für die SD Karte anlege wie in der Anleitung beschrieben (Veruzeichnis anlegen per: mkdir /media/sdcard) ist es nach einem Neustart verschwunden.
      Gruß
      Tom73

      The post was edited 2 times, last by Tom73 ().

    • Poste doch deine Eingaben und die Ausgaben/Fehlermeldung als Quellcode (Icon </> im Foreneditor) - das ist einfach besser lesbar

      Source Code

      1. root@dm900:~# parted /dev/mmcblk1 unit s print
      2. Model: SD SC16G (sd/mmc)
      3. Disk /dev/mmcblk1: 31116288s
      4. Sector size (logical/physical): 512B/512B
      5. Partition Table: msdos
      6. Disk Flags:
      7. Number Start End Size Type File system Flags
      8. 1 2048s 31116287s 31114240s primary ext4
      9. root@dm900:~#
      Display All
      Deine SD Karte hat zwar eine Partition, aber scheinbar ist kein Dateisystem erstellt - und auch kein filesystemtyp hinterlegt. Ich würde die SD komplett platt machen und neu initialisieren

      dazu hast du zwei Möglichkeiten:
      1. du machst alles zu Fuß in der Konsole, dabei kann ich helfen
      2. du installierst das Plugin enigma2-plugin-extensions-userscripts, damit kannst du die geblockte SD Karte im Gerätemanager anzeigen lassen. Dann kannst du bequem über die GUI die SD wie eine Festplatte initialisieren und einbinden. Wie du zu dem plugin kommst und bedienst, musst du selbst rausfinden. Ich supporte die Plugins von @gutemine aka 'Lost in Space' nicht mehr - das soll er/sie/es selbst machen, dafür gibt es ja nun ein eigenens Supportforum auf sourceforge.net. Aber das ist eine andere Geschichte und hat hier nichts verloren. Die Plugins sind zwar vielleicht nice to have, aber nicht unersetzlich und auch nicht zwingend erforderlich.
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox
    • Danke,

      hab die Karte jetzt gefunden. Jetzt hab ich versucht sie zu initialisieren, aber es klappt nicht. Es kommt folgende Fehlermeldung: „Es gab ein Problem während der Konfiguration der Festplatte“.

      Unter Aufnahmepfade ist sie nicht auszuwählen. :tischkante:


      Gruß
      Tom
      Gruß
      Tom73
    • Hallo zusammen,

      ich häng mich hier mal an. Seit 2 Tagen versuche ich die SD Karte nun zum Laufen zu bringen. Ich hab hier mehrere Threads durchforstet, bin genau nach der Anleitung gegangen, und eigentlich sollte es funktionieren, tut es aber nicht. Das User-Scripts-Plugin bekomme ich nicht installiert, aber es geht ja anscheinend auch anders.
      Ich muss vorausschicken, dass ich mit Linux bisher nichts zu tun hatte, aber ich bin steinalt und mit MSDOS aufgewachsen, also ein paar Grundbegriffe sind mir geläufig.

      Ich poste mal den Stand der Dinge:

      Source Code

      1. root@dreambox:~$ blkid
      2. /dev/dreambox-rootfs: LABEL="dreambox-rootfs" UUID="cb3eb1c0-535b-4856-bbd6-d3fae11239d8" TYPE="ext4"
      3. /dev/dreambox-data: LABEL="dreambox-data" UUID="ebdbe8a5-5d20-4fc1-a2fe-23873f14a99f" TYPE="ext4"
      4. /dev/mmcblk1: LABEL="sd" UUID="0397ae30-10b1-4370-8d31-b317bce55081" TYPE="ext4"
      5. root@dreambox:~$ blkid|grep mmcblk1
      6. /dev/mmcblk1: LABEL="sd" UUID="0397ae30-10b1-4370-8d31-b317bce55081" TYPE="ext4"
      7. root@dreambox:~$ parted /dev/mmcblk1 unit s print
      8. Model: SD SR64G (sd/mmc)
      9. Disk /dev/mmcblk1: 124735488s
      10. Sector size (logical/physical): 512B/512B
      11. Partition Table: loop
      12. Disk Flags:
      13. Number Start End Size File system Flags
      14. 1 0s 124735487s 124735488s ext4
      Display All

      Ich bin mir nicht ganz sicher, ob mit der Partition auf der SD Karte alles stimmt, oder fehlt eine Partition? Wenn ja, was muss ich eingeben?

      An der fstab hab ich auch schon rungefummelt (hat auch ne Zeit gedauert, bis ich wusste, wie ich das bewerkstellige, aber ich habs selbst hinbekommen):


      Source Code

      1. rootfs / rootfs rw,relatime 0 1
      2. proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
      3. sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
      4. devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620 0 0
      5. tmpfs /dev/shm tmpfs rw,nosuid,nodev,relatime 0 0
      6. tmpfs /run tmpfs rw,nosuid,nodev,relatime,mode=755 0 0
      7. tmpfs /tmp tmpfs rw,relatime 0 0
      8. tmpfs /var/volatile tmpfs rw,relatime,mode=755 0 0
      9. /dev/dreambox-data /data auto noauto,x-systemd.automount,nofail 0 0
      10. /dev/disk/by-uuid/0397ae30-10b1-4370-8d31-b317bce55081/media/sdcard auto auto,nofail 0 0
    • du hast das RAW Device formatiert, also keine Partiton erstellt - es fehlt mmcblk1p1
      müsste in etwa so aussehen

      Source Code

      1. root@dm900:~# blkid|grep mmcblk1
      2. /dev/mmcblk1p1: LABEL="sd-card" UUID="e6e1f2b7-0e33-41e9-9be0-75e88ffa5623" TYPE="ext4"
      3. /dev/mmcblk1: PTTYPE="dos"
      4. root@dm900:~# parted /dev/mmcblk1 unit s print
      5. Model: SD SC16G (sd/mmc)
      6. Disk /dev/mmcblk1: 31116288s
      7. Sector size (logical/physical): 512B/512B
      8. Partition Table: msdos
      9. Disk Flags:
      10. Number Start End Size Type File system Flags
      11. 1 2048s 31116287s 31114240s primary ext4
      12. root@dm900:~#
      Display All
      am besten mit dd die ersten 512byte der SD überschreiben und mit fdisk eine DOS Partitionstabelle (MBR) oder mit gdisk eine GPT erstellen
      dann eine Partition (/dev/mmcblk1p1) und die in ext4 etc. formatieren
      Gruß Fred

      Die Dreambox ist tot, es lebe die Dreambox
    • Danke dir!!!

      eigentlich sollte es jetzt passen:


      Source Code

      1. newnigma2@dreambox:~$ sudo blkid|grep mmcblk1
      2. Password:
      3. /dev/mmcblk1p1: UUID="2a5bd188-943c-d601-001b-d188943cd601" TYPE="ext4" PARTUUID="44658040-01"
      4. /dev/mmcblk1: PTUUID="44658040" PTTYPE="dos"
      5. newnigma2@dreambox:~$ sudo parted /dev/mmcblk1 unit s print
      6. Model: SD SR64G (sd/mmc)
      7. Disk /dev/mmcblk1: 124735488s
      8. Sector size (logical/physical): 512B/512B
      9. Partition Table: msdos
      10. Disk Flags:
      11. Number Start End Size Type File system Flags
      12. 1 2048s 124727295s 124725248s primary ext4
      Display All
      aber ich hatte heute nacht was aufgenommen, das finde ich aber nicht, ich hatte das noch nicht eingestellt

      Timer setzen
      Problem: Es wird ein Umschalt-Timer anstelle eines Aufnahme Timers gesetzt. Lösung: Unter Menü > Einstellungen > Kanäle und Aufnahmen > Aufnahmepfade alle Aufnahmepfade (außer Timeshift) auf /media/hdd/movie setzen

      mal sehen, obs jetzt klappt.

      manchmal wird mir im Gerätemanager bei der SD Karte auch angezeigt, dass das Dateisystem ungültig ist (oder so ähnlich), jetzt ist die Meldung wieder weg, ich mache einen Screenshot nächstes Mal. Ich nehme gerade noch was mit Timer auf, mal sehen, ob es diesmal klappt.

      The post was edited 2 times, last by Mostly Harmless ().

    • jetzt hats geklappt mit der Aufnahme, auch nach einem Neustart der Dreambox kam keine Meldung mehr, dass mit der SD was nicht stimmt.

      Eine letzte (?) Frage:

      muss das


      Source Code

      1. dev/disk/by-uuid/2a5bd188-943c-d601-001b-d188943cd601 /media/hdd auto auto,nofail 0 0
      aus der fbstat wieder raus?

      Danke dir nochmals!